Gtk3 installation

I'm trying to install gtk+-3.2.3 on Ubuntu natty. This is a fresh Ubuntu install with security updates only. I have not installed any new versions of gtk. I just have gtk2, that Ubuntu comes with....

XLib Error when compiling QT for ARM using linux-arm-gnueabi-g++

I am having some issues compiling a QT program from an i386 Ubuntu Linux PC to a Pandaboard. We were successful in creating a build which could create a console application from my PC to a...

Install Webkit for Standalone HTML Desktop App

A few months ago I converted my web application to run as a linux app (kind of, it's just in a web browser to give the illusion that it's a full fledged linux app) I made it on Ubuntu 14.04 and...

Can't install libgtk2.0-dev on linux

I am trying to compile xfce-terminal, configure will not pass saying I lack gtk2 checking for gtk+-2.0 >= 2.24.0... not found *** The required package gtk+-2.0 was not found on your system. ***...

Installing PhantomJS: went through build process, how to install?

EDIT: I dont think linked question answers my problem. Here's the summary When I do > ./phantomjs/bin/phantomjs phantomjs> # this is the phantomjs shell so it is working but when I do > ln -s...

Unable to compile xps after installing ROOT, missing libraries

I'm trying to install xps in R, and have installed ROOT from CERN. during compile I get: TMLMath.cxx:51:19: fatal error: TMath.h: No such file or directory #include "TMath.h" ...

Debian httpredir mirror system unreliable/unusable in Docker?

Short Version Debian's httpredir.debian.org mirror service causes my Docker builds to fail very frequently because apt-get can't download a package or connect to a server or things like that. Am I...

Use Jupyter together with file share or mounted folder

how can we synchronize notebooks between a jupyter service and other services (Google Cloud Storage or git repository)? Some background on this question: Currently I am on the way moving from...

R Shinyapp Error: compilation failed for package tkrplot

Why do I get these errors when I try to deploy my shinyApp? The issue seems to be the tkrplot package or .h file see bottom of output. Any pointers would be appreciated. (This would be my first...

configure settings for Installing Octave 4.0.3 in Ubuntu 16.04

So i am following steps to install the latest version of octave from here. sudo apt-get install g++ gcc gfortran make autoconf automake bison flex gperf gzip icoutils librsvg2-bin libtool perl...

Testing a dockerized Ruby on Rails app with MySQL on CircleCI

I am trying to use CircleCI with my Dockerized Ruby on Rails app. The app is set to use MySQL. Locally, everything works fine; RSpec passes, everything is great. When testing in CircleCI, I can't...

PhantomJS not loading webpages properly

The below R code to get website screenshots using RSelenium (1.4.5 from CRAN) and PhantomJs (1.9.8) works fine in Mac OS and Ubuntu 14 on AWS. But the webpage doesn't seem to load properly when...

Can't install cuDNN 5.1.5 with CUDA 8.0 and Tensorflow 0.12 on g2.2xlarge instance

The steps I've taken are below. During the ./configure step, unless I allow the system default for the cuDNN version (v5) instead of specifying v5.1.5 (as I want), I get an error saying that the...

How can I install pdal in python in a dockerfile?

I have my own dockerfile, which creates an image with python with gdal and several other packages: FROM geodata/gdal:2.1.2 USER root RUN apt-get update && apt-get install -y \ ...

Docker build fail

My docker build command fails with the message: Step 3/23 : RUN apt-get install vim -yqq cron -yqq python-software-properties -yqq supervisor -yqq python-dev -yqq python -yqq ...

How to use HIDAPI in Qt Creator?

I unpacked the entire hidapi-0.7.0 download (https://github.com/downloads/signal11/hidapi/hidapi-0.7.0.zip) into my project directory, then added hidapi-0.7.0/hidapi/hidapi.h and...

Prevent docker from building the image from scratch after making changes to the code

A docker newbie, trying to develop in a docker container; I have a problem which is every time I make a single line change of code and try to rerun the container, docker will rebuild the image...

Devise could not find the `Warden::Proxy` in docker

I found some SO answers about this problem. I have this error when I load the web from the Docker container. I tried what's is suggested...

docker alpine with node js and chromium headless - puppeter - failed to launch chrome

I'm trying to run a custom node command from within an Alpine linux docker container. Installed...

error running Julia on Ubuntu 16.04 docker for host with GPU

I'm stuck in getting Julia to run on Ubuntu 16.04 on a server having GPUs. Basically we want to utilise power of GPUs. We're using Docker image to host Julia, it's pulled from nvidia-cuda, the...

i am getting error The 'make' utility is missing from PATH when i am building Docker file

when i build docker file i am getting error as 'The make' utility is missing from PATH. This is my Docker file FROM python:3.6-alpine ...

Unable to Install Older Version of R

I am trying to install and older version of R (3.2.1), and am following the instructions on this page: https://www.miskatonic.org/2015/06/23/installing-r-from-source/ As suggested by the webpage,...

Failure to find x11 on nana cmake

I am loading up nana source in CLion and cmake gives me the an error saying x11 is set to NOTFOUND I have tried installing x11 dev libs on ubuntu but it has not helped :/ EDIT: I have fixed the...

How to install libgtk2-dev:i386 without removing libgtk2-dev:armhf? Or what to do to cross-compile for i386 and armhf?

I'm struggling trying to cross-compile a wxWidgets app for a BBB from a Debian 9 PC. After a lot of failures, i've found what seemed to be the solution: multiarch. So i added an armhf...

Unable to locate package openssl-dev

I'm trying to install the ROOT CERN packages on linux, using Ubuntu 18.04, and whenever I get into the prerequisites download, with this command: sudo apt-get install dpkg-dev cmake g++ gcc...