To install ia32-libs on debian wheezy amd64

I'm using Debian 7 (wheezy) amd64. uname -a Linux tzwm-debian 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64 GNU/Linux And I want to install ia32-libs in my Debian. But this happens when I try to...

Ubuntu install previous version of erlang solutions package

I am trying to create a fabric script that will install the erlang solutions R15B02 package and am having some difficulty. I have the following code in my fabric script: sudo("apt-get update") ...

Qt: How to find text, while the criteria is in a QStringList?

I load a file with QTextStream, then read it line by line with readLine. Then I want to get the line which have some keywords. Then, I remove the keywords from each line, so I will get entire line...

ninja_syntax missing when trying to build chromium arc

I am trying to build arc on ubuntu 14.04 but I get the following error: ➜ arc git:(master) ✗ ./configure Traceback (most recent call last): File "src/build/configure.py", line 17, in...

Why install :i386 packages?

i use xubuntu 12.04 amd64 and today i try to install wine: sudo aptitude install wine Следующие НОВЫЕ пакеты будут установлены: attr{a}...

Dependency Issues in Ubuntu - I've Tried Everything

So I recently installed Ubuntu 14.04 as my primary operating system. I have toyed with Ubuntu for years but have never had these kinds of issues to this degree at least. What's happening is that...

Ubuntu / DigitalOcean - Unable to fetch packages to install git on a fresh install

Just started with a fresh install of Ubuntu 14.04 on my digitalocean droplet and I'm trying to install git. My first attempt failed to install some packages - [email protected]:~# sudo apt-get install...

Net::HTTPServerException causing Chef to fail

I'm attempting to set up a Rails environment with Vagrant and Chef by following this guide. I've used it in the past with success. When I run vagrant up it fails, and (I think) this is the...

Error while installing java in ubuntu 16.04 having Cyberoam Client installed

I'm using Ubuntu 16.04 OS and also linked my pc with Cyberoam client for the security purpose. I'm trying to install java for Android Studio in it and I'm getting following error in terminal...

Dockerizing kafka gives non zero exit code

I am a newbie trying to learn docker. I am trying to dockerize kafka installation and stuck with a non zero exit code. I would like to debug the issue and find out the reason. How to debug a...

Sublime Text 3 installation with GTK library fails on AWS Ubuntu 16.04.03 instance

I tried to install Sublime Text 3 on an AWS Ubuntu 16.04.3 LTS instance according to the instructions provided by the link: Install Sublime Text 3 in Ubuntu 16.04 & Higher The Official Way. After...

Make .deb for JDK8 with JavaPackage

I'm trying to install JDK8 on Debian Stretch. The recommended way is to use JavaPackage. I have successfully packaged JDK6 and JDK7 using this method: Download the JDK archive from...

How to resolve issue related to installing Java 8 on Debian 8 (Jessie)?

I'm a Linux noob, and I trying to follow a variety of articles on installing Java 8 on Debian 8...

Can apt-get autoremove remove system files?

I tried to install Python 3 on my Ubuntu 16.04.4 LTS and while using apt i found this: The following packages were automatically installed and are no longer required: cabextract gcc-5-base:i386...

How to minimize an ubuntu docker image which needs only git, cron and openjdk-8-jre

Testing some docker project so after playing with alpine, I would like to use ubuntu:bionic for production. I decided to roll out my own image but the problem is that it's 600MB+ . REPOSITORY ...

How to install libgtk2-dev:i386 without removing libgtk2-dev:armhf? Or what to do to cross-compile for i386 and armhf?

I'm struggling trying to cross-compile a wxWidgets app for a BBB from a Debian 9 PC. After a lot of failures, i've found what seemed to be the solution: multiarch. So i added an armhf...

how to fix php-gd failing to install debian

i know this question has already been asked, but it didn't have an answer that worked for me and i cannot comment as i do not have enough reputation. I'm not able to install php-gd extension on my...

Permission denied when restoring cache in CircleCi job

Whenever my job run, they always take around 40s to download and install libreoffice. I'm gonna to store this into cache and restore cache to reuse it in next job. - restore_cache: ...

ModuleNotFoundError: No module named 'bs4' in heroku

I'm trying to use beautifulsoup to make a line bot and push the code to Heroku. My code can run in local but after pushed to Heroku it had the following error: 2019-11-30T13:31:11.000000+00:00...

Failed to deploy Nightmarejs app to Heroku

EDIT - 1/6/2020 My solution finally is moving to puppeteer.js, deployed to Heroku with zero problems, and took me 15 min the change the code since the API is similar. so if anyone gets those...

Running apt-get install within Docker container: "Unable to connect to deb.debian.org" part-way through installing dependencies

I'm trying to build a docker container on a Raspberry Pi 3B. I need to install gpac for MP4Box. Dockerfile FROM python:3.8-buster RUN apt update && apt install curl gpac -y ENV...

Heroku requirements.txt dependencies not installing, returning ImportError: No module named selenium

I'm trying to deploy a Python script on Heroku that utilizes Selenium. I have my Python script file, Procfile, requirements.txt(created via pipfreeze), and runtime.txt files all created in my root...

Mongoose query/schema error only in docker container

I have a MongoDB database which I am querying with Mongoose. I am using a collection audits to store information about update changes, failed logins and errors. Audit Model const mongoose =...

NPM requires x11 during installation via apt

I running Ubuntu server 20.04 and i need to install npm. But when i run "apt install npm" i see x11 packages in requirements. The following NEW packages will be installed: gyp javascript-common...