debian apt packages hash sum mismatch

From the Debian command line, I'm getting a hash sum mismatch after executing aptitude update; aptitude upgrade. Below is the command line output. I've tried an aptitude clean, but this does not...

Installing MariaDB: unmet dependencies, mariadb-server-10.0

ubuntu:~$ sudo apt-get install mariadb-server Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that...

xpath query on Linux command line

I am trying to use xpath queries on stack exchange data. The xml file has the following structure. <posts> <row Id="2" PostTypeId="1" Body="some text goes here" ..... /> </posts> According...

In a Dockerfile, How to update PATH environment variable?

I have a dockerfile that download and builds GTK from source, but the following line is not updating my image's environment variable: RUN PATH="/opt/gtk/bin:$PATH" RUN export PATH I read that...

Install pip in docker

I'm not able to install pip in Docker. Here's my Dockerfile: FROM ubuntu:14.04 # Install dependencies RUN apt-get update -y RUN apt-get install -y git curl apache2 php5 libapache2-mod-php5...

docker alpine with node js and chromium headless - puppeter - failed to launch chrome

I'm trying to run a custom node command from within an Alpine linux docker container. Installed...

Scrapy: ImportError: No module named scrapy_proxies

I have installed scrapy_proxies with pip install scrapy_proxies. But whenever I run my spider I get the following error log: scrapy crawl event -o items_new.csv 2018-09-13 01:15:19...

R hangs when ncdf4 nc_open is called in HPC cluster

I have started using R (R/3.5.1-foss-2018b) on an HPC server. It seems to work fine except when it has to deal with NetCDF files. I am using the nc_open function from ncdf4 package to read...

How can I efficiently convert gtts audio into pydub audiosegments?

I want to manipulate gtts audio in pydub but I am not sure how to translate gtts file like to pydub audio. I know that I can convert google text to speech audio to an mp3 and I know that I can...

How to apt-get install in a GitHub Actions workflow?

In the new GitHub Actions, I am trying to install a package in order to use it in one of the next steps. name: CI on: [push, pull_request] jobs: translations: runs-on: ubuntu-latest ...

No module named 'matplotlib.artist'

I faced with this error No module named 'matplotlib.artist' here is the complete error: --------------------------------------------------------------------------- ModuleNotFoundError ...

Windows authentication in linux docker container

i am trying to use windows authentication in linux docker container under kubernetes. I am following this settings:...

Certificate / SSL connection problem in docker build on macOS

I am building a docker image on macOS. This is the part of my Dockerfile: FROM ubuntu:18.04 # Dir you need to override to keep data on reboot/new container: VOLUME /var/lib/mysql #VOLUME...

Error "Running as root without --no-sandbox is not supported"

I try to implement scrapy-puppeteer library for my project (https://pypi.org/project/scrapy-puppeteer/) I implement PuppeteerMiddleware according to documentation from library Here is code which I...

Issue creating OSM tile server using Docker

I'm using OpenStreetMap tile server @ the https://github.com/Overv/openstreetmap-tile-server to host my own tile server. I run the container with the following command and it runs without error,...

No module named 'wsgi' on docker

I'm trying test flask + uwsgi on docker. Here is my Dockerfile: FROM --platform=linux/amd64 python:3.8.3-buster as build WORKDIR /opt/test_apis COPY requirements.txt /opt/test_apis RUN pip3 wheel...

Wordpress and Woocommerce installation with docker

Good morning, I'm trying to create an installation of wordpress with woocommerce already installed and active using docker-compose file with 2 containers, one with mysql taken from bitnami...

How to loop through start urls in csv file scrapy

So basically it worked for some reason the first time I ran the spider but after that its only scraping one URL. -My program is grabbing the parts i want to scrape from a list. -Converts the list...

Error installing tidyr on Ubuntu 18.04 & R 4.0.2

In trying to install the package tidyverse, I get errors in the installation of dependency tidyr. Here is the tail of the message I get: cpp11.cpp:31:100: error: ‘unmove’ is not a member of...

Can't install tidyverse on latest version of Linux Mint

So here is a snippet of the error message: **cpp11.cpp:24:409: error: ‘unmove’ is not a member of ‘cpp11’ 24 | return...

I built a docker image but got an error: returned a non-zero code: 1

EDIT log after Dockerfile correction (add -y parameters) C:\Users\jl3.PRT-063\Desktop\Docker>docker build -t ocr-docker-build-starwars . Sending build context to Docker daemon 3.072kB Step 1/8 :...

AttributeError: 'NoneType' object has no attribute 'strip' - Scrapy doesn't crawl all the elements

My spider doesn't crawl all the elements. As I can see now, one of the errors is an attribute error which I don't know how to fix it. This is a non-English website that I want its numbers to be...

Hot Reload HMR Webpack not working on Docker Container WSL2

To preface, I am new to Docker. I created my own docker container for my local development environment for a project I am working on using Intertia.JS + Laravel Jetstream in Ubuntu on WSL 2. I am...

Scrapy - TypeError: can only concatenate str (not "list") to str

While I try to gather a list of URL from a website and put them to combine with a base URL, then continue it inside the page. Once combine and will crawl those Url 1 by 1 then crawl the details of...

It seems that scikit-learn has not been built correctly

I have been using Jupyter Notebook for my machine learning project. Before scikit-learn was working fine but eventually I installed pip install imblearn and pip install -U imbalanced-learn after...

Getting errror When install Postgis in Postgresql 14 from source

I'm trying to install Postgis. I have install prerequisite: Geos 3.5.6 Proj 7.0.0 Jsonc 0.15 gDal 3.0.0 This is logs when Configure Postgis: ./configure --prefix=/opt/postgis...

Showing multiple errors while upgrading php-5.6 to 7.3 in centOS 6.9 (Final)

I'm trying to upgrade my php version 5.6 to 7.3 on centOS 6.9. I follow this. Everything works fine but i'm getting package errors while running following command- sudo yum install php php-common...

Can not get asdf-direnv work in docker when building

I'm trying to use asdf-direnv in docker. Following the README of asdf-direnv, I make this Dockerfile FROM nvidia/cuda:10.2-devel-ubuntu18.04 RUN chsh -s /bin/bash SHELL ["/bin/bash", "-ic",...

Bokeh/panel won't render in-line with Jupyter Lab

I'm trying to visualize Bokeh plots and panels with a Bokeh backend in a notebook in JupyterLab. Things were running fine until I updated. Current packages and versions are below I have tried the...

Docker with sqlsrv php73 extension failing to load

I made a docker LAMP Stack Container including PHP7.3 and some extensions that I need to run my web application on. Recently I needed to include the sqlsrv extension to establish a connection to a...