Define a default namespace for use in XSL XPaths with xpath-default-namespace

I have this simple xml document: <?xml version='1.0' encoding='UTF-8'?> <registry xmlns="http://www.iana.org/assignments" id="character-sets"> ...

my xsl transform is outputting malformed input tags

I am working on a transform that inputs an XML file and outputs an html form for ordering groceries. I'm using the linux xmlstarlet utility (which uses libxml2 and libxslt1.1) transform the...

PHP5 xsl install

just a quick question, Im running PHP5 on my debian server (squeeze), due to some magento extension requirement, I need to install the php5-xls module, this is a PRODUCTION ENVIRONMENT, so, after...

Unable to install Ruby gem unf_ext 0.7.4 on Ubuntu

I am having a hell of a time installing unf_ext 0.7.4 on Ubuntu. I've tried every form of Google searching you can possibly imagined and installed almost everything I could think of, here's what...

Wrap everything between two tag occurrences with XSLT 1.0

I want to split an XML (actually, XHTML) document in sections by the top-level h1 tags. Everything starting at the first of <h1> up to the next one should be wrapped in <section>...

what does "can not write log (is /dev/pts mounted") mean in apt-get in Ubuntu-on-Windows?

What exactly does the error message beginning with E: mean? I assume it has to do with the file structure on Ubuntu-on-Windows, but what exactly? The following package was automatically installed...

Trying to add libxslt to Docker Container

I've getting started with Docker, using the LAMP repo from GitHub as my starting point. I need to add the libxslt lib. I've tried adding this to my Dockerfile: RUN apt-get install libxslt-dev RUN...

Compile the most recent version of a package in an old system for local use

=) I've got a doubt, maybe someone can help me, thanks in advance ;) I need to know if it is possible to compile the best and newest package in an old, ancient system. Why? Well I'm limited at my...

Getting Python to wait for apt-get install

I'm trying to write a Python script that installs some packages but unfortunately it's not playing friendly with Ubuntu's apt-get install. Here's my code: subprocess.Popen( 'sudo apt-get...

Python Libxml2 parseFile intermittently fails after OS upgrade

We have a set of legacy python web applications that have been running on a Debian Lenny (production) server for years. We have recently cloned that server and upgraded the clone to Wheezy. The...

Unable to install protobuf in https://colab.research.google.com

I am trying to install apt-get install protobuf-compiler python-pil python-lxml in https://colab.research.google.com: Reading package lists... Done Building dependency tree Reading state...

How to install a package on Debian 8 Jessie running systemd without starting up the service?

I have ansible provisioning HAProxy and Nginx onto a Debian 8 running systemd in a Virtualbox VM. The problem is that Nginx installation fails, because of a port conflict. HAProxy installs first...

Nginx wont install due to being unable to make backup link

I am attempting to simply install nginx on a raw ubuntu box. I using vagrant and issuing ''vagrant up'' to ubuntu/trusty64 and then attempting to install nginx. It is giving this error: unable...

64bit debian and 32bit Wine

I'm trying to install 32bit Wine on 64bit Debian Jessie. I've tried suggestions...

Packages have unmet dependencies

So I understand that there are quite a few different posts about this topic. I have been to all of them and none of them are helping me with this problem. Could someone please help me out? Thank...

Building docker image with TeXLive 2017 and latexml

I am trying to make a docker image with full TeXLive 2017 and latexml for compiling latex to pdf and also converting latex to html. I believe this would be a useful tool. Here is my...

error setting up nginx provisioning on vagrant with virtualbox on Ubuntu

I have installed Vagrant and Virtualbox on Ubuntu 16.04 LTS, with apt-get repositories fully updated. I have port forwarding set up for 'guest:80 host:8080', and a bootstrap.sh file requiring...

Python Zipp incompatibility when creating venv using Ansible

I am currently working on rewriting an old tool that uses ansible to create a virtual environment in which it hosts a python based app. The failing playbook is as follows: ``` - name: Ensure bash,...

AWS/Ubuntu archive server appears to be down?

I am brand new to both AWS and nginx (OSS version). I just created my free-tier (micro t2) EC2 Ubuntu instance and am trying to install nginx on it. So I run sudo apt-get upgrade and then sudo...

Update R version from 3.0.3 to 3.1.2

I want to update R with ubuntu from 3.0.3 to 3.1.2. I am working on Ubuntu 14.04LTS, 64bits. I did the following: cd /etc/apt/ sudo gedit sources.list I added the following line : deb...

I built a docker image but got an error: returned a non-zero code: 1

EDIT log after Dockerfile correction (add -y parameters) C:\Users\jl3.PRT-063\Desktop\Docker>docker build -t ocr-docker-build-starwars . Sending build context to Docker daemon 3.072kB Step 1/8...

Could not install mysql-server using Ubuntu 14.04

I am facing one issue. I am trying to install mysql-client mysql-server using below command. sudo apt-get install mysql-client mysql-server libmysqlclient-dev But here I am guessing that its...

Can apt-get autoremove remove system files?

I tried to install Python 3 on my Ubuntu 16.04.4 LTS and while using apt i found this: The following packages were automatically installed and are no longer required: cabextract gcc-5-base:i386...

Laravel - not connection to DB on docker

I'm trying to run Laravel with postgres db. Docker build works fine I have access to app thru url and can connect to db. But laravel cant establish connection to db. My connection to db using...

Error while installing java in ubuntu 16.04 having Cyberoam Client installed

I'm using Ubuntu 16.04 OS and also linked my pc with Cyberoam client for the security purpose. I'm trying to install java for Android Studio in it and I'm getting following error in terminal : >...

vagrant-berkshelf plugin compilation (installation) error

enclosed a snippet of my console: release version: $ sudo cat /etc/*release* | grep -i distrib DISTRIB_ID=Ubuntu DISTRIB_RELEASE=13.10 DISTRIB_CODENAME=saucy DISTRIB_DESCRIPTION="Ubuntu...

Can't install java 8 on linux mint

Linux Mint 19.3 I need to install jdk 8. I try this: sudo apt update result: Ign:1 http://mirrors.evowise.com/linuxmint/packages tricia InRelease Hit:2...

Building PySide for Android error: 'getWrapperForQObject' is not a member of 'PySide'

I am following the PySide for Android guide under Xubuntu 14.04 for which I ran the following commands: wget...

Can only run uwsgi with root

I'm preparing to use nginx/uwsgi with flask for a website i'm developing, but i'm running into problems. NB the website itself runs great using flask's debug :5000 port, but i want to go into...

How to install redmine with Chef

I try to install Redmine via APT and Chef but it does not work. I always get the error Could not find gem 'rails (~> 4.2.7)' in any of the gem sources listed in your Gemfile. It seems...