how to install postgresql for mac os x

I use homebrew,write this order to terminal.app to install postgresql. `brew install postgresql` <pre>==> Installing postgresql dependency: ossp-uuid ==> Downloading...

YUM complains about PyYAML and libyaml in CentOS 5.8

Every single time I try to #sudo yum update, I get warnings that PyYAML-3.08-4.el5.x86_64 is missing a dependency, libyaml-0.so.1()(64bit). So I did some checks, and it appears that libyaml is...

Ansible : define when a command doesn't have to run (building ruby from source)

Here is the section of my playbook responsible for downloading and building ruby from source : vars: ruby_version: '2.0.0-p247' ruby_url: 'ftp://ftp.ruby-lang.org//pub/ruby/2.0/ruby-{{...

OTRS installation error on openSUSE

I have a fresh, text-only installation of openSuSe 13.1 (physical server, old Samsung netbook), and I'm trying to get OTRS up and running. I've installed OTRS using the below commands. I don't...

Error occurred while installing openstack after setting FORCE=yes

I tried installing openstack through devstack using the following commands $ git clone https://github.com/openstack-dev/devstack.git -b stable/havana devstack/ i followed this link to do it. In...

OTRS install on ubuntu

I'm trying to install OTRS on ubuntu with the following shell script, but when installation finished I couldn't reach the installer.pl file on the webserver, and got the following error: error:...

how to fix Homebrew permissions? (extra tough case)

I'm trying to fix my permissions for OSX Homebrew, but I'm still getting Error: Permission denied - /usr/local/opt Here's what I've tried so far. I followed the instructions at...

Invalid access to memory location on 64-bit Strawberry Perl only

Hi I am trying to get a Perl program running on Windows 64-bit using Strawberry Perl version 5.20, the 64-bit version. I have no problems running the 32-bit version (32-bit Strawberry Perl on...

Ubuntu / DigitalOcean - Unable to fetch packages to install git on a fresh install

Just started with a fresh install of Ubuntu 14.04 on my digitalocean droplet and I'm trying to install git. My first attempt failed to install some packages - [email protected]:~# sudo apt-get install...

How to install php yaml on CentOs?

On the start I was getting this error: Call to undefined function yaml_parse_file() I have tried everything what I have found over google: yum install libyaml yum install yaml yum install...

Why do I get a E474: Invalid Argument history=... when I set a history size greater than 10000?

In my .vimrc I am trying to set a very large history size. But whenever I try a number greater than 10,000, I get an invalid argument error like: E474: Invalid argument: history=10001 It works...

installing hhvm on centOS 7.2 With Apache 2.4

I've been looking into this and I have some questions about it. As far as I understand, hhvm is a framework developed by facebook to support the "hack" and "php" languages. If I install this in...

How do I download an ubuntu dsc file?

I am trying to implement a work around with git. In order to do so I am going to this page LaunchPad Git and am attempting to download this file git_2.10.2-2.dsc. I need this specific file in...

Setting up Vagrant for django tutorial

I have found a django beginner+ tutorial. However, I encountered an issue I can't resolve by myself. First I changed all precise64 to precise32, because even if I run 64 bit Xubuntu 16.04, my...

Post install script: OpenSSH fails

I am currently working on a post install script for servers (mostly for myself, since I know what I need/want), targeting debian 8. But I have issues by make OpenSSH. First of...

How to fix broken apt-get on debian wheezy?

I'm using a debian wheezy at work. Packages are held in specific versions. My /etc/apt/sources.list contains lines like : deb http://mycompany.com/debian/debian-main/ wheezy main non-free...

Install multiple yum packages on Centos(node) via Ansible?

Here is the part of YAMLcode that i am trying to run on a node which has operating system, Centos-7...... file hierarchy is --> roles/install_tools/tasks/main.yml its not working fine, YAML syntax...

I am trying to install my ejabberd from dockerfile , image is building succesfully but when i hit the run command container exits immediately

After running the container it exits immediately. How am i suppose to keep this container and ejabberd running? What changes should i make in dockerfile? Any help is appreciated. Here is my...

brew install vim --with-lua is failing

I'm using Mac OS Sierra and trying to install vim with lua brew uninstall vim brew install vim --with-lua It gives me error that a library is missing but i can't find how to install it. env...

Errors when starting vim with the Quramy/tsuquyomi plugin

I use the Quramy/tsuquyomi plugin on my laptop and everything is working well. Today I installed it on my desktop (macOS Sierra the same as on the laptop) and I get the errors when starting the...

How can I get Vim to recognize Python3 syntax?

I've scoured related posts and have tried several things, but I'm still receiving a syntax error in Vim when using Python3 syntax. The code that is receiving the error: types_of_people = 10;...

Vim: running `:Explore` (netrw) results in "E492: Not an editor command: Explore"

I can't use :Explore, :Sexplore, et al in both vim or neovim. When I try, I get E492: Not an editor command: Explore. I know it's a problem with my vimrc, because :Explore works when I run vim -u...

Can't install nokogiri with bundle when build docker container in archlinux

Never was, and here again. ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-linux] Bundler version 1.16.2 Archlinux updated 4.17.4-1 x86_64 Pure ruby project I can install nokogiri with gem...

Rails & Docker: configure bundler to run bundle install in a docker build for Rails.4.2.6?

I am having so much trouble with docker. It seems to be a pattern. I have a dockerfile which installs Node.js and Yarn from source repositories fine. I install ruby from the get-apt repositories...

Why does pip consistently fail to install pytest-django? .dist-info directory not found error

I have a docker container setup that keeps failing to install this pytest-django==3.4.8 from requirements.txt. If I comment it out everything else installs correctly. Tried everything from tearing...

Powerline with Vim with ImportError: can't find appropriate configuration

I've been trying to get powerline working for awhile and I can't seem to figure out what is wrong. I often use vim inside of tmux, but the error is the same inside of tmux and out. This is the...

Mysql will not install due to mariadb install but mariadb is not installed

Been trying for hours to get mysql installed but it failed due to a conflict. This is a brand newly installed CentOS 8 x64 (latest) and it's fully updated. There are no custom packages installed...

Perl throws "Can't locate Config/YAML.pm in @INC"

I'm getting Can't locate Config/YAML.pm in @INC (you may need to install the Config::YAML module) while running a perl script. Can't locate Config/YAML.pm in @INC (you may need to install...

Linking pyenv python to homebrew in order to avoid homebrew [email protected] installation

Some packages from brew require [email protected] as a dependency. For example: $ brew deps vim gdbm gettext libyaml lua [email protected] perl [email protected] readline ruby sqlite xz However, I want to manage all...

Git, fatal: unable to access 'https://github.com/path/to/repo.git': gnutls_handshake() failed: Error in the pull function

OS: Ubuntu 18.04.1 in a windows VirtualBox (the Stanford CS144 lab VM) (and I am not a Stanford student doing homework, just for fun) Git Version: 2.32.0 And when I run this: $ git push -u...