what is arm-linux-gcc and how to install this in ubuntu

In compiling qt I found that there is a qws target called arm-linux-gcc. I looked around a bit but unable to figure out how and where to find this. I tried installing and apt-cache gave me...

Installing MariaDB: unmet dependencies, mariadb-server-10.0

ubuntu:~$ sudo apt-get install mariadb-server Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that...

Install pip in docker

I'm not able to install pip in Docker. Here's my Dockerfile: FROM ubuntu:14.04 # Install dependencies RUN apt-get update -y RUN apt-get install -y git curl apache2 php5 libapache2-mod-php5...

Mosquitto Auth Plugin with Openssl issue on raspberry pi

I have first created a user for mosquitto: sudo adduser --system -no-create-home mosquitto Then I installed some dependencies: sudo apt-get install libc-ares-dev libcurl4-openssl-dev...

Karma Chrome Headless not working on Jenkins

When I run the below setup with Docker locally on my mac everything works fine. But same setup does not work on Jenkins running on Ubuntu 16.04 ChromiumHeadless have not captured in 60000 ms,...

"fatal error: bits/libc-header-start.h: No such file or directory" while compiling HTK

I'm getting the following issue when trying to run make on the HTK library: (cd HTKLib && make HTKLib.a) \ || case "" in *k*) fail=yes;; *) exit 1;; esac; make[1]: Entering directory...

Docker build php on alpine image with curl support failed. How I can solve it?

I try to install curl support to php on a php:7-fpm-alpine image. Therefore I utilize the following Dockerfile: FROM php:7-fpm-alpine RUN apk add --update libzip-dev libcurl &&\ ...

Issue installing python3-dev on fresh install of Ubuntu 18.04 in Vagrant box

My Vagrantfile is as follows: # -*- mode: ruby -*- # vi: set ft=ruby : # Set Vagrant Minimum Version Vagrant.configure("2") do |config| config.vm.box = "bento/ubuntu-18.04" ...

Failed to install gcc on Python-3.7-alpine docker container

I am trying to set up a Python docker container, when I run the command "docker-compose up" to build the Dockerfile it throws me this error message below. The docker file was successfully built...

Unable to install sklearn when building docker image

When I try to install sklearn (scikit-learn) when building a docker image, it fails. These are the processed lines of the Dockerfile: FROM amancevice/pandas:0.25.0-alpine RUN apk update RUN apk...

Can't upgrade NVidia packages

I want to upgrade my Ubuntu from 19.04 to 20.04, but it's not possible until I update all my packages. ❯ sudo do-release-upgrade Checking for a new Ubuntu release Your Ubuntu release is not...

How can i resolve this issue: ERROR: unsatisfiable constraints: postgresql-client (missing): required by: world[postgresql-client]?

Please, can someone help me? I just started learning Django-REST-API using Docker. I want to install postgresql-11-alpine but i keep getting this error messages when i run; docker-compose...

squashfs error when running singularity after Ubuntu upgrade

Overview: I am working with code in a singularity image on a machine running Ubuntu 18.04. It was working (well, I was debugging the code) as of Tuesday evening on machine A. I ran an update and...

How do I deal with an internal compiler error (cc1plus: gimplify) when installing c based python libraries (OpenCV2) on a Raspberry PI?

I've been trying to install the OpenCV2 libraries for Python 3 on my Raspberry PI 3B. I started this process by installing Python 3 through apt and using pip3 to install OpenCV. However the...

How to properly configure Django Channels in production using AWS, Docker, Nginx + Daphne?

We are attempting to configure a live-chat on our website, through the use of Django Channels 2, AWS, and Nginx + Daphne. Our setup works fine running locally, however we are running in to issues...

Yocto SDK missing kernel header files

I have a kernel module that I have successfully compiled against my toolchain and installed in the image. The driver loads just fine and functions as expected. The user program that uses the...

How to solve libpq.so.5 Import error when running postgresql on alpine in docker

Hi I am trying to run postgresql in alpine in docker with SQLAlchemy and flask but anytime I run my app I get this error ImportError: Error loading shared library libpq.so.5: No such file or...

docker python flask gets " Do you want to continue" then "executor failed"

Trying a simple python flask web app in docker 20.10.2, build 2291f61. Doing the: docker build -t hello-world . starts out ok (please see below), but ends with: #6 2.866 After this operation, 305...

Problem installing nodejs version >= 10 on Linux Mint 19.3, which stubbornly installs nodejs 8.10

Trying to use https://github.com/nodesource/distributions/blob/master/README.md to install nodejs in version higher than 10 ( and then npm) on Linux Mint 19.3. It stubbornly installs the 8.10...

multiple applicable items in scope

I'm using Ubuntu 20.04.2.0-desktop-amd64 , Substrate 3.0.0 Version: [email protected]:~$ rustup show Default host: x86_64-unknown-linux-gnu rustup home: /home/gh/.rustup installed...

Django/Docker/Postgresql - psycopg2 error

hope you can help me with my following issues. This is my first time using docker and docker-compose. I'm trying to "dockerize" my Django project running on Postgresql database and I'm having an...

Missing OCI support when building GDAL

So I am building a DOTNET application that runs on Debian, and makes use of ogr2ogr to copy data from an oracle database towards an Postgres database. The problem is that I cannot get GDAL to...

Static Nginx with Modsecurity

Trying to add Modsecurity v3.0.4 in to Nginx v1.19.9 but running in to some errors I do not understand. There are MANY errors similar to the ones I pasted below but did not include them all. My...

Laravel + PHP 8 fpm SIGSEGV (signal 11)

Really strange thing happening on PHP 8 fpm (using anything Eloquent triggers it) and unable to debug the coredump (PHP 7.3 is ok) Environment is Debian 10 (Vagrant VM and also DO...

Install Python pip in ubuntu using ansible

I am trying to install Python-pip in ubuntu using ansible and then installing python package, But I am getting following error during Python package install task: failed: [X.X.X.X]...

No symbols in google breakpad stack trace when applying compiler optimizations

The main point of a crash reporter tool like Google breakpad is to generate core dump or minidump files from stripped binaries to process later with debugging symbols. normally these binaries are...

pip install py-find-1st fails on ubuntu20 & centos with python3.9

This is my process. I start a new aws t2.micro ec2 on ubuntu20 and run this script sudo apt-get update sudo apt-get install gcc sudo apt-get install python3.9 sudo apt-get install...

Docker failed with [Makefile:192: imagick_file.lo] Error 127

I try to install php in docker of w2orking project with header in Dockerfile : FROM composer:1 AS composer FROM php:7.4-fpm-alpine COPY --from=composer /usr/bin/composer /usr/bin/composer ENV...

GCP Compute Engine VM startup-script and SSH Breaks after `apt-get update`

To install git on e2-medium (2 vCPUs, 4 GB memory) Debian GNU/Linux 10 (buster) instances, we run the following script defined in the startup-script-url as per the instructions seen here: GCP...

Impossible to install php-gd on docker alpine version 3.14 or newest

I trying to build gd on PHP container and it's impossible to build it with alpine version 3.14 or 3.15, but work's fine with alpine 3.13. My Dockerfile FROM php:8.0-fpm-alpine RUN apk add...