Webpack Failed to Compile Simple Application

I am new to node and webpack. I am trying to setup a simple application. I am unable to get webpack to successfully compile the application. I have been struggling with this for several days. ...

NPM still gives warnings, npm audix fix not working

My project's package.json dependencies: "dependencies": { "@babel/cli": "^7.0.0-beta.51", "@babel/core": "^7.0.0-beta.51", "@babel/preset-env": "^7.0.0-beta.51", "babel-loader":...

How to install Gulp.js v4 globally with Yarn?

I installed Gulp.js globally with Yarn: $ yarn global add gulp --no-bin-links yarn global v1.17.3 [1/4] Resolving packages... warning gulp > glob-watcher > anymatch > micromatch > snapdragon >...

Angular upgrade from 8 to 9 - yarn incompatible error

I've upgraded the project from 8 to 9 as per angular.io upgrade guide But after the upgrade yarn install is giving this error. Does anyone know how to solve this? Error: error...

How do I fix the security vulnerabilites in my Gatsby Dev Blog?

I have a dev blog, and I'm seeing 14 security alerts, with some of them have high severity, critical severity, and moderate severity. So, I ran npm audit to see the problem, and it gave me...

webpack compile gives ts-loader error on new computer

I have just set up a new laptop, checked out my sources run npm install as is the norm. Then ran webpack build thus: npm run clean && npm run scss && webpack --bail --progress --profile I then get...

NPM build issue with webpack-dev-server

I'm hoping someone can advise on a problem with NPM building that resulted from trying to use an old version of webpack-dev-server. I'm following a React tutorial and using the old versions of...

Yarn is unable to upgrade, why?

error An unexpected error occurred: "EACCES: permission denied, unlink '/home/ubuntu/environment/sample_app/node_modules/.bin/acorn'". this is what the file looks like: #!/usr/bin/env node 'use...

react-native init SampleApp Project creation error

I was trying to create a project for react-native but I am getting this error. D:\Projects\PoC\ReactNative>react-native init TravelApp This will walk you through creating a new React Native...

Ruby Version Failure 2.7.0: Error: Permission denied @ apply2files - /usr/local/share/Library/

As the title states, when I try install Ruby version 2.7.0 with rvm install ruby-2.7.0, I get the following output: Ruby Version Failure 2.7.0: Error: Permission denied @ apply2files -...

Why my package.json file shows react-native": "https://github.com/expo/react-native/archive/sdk-38.0.2.tar.gz" instead of react-native version

Why my package.json file shows react-native: "https://github.com/expo/react-native/archive/sdk-38.0.2.tar.gz" instead of a react-native version like react-native: 0.60. Because of this I'm...

unable to upgrade yarn package or dependencies (semantic-ui/rails)

I would like to upgrade to the latest version of Semantic UI to see if some issues regarding content security policy have been fixed. I type yarn upgrade semantic-ui to upgrade, and get the...

Node, Yarn, Javascript - Error installing setprotocol dependencies

I am getting following error when adding a "setprotocol.js" dependency using Yarn (yarn add setprotocol.js) to my project. I am not familiar with Node or Yarn. I ran into this error when following...

After command yarn global add @vue/cli vue is not found in my OS

I want to move to vuejs 3 and tried to create new vuejs 3 app and got error that vue is not found. I do : $ npm -version 6.14.8 $ nodejs --version v14.12.0 $ cd ../ $ yarn global add...

when I install jupyterlab-kite build error

OS: Mac OS python: Python 3.7.3 (default, Mar 27 2019, 16:54:48) [Clang 4.0.1 (tags/RELEASE_401/final)] :: Anaconda, Inc. on darwin pip: pip 19.0.3 from...

A regex for NPM or any other package both for name and any version number

I search on SO and on google a good validation regex to detect FULL NPM / other package name (package name(@)version number - all formats). Now, before you mark this question as duplicate, I must...

i am not able to create a new react app i get these errors below i belive i have everythig up to date

F:\Web-Development>npx create-react-app portfolio-site Creating a new React app in F:\Web-Development\portfolio-site. Installing packages. This might take a couple of minutes. Installing react,...

jhipster vue npm audit fix --force error I don't know what to do, please help me

I created the project with jhipster when I installed npm failed to perform a repair log as follows I don't know what to do, please help me npm audit fix --force log npm WARN using --force...

yarn add react-native whern creating a project via npx

So I have npm 7.5.3 and node v15.8.0 on my ubuntu system. I'm trying to create a react-native project as follows: npx react-native init Sample And I get a large error dump with the following...

**node-sass: Command failed** when rails new APP_PATH

I am trying to build a new rails app, with the following versions installed: node v15.6.0 npm v7.4.0 yarn v1.22.10 ruby 3.0.0 Rails 6.0.3.4 when I run rails new APP_PATH, error comes up when...

Vue create “projectName” ERR_SOCKET_TIMEOUT - fails all the time no matter what - taobao

I am getting a bit confused about what’s been happening to me recently. Whenever I want to create a new vue project, it fails with: Vue CLI v4.5.11 ✨ Creating project in...

Build is failing for Syntax Error - Micromatch

I'm facing some difficulties while trying to solve the issue below, which is causing my build to fail. The grunt_default task is failing, and it's complaining about a syntax error in micromatch, I...

npm audit fix --force is not fixing any problems

I've deleted the package-lock.json and node_modules. Then npm i. No success. Tried the same but with yarn install instead. Nothing. I reinstalled NodeJS. Also no success. npm is at version 7.12.1...

npm audit fix --force never able to avoid vulnerabilities

I'm stuck in a situation where I've either got 22 vulnerabilities or 47. I can run npm audit fix but I'm always suggested to run the --force switch in order to actually perform an upgrade. From...

Can VUE CLI Run on be run/installed on Azure Pipelines?

I currently have our backend project running on azure pipelines and I would love to integrate our front-end VUE project in the same way. However, I have tried everything to get vue-cli-service...

Node-pre-gyp and bcrypt yarn install problem on MacOS

I had to install bcrypt, but fell into errors. I tried most of the solutions I found. There are many threads, but I haven't seen many of them for Mac. Here is what I've got from my...

After npm install I received error: Prototype Pollution in set-value

I have an app in React Native, and when I run npm install I received this error "found 15 vulnerabilities (5 moderate, 10 high) in 1182 scanned packages". After run npm audit the most of error...

Error in installing firebase through npm while working in react project

> npm install firebase added 13 packages, changed 1 package, and audited 2276 packages in 7s 148 packages are looking for funding run `npm fund` for details 70 vulnerabilities (24...

npm audit fix causes cascading vulnerabilities

See this console output with npm. First, when I run npm audit it tells me I need to downgrade from [email protected] to [email protected] because of supposed vulnerabilities with the newer...

npm install issue : 27 vulnerabilities (16 moderate, 9 high, 2 critical) To address all issues , run: npm audit fix --force

When I enter npm install in the relevant react project folder, it gives back this error after installing node modules => 27 vulnerabilities (16 moderate, 9 high, 2 critical) To address all...