installing packages for python 3

I tend to run my code in Jupyter notebooks, and these run in python 3. I also have python 2 on my computer. I installed pip3 so I'd be able to install packages specifically for python 3 but this...

MultiDict Error Django

Im using Django and trying to get a response by using AJAX. I have two forms, the first one works just fine. Though I use the same logic in my second form handling it does not work...

Set up virtualenv using a requirements.txt generated by conda

I'm setting up a python project, using an Anaconda virtual environment. I'm generating a requirements.txt so other people can easily set up their own virtual environment for the project. I was...

Simple request parsing without reqparse.RequestParser()

flask_restful.reqparse has been deprecated (https://flask-restful.readthedocs.io/en/latest/reqparse.html): The whole request parser part of Flask-RESTful is slated for removal and will be...

Could not build wheels since package wheel is not installed

I am having this problem with wheels: 'Could not build wheels for ..., since package 'wheel' is not installed.' with several packages and I have no idea what to do since - as you can see in the...

aiohttp.client_exceptions.ClientConnectorError: Cannot connect to host stackoverflow.com:443 ssl:default [Connect call failed ('151.101.193.69', 443)]

here is my code: import asyncio from aiohttp import ClientSession async def main(): url = "https://stackoverflow.com/" async with ClientSession() as session: async with...

Python: TypeError: required field "type_ignores" missing from Module in Jupyter notebook

I have been having issues with my jupyter notebook for a few days. I didn't fix them at the time but have decided to now. Earlier whenever I executed anything in the jupyter notebook, It showed a...

Big Sur clang "invalid version" error due to MACOSX_DEPLOYMENT_TARGET

I assume due to the fact Big Sur is sparkling new hotfixes for the new OS have not yet happen. When attempting to install modules that use clang for compilation, the following error is...

PyJWT won't import jwt.algorithms (ModuleNotFoundError: No module named 'jwt.algorithms')

For some reason, PyJTW doesn't seem to work on my virtualenv on Ubuntu 16.04, but it worked fine on my local Windows machine (inside a venv too). I'm clueless, I've tried different versions,...

Problems with lavalink discord.py bot

I'm trying to implement a music bot on my bot based on https://github.com/stuyy/Lavalink-Discordpy-Example with lavalink and dicord.py. Before hosting it on heroku I'm trying to run it on my...

Keep getting an error about failing to build "multidict yarl

I've been wanting to make a bot for discord using discord.py, yet whenever I install the package, it spits out an error like this ********************** * Accellerated build * ...

error: Microsoft Visual C++ 14.0 or greater is required

When doing pip install discord.py, I got the error message "error: Microsoft Visual C++ 14.0 or greater is required. Get it with "Microsoft C++ Build Tools":...

(Python: discord.py) ERROR: Could not build wheels for multidict, yarl which use PEP 517 and cannot be installed directly

trying to download discord.py using pip install, gave me the error message in the title. I installed using cmd and the commands py -m pip install -U discord, the cmd was also run in admin. tried...

python 3.9 discord.py asyncio.async error

This question deals with discord.py errors caused by asyncio, but any advice on creating discord bots would be very welcome. I am more than willing to read documentation to fully understand...

Python 3.9 Microsoft Visual C++ 14.0 or greater is required

so I recently upgraded to Python 3.9 and when trying to install some libraries - specifically pip install discord - I encountered the following error: ERROR: Command errored out with exit status...

Error of rasa and rasa X intallation and running the local server

I have installed rasa on Max OSX and this output on the terminal: python3.8 -m pip install rasa Collecting rasa Using cached rasa-2.2.2-py3-none-any.whl (688 kB) Processing...

Install Discord.py on a Linux Python 3.8.5

I recently installed armbian focal to a tinker board, and was attempting to install the discord python package. It's running a pre installed python 3.8.5 version, but I've only seen errors with...

"Exception Ignored: RuntimeError: Event loop is closed" when using pytest-asyncio and aiohttp

I'm writing python tests with pytest and have some async code I want to test so I installed the pytest-asyncio plugin. The async code uses aiohttp and running the tests I get the following...

Heroku SSL connection error unsupported protocol

I have been using Heroku for a while to host my Discord bot. It has been connecting to a MySQL database hosted on ClearDB successfully. However, very recently, whenever I use the bot and it tries...

Failed to run TA-lib Python on Heroku

I want to deploy an app using Heroku but it did not manage to build it. See my build logs under this message. It looks that my problem is that it cannot load/install Ta-Lib (package that I want to...

Conda - how to update only cudatoolkit in an existing environment?

This is a specific instance of a general problem that I run into when updating packages using conda. I have an environment that is working great on machine A. I want to transfer it to machine...

Apache Superset TypeError while starting with OAuth authentication enabled

I'm trying to configure OAuth authentication with GitHub apis, on Superset 1.0.1. Following the docs, I added the following lines in superset_config.py from flask_appbuilder.security.manager...

Tensorflow stuck on first epoch

My execution is stuck on the following step I got GTX 3090 on Python 3.7 on windows 10. I installed cuda, cudnn and tensorflow-gpu using conda as instructed from here conda install...

Python Flask CORS - No 'Access-Control-Allow-Origin' header is present on the requested resource

I have a simple Ajax script written on a Shopify Product Page. This script would be triggered and send a json message to the API server whenever the upload button is clicked jQuery.ajax({ ...

dask-yarn job fails with dumps_msgpack ImportError while reading parquet

I am trying to do a simple read and count of a small parquet file (10K records) using dask-yarn on an AWS EMR cluster with one master and one worker node, both are m5.xlarge instances. I am trying...

Error Running Async Flask 2.0.0 on Python 3.6.10

I am attempting to run Flask in an async manner on python 3.6.10, but keep getting: RuntimeError: Async cannot be used with this combination of Python and Greenlet versions. I have written the...

Cannot import installed packages in Jupyter Notebook using Miniforge Conda Environment on M1 Mac

I have a M1 Mac (Apple Silicon, ARM) and I followed the instructions given by Apple here to install Miniforge, create a conda environment called tf_env and install Tensorflow on it. I wanted to...

pathlib: cannot import name 'Sequence' from 'collections'

It has been a few days since I rebuilt my project but when I was testing some things this morning I wanted to update my Werkzeug package due to an issue I was having with its Multidict class, I...

Python: matplotlib.pyplot.show() is not showing the plot

import matplotlib.pyplot as plt plt.plot([1,2,3]) plt.show() input("Press enter to continue...") If I run the script above within VS Code, or even within command prompt, the plot canvas only...

Getting DLL error when running tensorflow/keras program on python gpu 3.8

I am trying to run my simple AI program but I keep getting this DLL error: ImportError: Could not find the DLL(s) 'msvcp140_1.dll'. TensorFlow requires that these DLLs be installed in a...