Netbeans: How to change error row highlighting color away from red

I've dug through every damn color setting under Tools> Options. Went through every Fonts & Color, Editor, PHP etc and I'll be damned if I can figure out how to change the background row...

The Composer installer script did not run correctly [exit code 1]

I tried to install Composer-php in Windows 10 by downloading the executable Composer-Setup.exe from getcomposer. When prompted during installation to chose the command-line PHP I wanted to use, I...

Invalid characters passed for attempted conversion, these have been ignored - Pushing Laravel project to heroku

I am not a php developer, but I am trying to take a laravel project from a server and move it to heroku following alll the provided steps, when pushing the repo to heroku; I encounter the...

How to use Parallel in PHP

I have been trying to use Threads in PHP for my application but could not find a supporting DLL for Windows for PHP VC15 7.4. When I was looking for more details and tutorials on Threads in PHP, I...

PHP 7.4 deprecated get_magic_quotes_gpc function alternative

I am encountered with the situation where one of my old code is using get_magic_quotes_gpc() which is deprecated in the latest PHP version 7.4.* Currently, I have something like this. ###Add...

Redirect to custom tool url in a laravel nova application

Laravel Version: 7 Nova Version: 3 PHP Version: 7.4 Database Driver & Version: Operating System and Version: MacOS Browser type and version: Chrome Reproduction Repository:...

Why does iconv returns empty string in php:7.4-fpm-alpine docker

Given the following code: <?php $mb_name = "湊崎 紗夏"; $tmp_mb_name = iconv('UTF-8', 'UTF-8//IGNORE', $mb_name); if($tmp_mb_name != $mb_name) { echo "tmp_mb_name: {$tmp_mb_name}\n"; ...

TCPDF V5.0.002 line 3018 -> Trying to access array offset of type null. How to fix it?

I am currently working with TCPDF (https://tcpdf.org) to help me generate PDF files. I recently upgraded to PHP V 7.4, and this Specific line of code is giving my the error: trying to access array...

Running php artisan serve command with different php versions

I have a Laravel 5.6 Project which is running with PHP Version 7.10 and another Laravel 7.x project with PHP version 7.4. I defined the PHP path in Windows 10 Environment Variable and every time I...

Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.3.0"

I have uploaded my laravel project to aws hosting when I go to ip address of ec2 instance it give me this error Composer detected issues in your platform: Your Composer dependencies require a PHP...

Fatal error: Uncaught ImagickException: PDFDelegateFailed `The system cannot find the file specified

I want to convert pdf file to jpg. I installed *imagick* correctly and I installed *ghoscript 9.53.3 64x* but I got this error. I put the ghoscript / bin and lib path in the enviroment...

PHP Fatal error: Uncaught TypeError: implode(): Argument #2 ($array) must be of type ?array, string given in

Can anyone help me to solve this issue? I've changed PHP version form 7.4 to 8 and got this error: PHP Fatal error: Uncaught TypeError: implode(): Argument #2 ($array) must be of type ?array,...

TYPO3 10.4.12 installation blocked on second step

After Enviroment Overview (No Problems) i cannot continue with the installation. It's blocked at 2/5 40%. When I press "No Problems detected, continue with installation" these errors are displayed...

How to avoid the preinstalled PHP on MacOS Big sur?

I've installed an updated version of PHP 7.4 using homebrew. But still, when i run php -v on the command line, i get : WARNING: PHP is not recommended PHP is included in macOS for compatibility...

Reference - Composer error "Your PHP version does not satisfy requirements" after upgrading PHP

After updating PHP from 7.4 to 8.0, I ran composer update on my existing project, and got an error like this: acme/some-package[1.0.0, ..., 1.4.0] requires php ^5.6.4 || ^7.0 -> your php version...

xampp installed in ubuntu but php and mysql shows not found

I have installed XAMPP version 7.4 in UBUNTU OS, now when I go to the terminal and type php -v command, it shows [email protected]:/opt/lampp/htdocs/magento242# php -v Command 'php' not found, but can be...

Install grpc extension on Mac OS Big Sur

For 2 days now, I am trying to install grpc for php on my Mac mini server Mac OS Big Sur 11.2.1 Built-in Apache I have tried it on php 7.3 and 7.4 installed with homebrew I have installed grpc...

pecl fails installing mongodb driver on Apple Silicon (M1)

I have php 7.4 installed on my macbook pro m1 % php -v PHP 7.4.15 (cli) (built: Feb 26 2021 09:28:23) ( NTS ) Copyright (c) The PHP Group Zend Engine v3.4.0, Copyright (c) Zend Technologies ...

How to set php 8.0 as default version in ubuntu server

For some reason, i have to install PHP 7.4 and PHP 8.0 in the same ubuntu server. By default when i install php 7.4, it shows it is the default version when use the command php -v. But i want to...

Symfony 5 Fast Track: Database access error

I'm trying to go through the aforementioned tutorial, but I get stuck on the stage between Step 7 and 9 - when the database goes into action. On local server I get An exception occurred in...

How to verify discord endpoint using php?

I am having some issues in creating a Discord bot. I want it to be able to respond to slash commands, but to do so I need to verify an endpoint. I am using PHP 7.4, and can't use any external...

SQLSTATE[08001]: [Microsoft][ODBC Driver 17 for SQL Server]TCP Provider: Error code 0x2746

I'm using PHP Laravel 7.4 on Ubuntu 20.04.and trying to get data from SQL server located in windows server on another cloud. this method was tested on my PC (Windows) and it successfully got the...

Drupal 9.2 Login not working after logout

My site upgraded from Drupal 8.x to Drupal 9.2.4 (PHP 7.4). Once logout then login was not working. No error or warning, just page refresh happened. I checked the cookie compared with my old...

ErrorException Undefined variable: addon

Illuminate\Foundation\Bootstrap\HandleExceptions::handleError vendor/mehedi-iitdu/core-component-repository/src/CoreComponentRepository.php:19 This is the code here public static function...

Prestashop Not working shopping cart after Upgrade 1.7.8.0 PHP 7.4

After upgrade not working shopping cart. First when upgrade to 1.7.8 and PHP 7.3 at shopping cart not working ajax update on products quantities and delete not working. When change to PHP 7.4...

Fatal error: Uncaught PhpOffice\PhpSpreadsheet\Reader\Exception: Could not find zip member

I have installed the latest version of this library using Composer. I created a test file to test the library's functionality, but when I try to parse a file and make a data array out of it, I get...

Error when push commit to gitlab, pipeline error could not read Username

When I commit changes to gitlab and deploying project on cpanel. but got this error in pipeline. i am using laravel deployer in this project, i want to deploy my project on cpanel through...

Error when install PHP with brew in OS Monterey

I got php is deleted in OS Monterey, so I try to install it via Homebrew I already install Homebrew, update tap to shivammathur/php and use this command brew install shivammathur/php/[email protected] but...

How do I build the Firebird database extension (ext-interbase) for PHP on a MacOS M1 Monterey?

Firebird Extension for PHP on MacOS M1 I have PHP7.4 installed with homebrew and the Xcode command line tools. I followed the instructions as per the source repository here...

PHPUnit Cannot acquire reference to $GLOBALS

I am getting an error when running PHPUnit tests on GitHub actions. PHP Fatal error: Cannot acquire reference to $GLOBALS in...