Conda update fails with SSL error CERTIFICATE_VERIFY_FAILED

I have a problem with conda update. Specifically, I tried doing conda update <package> , and I got the following error: Could not connect to...

iPython installed but not found

I've recently deleted Anaconda and reinstalled python with brew. I've installed everything according to these instructions. Python works great, and all packages I've tested so far also work. I've...

Flask python app crashes on heroku

I tried pushing my code directly to Heroku for hosting but I got so many errors. Now, what I did was host the code on Github, and then link the git repo with Heroku. Now, the Heroku app was...

one hot encoding for frequent values only

I am looking to do one hot encoding to a column, but only for those that are very frequent. All that are below a threshold T will be put in their own category. My strategy was to create a...

I can't install Jupyter and Matplotlib in my anaconda env

I have an environment of Anaconda (apart of root) and I'm trying to install this two libraries with no success. I tried: Install libraries by the environment tools of Anaconda Navigator...

Jupyter Notebook - Cannot Connect to Kernel

I've tried installing jupyter notebook using pip3 install jupyter. Every time i launch a new jupyter notebook, the notebook is unable to connect to the kernel. See screenshot below Attaching my...

Cuda Runtime Error cudaErrorNoDevice: no CUDA-capable device is detected

I am using Chainer, Cupy for CUDA 8.0 . I am trying to train machine learning model using python3.5 script, but I got this error: cupy.cuda.runtime.CUDARuntimeError: cudaErrorNoDevice: no...

WEBP support not installed error with Pillow included in Anaconda

I have written a small code to open webp image in the Anaconda prompt. from PIL import Image im = Image.open('test.webp') It causes the following...

"AssertionError: Torch not compiled with CUDA enabled" in spite upgrading to CUDA version

I figured out this is a popular question, but still I couldn't find a solution for that. I'm trying to run a simple repo Here which uses PyTorch. Although I just upgraded my Pytorch to the latest...

HDF5 library version error - HDF5 ver 1.10.4

I'm trying to import some packages with spyder (OS x64), Anaconda and pyton 3.x The error is pretty famous in the internet. The solution proposed is to match the version of the library 1.10.5 with...

Why does Heroku has to install so many modules every time?

I am developing an app in Django and I am deploying it on Heroku. Why does, with each push, Heroku has to install all these modules? I know there is a way to prevent it from doing it all the...

Deploy python app to Heroku "Slug Size too large"

I'm trying to deploy a Streamlit app written in python to Heroku. My whole directory is 4.73 MB, where 4.68 MB is my ML model. My requirements.txt looks like...

mognoengine and bson package not work together

I have one project which is depend on mongoengine and I am using one library which was using bson library. It structure like below. bsNotify/ ├── setup.cfg ├── setup.py └── src ...

module 'tensorflow' has no attribute 'Session' cannot resolve

Please please please help me out here! I cannot resolve it! so... my python version is Python 3.5.6 and Anaconda version is Conda 4.8.3. I am working with Jupyter Notebook. I am working in...

pipx-installed Spyder doesn't recognize Poetry-installed pandas only when trying to view DataFrame in Variable Explorer

I'm using Python 3.8.5. My OS is Kubuntu 18.04. I installed Spyder and Poetry via pipx: pipx install spyder --include-deps pipx install poetry Within my project folder, I installed pandas and...

OANDA API Connection Error: TypeError in tpqoa.py package in __init__(self, conf_file)

I get the below error when attempting to establish a connection to my OANDA Practice account: api = tpqoa.tpqoa("oanda.cfg") TypeError Traceback (most recent call last) in ----> 1 api =...

Error while Installing Packages from requirements.txt in python 3.9

when i run pip install -r requirements.txt i get ERROR: Could not find a version that satisfies the requirement cffi==1.14.0 (from versions: 0.1, 0.2, 0.2.1, 0.3, 0.4, 0.4.1, 0.4.2, 0.5, 0.6,...

Error importing pyarrow in jupyter notebook after pip installation of pyarrow

I am having an issue importing pyarrow into my jupyter notebook. To give some context, I created a virtual environment named rc_env. I've uninstalled and reinstalled pyarrow quite a few times but...

How to install PyCaret in AWS Glue

How can I properly install PyCaret in AWS Glue? Methods I tried: --additional-python-modules and --python-modules-installer-option Python library path easy_install as described in...

ImportError: Could not find the DLL(s) 'msvcp140.dll or msvcp140_1.dll'. Even when the files are located in the %PATH% directory

I receive the following error when importing tensorflow (base) PS C:\Users\Rostyslav\GIt\GNN-GCP> python run_model.py --train --save Traceback (most recent call last): File "run_model.py", line...

ModuleNotFound: dateutil.parser

Here's what I'm running into: (.venv) PS C:\Users\<redacted>\onedrive\dev\python\code\kb4> py kb4.py Traceback (most recent call last): File...

Cannot pip install mediapipe on Macos M1

Hello fellows I'm using mac air with M1 chip My env sets like (CV) san  ~/work/python  conda list # packages in environment at /Users/san/miniforge3/envs/CV: # # Name ...

Tensorflow Object Detection Api M1 Macbook Conflict Error

Machine: MacBook Air M1 2020 OS: macOs BigSur 11.4 Python version of venv: Python 3.8.6 Tensorflow version: ATF Apple Tensorflow 0.1a3 Pip version: 21.2.4 I have installed Tensorflow from...

pip3.6 install mysqlclient==1.3.12 fails with error: unknown type name ‘my_bool’; did you mean ‘bool

I have a project that worked on ubuntu 16.04 with python 3.6 but now we are trying to make it run on ubuntu 20.04 with same python version. I need to install all requirements on the venv and...

Python 3.8 with Kora in Colab is not working anymore, how to fix?

I did: !pip install kora import kora.install.py38 but got error: Requirement already satisfied: kora in /usr/local/lib/python3.7/dist-packages (0.9.19) Requirement already satisfied: ipython in...

heroku failing to process requirements.txt "because these package versions have conflicting dependencies."

I have deployed this project many times before successfully and have made no changes to the requirements.txt file located in the root directory of the project, however. Heroku will no longer...

Python: matplotlib.pyplot.show() is not showing the plot

import matplotlib.pyplot as plt plt.plot([1,2,3]) plt.show() input("Press enter to continue...") If I run the script above within VS Code, or even within command prompt, the plot canvas only...

ModuleNotFoundError: No module named 'mxnet'

I have been looking for the solution for this error for a whole morning. I created an separate environment for python 3.6 and I still got this error. I am using anacondas. So i am so...

Getting DLL error when running tensorflow/keras program on python gpu 3.8

I am trying to run my simple AI program but I keep getting this DLL error: ImportError: Could not find the DLL(s) 'msvcp140_1.dll'. TensorFlow requires that these DLLs be installed in a...

pycharm error happening at random time: Process finished with exit code 134 (interrupted by signal 6: SIGABRT)

I am working with pycharm community on a tensorflow model with keras backend, sometimes this error appears in a random time, specially after I call pyplot and close the window: Exception ignored...