How to install psycopg2 with "pip" on Python?

I'm using virtualenv and I need to install "psycopg2". I have done the following: pip install...

How to Build libspotify examples on a Mac

I just downloaded libspotify for the mac and I'm attempting to take a look at the examples, but upon Make-ing I get the following: for a in jukebox spshell; do make -C $a all; done /bin/sh:...

gio.h no such file or directory

I am trying to compile the GIO example program code at here on developer.gnome.org link. And the command I am using to compile it is g++ gdbserver.cpp `pkg-config glib-2.0 --libs --cflags...

undefined reference to symbol '[email protected]@GLIBCXX_3.4' building OpenCV on Ubuntu

I'm on Ubuntu Trusty and I'm building the following code with this command. I'm new to clang and I could use help debugging these errors. The cpp and hpp files these C bindings are from compile...

configure: error: Cannot find OpenSSL's <evp.h> - Installing php imagick in Mac OS 10.9.4

Tried to install imagick in my php 5.3 (AMPPS) I saw instructions in net to do this command but there's an error brew install php53-imagick ==> Installing php53-imagick dependency: php53 ==>...

"configure: error: mcs Not found" during configure mono-addins on CentOS

I'm trying to install MonoDevelop 4 on CentOS 7 as described in this post: https://stackoverflow.com/questions/16900575/install-mono-and-monodevelop-on-centos-5-x-6-x/17034163#17034163, but when...

'pkg-config' is not recognized as an internal or external command when installing package

So I'm getting this error when attempting to install OpenCV on my computer. 'pkg-config' is not recognized as an internal or external command ...

libedit not found: Centos, installing openssh

I wnt to install openssh from http://www.linuxfromscratch.org/blfs/view/svn/postlfs/openssh.html (I don't want to use packages with yum) --with-libedit[=PATH] Enable libedit support for...

nodemon app crashed - waiting for file changes before starting

EDIT After further testing, I have found that this is happening with both gulp and grunt on this app and on the default install of mean.js. I'm running this locally on a Mac. When I running...

No such filter in ffmpeg

I am trying to create the slideshow with below command. Here is the command I have executed: ffmpeg -loop 1 -t 1 -i /sdcard/input0.png -loop 1 -t 1 -i /sdcard/input1.png -loop 1 -t 1 -i...

fail to visualize a network in python - issue with pygraphviz?

As I use some code to visualize a network, I encountered an error Traceback (most recent call last): File "networkplot.py", line 21, in <module> pos = graphviz_layout(G, prog='neato') File...

RMagick installation: Can't find MagickWand.h

Updating RMagick and Imagemagick is a painful expierence. I have updated the Imagemagick version on my mac (MacOS El Capitan Version 10.11.5) with homebrew for one project in Ruby 2.3 to 6.9.5-9 $...

libg2o linker errors on OS X

I am getting the following linker errors: cd /Users/mhoggan/Development/bluenote/image_pose_adjustment/image_pose_adjustment/native/graph/cmake-build-debug/src &&...

Full & complete uninstall QT Creator

Question: How to uninstall QT Creator from Linux machine? I have a corrupted install on a Debian Jessie machine. I have tried reinstalling, fixing, etc. and with no luck. I was advised to...

Kubernetes kubeadm init fails due to dial tcp 127.0.0.1:10248: connect: connection refused

I'm trying to setup a very simple 2 node k8s 1.13.3 cluster in a vSphere private cloud. The VMs are running Ubuntu 18.04. Firewalls are turned off for testing purposes. yet the initialization is...

Error (0x0 0x0) [Golang /Window10/64bit]

I was testing Golang Html/Templates with the Go script below and ended up getting Error (0x0 0x0) (the browser page never loads) .However,Javascript loads fine in the same...

Docker & Laravel : configure: error: Package requirements (oniguruma) were not met

Can anyone help me with this problem. When i try to create a docker image from a dockerfile for laravel application i get this error: checking for oniguruma... no configure: error: Package...

Controller_manager : [ERROR] Controler Spawner couldn't find the expected controller_manager ROS interface

I know there is already a lot of questions on this particular error but none of the ones i found solved the issue for me... I'm trying to implement the ROS differential drive controller for a two...

How to fix XCode invivisble Headers and Clang compiler issue in MacOS?

GCC- Apple clang version 11.0.3 (clang-1103.0.32.29) is giving me weird results when I try to run any C++/C program. For example, running this code: #include <string> #include <iostream> int...

calling python from golang

I am following https://poweruser.blog/embedding-python-in-go-338c0399f3d5 example on using python code from a golang application. I installed the python3.8 dev. When I try go build I...

QML module not found (QtQuick.Studio.Components 1.0 )

I cross compiled Qt 5.14.1 for my Raspberry pi 4 on a Ubuntu 18.04, for my application I need arcs when I searched I found out that arc belongs to QtQuick.Studio.Components 1.0...

VS Code go debug : could not launch process: not an executable file

i had the vscode running and debugging GO code just fine , after i did update from within VSCode now i can't debug and i keep getting this error : could not launch process: not an executable...

How to update cocoapods for flutter on Mac without getting an error?

I use Flutter with Android Studio on a Mac. One day (today), I ran "flutter doctor" from the command line. It stated that my "cocoapods" was not good enough. Doctor summary (to see all details,...

Cannot install psycopg2 with pip3 on M1 Mac

I cannot install psycopg2 on my M1 Mac and I used pip3. When I tried to install with pip3 install psycopg2 The output like that: ERROR: Command errored out with exit status 1: command:...

Package 'php' has no installation candidate

I tried to install PHP in BlueStacks by Termux, but thrown the below error : Command : pkg install php Error : Package 'php' has no installation candidate I ran apt-get update and apt-get...

Error installing Jekyll: Failed to build native extension | macOS BigSur

maybe someone can help me. I follow the instructions on https://jekyllrb.com/docs/installation/macos/ I have installed Ruby 3.0.1 via homebrew and set all paths. ruby 3.0.1p64 (2021-04-05 revision...

Error installing cocoapods : Failed to build gem native extension

I am trying to install cocoapods to my mac [ macOs bigSur 11.1 , Xcode 11.3 ] but after typing sudo gem install cocoapods i get the following error things i have tried : i was able to install...

Unable to install Cocoapods in macOS Monterey Version 12.0 Beta - Xcode 13.0(13A233)

unable to install Cocoapods in MacOS 12.0 Beta and Xcode Version 13.0 here is terminal output for sudo gem install cocoapods [email protected] ~ % sudo gem install...

Building my unaltered package suddenly fails: for Vignettes and 'arch = x64'

Context I've been developing a proprietary package (call it "my_pkg") with vignettes, in RStudio with the latest version (4.1.1) of R. I'm working on a Lenovo ThinkPad with the following...

CircleCI (Started 11/1/2021) Can’t find Python executable “python”, you can set the PYTHON env variable

As of this morning, CircleCI is failing for me with this strange build error: Can't find Python executable "python", you can set the PYTHON env variable I noticed it on a new commit. of course,...

Relevant tags