protoRPC: returning dict

How does one return a dict like object through protoRPC ? I tried using the FieldList to no avail. I only see the following field definitions: 'IntegerField', 'FloatField', ...

"ImportError: No module named _ssl" with dev_appserver.py from Google App Engine

Background "In the Python runtime, we've added support for the Python SSL Library, so you can now open secure connections to remote services such as Apple's Push Notification service." This...

Protobuf RPC Service method without parameters

I'm trying to describe an RPC service using Google's Protocol Buffers service WhoamiService { rpc WhoAreYou() returns (Whoami) {} } message Whoami { optional bytes request_id = 1; optional...

Database returned an invalid value in QuerySet.datetimes()

I got this error when I try to access the PayPal IPNs from the admin site. ValueError at /admin/ipn/paypalipn/ Database returned an invalid value in QuerySet.datetimes(). Are time zone...

Visual Studio Code pylint: Unable to import 'protorpc'

I'm using pylint in Visual Studio Code to develop a Google App Engine (GAE) Cloud Endpoint API in Python. I'm unable to resolve a lint error. I don't know what's causing the error, but at a guess,...

Wrong dependency in Google Cloud SDK for google-auth?

i am using google cloud storage and google cloud datastore api (locally, for now), in a Standard Environment app. I am having a very weird behaviour trying to running my tests (with pytest): i...

ImportError: No module named moves

Versions Python : 2.7.14 six : 1.9.0 & 1.11.0(tried on both) OS : mac(10.13.3) & ubuntu(16.04) [tried on both] Error from six.moves import http_client ImportError: No module named...

Pod install installs deprecated react and creates a build error 'React/RCTBridge.h' not found

I recently added some pods and ran pod install to a previously working project and now I get a warning that React has been deprecated and seems to have problems linking to React with a build error...

Flutter Firestore plugin throws error when Archiving in Xcode

After updating to the latest version of the cloud_firestore plugin (cf pubspec.yaml below), the application would no longer archive in the latest Xcode, although it runs on the emulator. Steps to...

How to solve Use of unresolved identifier 'SetOptions'?

I have updated Firestore to follows. Now, I can't use it anymore. I removed, reinstalled several times. But there is no change. I am losing my mind. The issue is: "Use of unresolved identifier...

Flutter iOS not using pods

im rather new to programming and flutter of course. I'm trying to get to work firebase pods in order to authenticate users within my app. Android and its "pubspec" worked like a charme, however i...

protoRPC: returning a pub/sub message python

How does one return a PubsubMessage through protoRPC ? Pub/sub message example, .{ "data": string, "attributes": { string: string, ... }, "messageId": string, "publishTime": string }

Firestore: Lexical or Preprocessor Issue

I'm trying to archive a project in Xcode. When pod 'Firebase/Firestore' is installed, I encounter the following issue: Lexical or Preprocessor issue: Include of non-modular header inside...

Unable to build a Flutter app for iPhone 4s Simulator in Xcode

I am getting the following exception when trying to deploy to an iPhone 4s in X-code. I would like to build the app in X-code so I can troubleshoot why the Flutter app is crashing on iPhone 4s...

many errors after updating xcode

After updating to Xcode 9.4, I started to receive some errors and I cannot even build it now. The errors are Apple Mach-o link error, dsymutil error, ditto error. The details of dysmutil error are...

Unexpected errors in working app -> 'Private/FIRComponentContainerInternal.h' file not found

A bunch of error cropped up unexpectedly in a working app tied to Firebase use. 'Private/FIRComponentContainerInternal.h' file not found 'GoogleToolboxForMac/GTMNSData+zlib.h' file not found These...

No such module 'FirebaseUI'

I want to authenticate with FirebaseUI. Following https://firebase.google.com/docs/auth/ios/firebaseui?authuser=0, I maked this program (Swift 4.1.2, Xcode 9.4.1). import UIKit import FirebaseUI...

How to fix Apple Mach-O Linker (ld) Error Group - ld: library not found for -lFBSDKCoreKit

it's been several days now that I get this error, I tried several solutions like: I always open the .xcworkspace file I always clean the project and relaunch I always restart xcode and...

Appengine VSCode can't debug Python main.py

I'm trying to get VSCode debugging a Google Appengine script. I followed the specific instructions on the VSCode web site for Pythong Appengine Debugging where I start the build process. Then I...

Flutter: Build ios error : ld: 13 duplicate symbols for architecture x86_64

After some trouble to add Geolocator plugin and couldn't work. I removed Geolocator from pubspec.yaml but now the project couldnt build for ios. I have tried for 2 days without success...

pod update problem with gRPC-Core 1.14.0 and 1.14.1

My Podfile look like this platform :ios, '11.2' target 'live-quiz' do use_frameworks! pod 'Fabric' pod 'Crashlytics' pod 'Kingfisher' pod 'Alamofire' pod...

CocoaPods could not find compatible versions for pod "Firebase/Core” | cloud_firestore, Flutter

I am having some issues in the pod, see below Launching lib/main.dart on iPhone X in debug mode... Running pod install... CocoaPods' output: ↳ Preparing Analyzing dependencies Inspecting...

Cannot import six on GAE local development environment

I got below error when trying to run my GAE Python 2.7 app. ImportError: No module named six I have followed this page and set up my app.yaml file like below. ... libraries: - name: six ...

Generate new proto

I have a <Podspec file name>.podspec equivalent to the standard GRPC one. I don't know how to run the script in here that generates new .pbobjc.h/.pbobjc.m files for each .proto file. Does anyone...

ImportError: No module named endpoints

Was working while setup in a samples dir downloaded from github, but now that I've built my own API, the dev server starts but throws this error when hitting it with CURL: $ dev_appserver.py...

TypeError: __init__() takes exactly 1 argument (6 given)

Working to build a Google CloudEndpoints API locally, getting to know with how the messages are constructed. This API will make the admin SDK reports API activities:list method available, but...

FIRAuth files not compatible with FirebaseUI: use of undeclared identifier 'FIRAuthErrorUserInfoUpdatedCredentialKey'

I just recently updated my podfile and added two entries pod 'Firebase/Storage' and pod 'FirebaseUI/Storage'. When I added these two entries, when I open up my project in Xcode, the build fails,...

GRPC Objective-C not calling handler on response

I'm running into an issue where I'm sending the message to the server (golang) but the response is not getting to the client (objective-c). To be clear, I see the log statement from the server...

Multiple Commands Produce gRPCCertificates.bundle error on Archive (iOS Xcode 11.1, Firebase SDK)

In updating to the latest Cocoapods, I updated googleapis pod and encountering the following error on Archiving the build in Xcode 11.1: Multiple commands produce...

What are Best Practice for msgprop.EnumProperty and messages.Enum with Python 3 and Cloud NDB?

With Python 2 and NDB, we could store Enum in entities' properties this way: from google.appengine.ext import ndb from google.appengine.ext.ndb import msgprop from protorpc import messages class...