No such module psutil, even though psutil is installed

I am on OS X El Capitan. I want to import psutil for a python script, but get module psutil not found. If I do pip install psutil I get psutil already installed. How is this possible that I have...

xcode-select error during pyobjc-core installation

I am trying to install pyobjc-core which is a requirement for pyautogui. I am getting the below error while installing. I have already updated setuptools using pip3 install --upgrade...

Unresolved reference 'BeautifulSoup'

I ran into a problem Unresolved reference 'BeautifulSoup'. I have already installed BeautifulSoup but still it shows unresolved. import requests from bs4 import BeautifulSoup OS: Mac IDE:...

Error when trying to install pyautogui

I am trying to install pytautogui through pip, but keep running into issues. This is on a Mac. I have tried running the command under python 2.7 as well as 3.6.1, but to no success. Complete...

No module named flask, despite having it installed

New to flask and python here. I've written a simple python app, but when i run python app.py, I get ImportError: No module named flask. app.py: from flask import Flask app = Flask(__name__) def...

Python push fails to Heroku

I'm developing a Reddit bot using PRAW that I'm trying to push to Heroku. When I run git push heroku master, I get this error: Counting objects: 40, done. Delta compression using up to 4...

`ImportError: No module named AppKit` after installing AppKit and PyObjC

I'm trying to get some Python code working on a fresh installation on Anaconda on Mac OS X Mojave with Python 2.7. This was all stuff that was working before on the same machine. The error I'm...

Unable to import geopy into Jupyter even after pip installation

I'm trying to install geopy to use in Jupyter, but I keep getting the following error when I try to import it. import geopy ModuleNotFoundErrorTraceback (most recent call...

PyAutoGUI - LocateAllOnScreen - Why is confidence not working?

I am trying to make an aimbot for diep. I am trying to locate all enemies on the screen, but with 1 confidence it returns None and with 0.9999 confidence it returns every single position on the...

Unable to install pyautogui on Ubuntu 16.04 LTS

I am using Ubuntu 16.04 LTS and I am unable to install pyautogui I followed installation steps exactly as in docs, but when I run pip3 install pyautogui I get: Collecting pyobjc-core (from...

I can't install Open CV

I am trying to install Open CV for this tutorial... https://www.youtube.com/watch?v=Hqf__FlRlzg&list=WL&index=4&t=2494s I have installed it and when I type pip list in the terminal it shows that I...

ContextualVersionConflict when importing guesslang package

When importing guesslang package, I've got ContextualVersionConflict error about html5lib package. ContextualVersionConflict: (html5lib 1.0.1...

Pyttsx3 is not installing on Windows

I have python 3.7.6 installed and when I try to install pyttsx3 on my windows 10, I had an error, that I need mac os, but it installing on another computer with windows. I have tried to reinstall...

Pip error installing PyObjC-core on mac OS 10.13.6

Hi currently i had PyObjC-core as one of the dependencies in my requirements.txt file, when i try to run pip install -r requirements.txt it return the following error: Collecting...

All Preinstalled Python packages automatically included in the new Virtualenv

I have this problem since moving from BASH to ZSH in macOS Catalina and trying to remove python 2, which is not successful, so I give up to remove the python 2. And as a result, every time I...

Heroku build fail with error "PyObjC requires MacOS to build" - how to fix?

I'm trying to use the playsound module in a very simple Django app with the below code which plays an mp3 file: from playsound import playsound playsound(filename) However, my push to...

Maya Python - "You need a shiboken-based type" Error

Many Python based tools in Maya are now returning an error that is new to me. "You need a shiboken-based type. #" Very fresh to Python, so I don't really know what the issue is. After looking...

Wont let me download pip, says there's a permission problem and I need to update pip

Audreys-computer:~ audreyoneill$ python3 -m pip install pyautogui Collecting pyautogui Collecting pyobjc-core; platform_system == "Darwin" (from pyautogui) Using cached...

Can't install speechrecognition and pyttsx3 on Mac

I'm using 3.8.1, macOS Catalina 10.15.5, I'm new in Python, I tried use pip install speechrecognition and pyttsx3 but it's doesn't work. I tried install pyaudio too but it have a fault. 125:~...

I Can't Install PyAutoGu

MacOs 10.14.6 Python3.7 I've been trying to install pyautogui for days now and I always get the same error. I've tryed a lot of solutions i found online but none of them seem to work! This is the...

How do I use python to get the UI elements of a native mac app?

I need to get the text from UI elements on a mac GUI. One possible route might through pyobjc and...

ModuleNotFoundError though Python module PyBluez is installed

I am using python3 with the Thonny IDE. My programs are running on a Raspberry Pi 4B. I tried to install PyBluez on different ways, with pip and with the built-in package installer of Thonny....

How do I install third party modules in the Mu Editor?

I am trying to install third party modules in the Mu Editor on my Mac OS and I am following the instructions on "Automate the boring stuff with Python" (here is the link to the instructions I am...

How to fix "ValueError: invalid literal for int() with base 10: '' occuring. whenever pyobjc is needed including installing pyobjc

I need to import a number of packages into python that require installation. From the command line (zsh) I've attempted to use pip, python and homebrew(I'm using Mac OS Big Sur) but get an error...

py2app "/usr/lib/libstdc++.6.dylib: No such file or directory" error

When I was building LDOCE5 Viewer on macOS Big Sur with the command sudo DISTUTILS_DEBUG=1 python3 setup.py py2app, the output printed this error: copying file /usr/lib/libstdc++.6.dylib ->...

Error when importing pyautogui on macOS 10.13 and Python 3.8

I'm working in a conda environment with Python 3.8.0 created using conda create --name atbs python=3.8.0. I have installed pyobjc, pyobc-core and pyautogui using pip install pyautogui. The...

Error installing Pyobjc on macOS 11.0 Big Sur

I'm getting an error when trying to install the pyobjc library in a virtual environment on Big Sur. The installation errors out claiming that it "Cannot determine SDK version." I've done some...

Cannot install pyobjc-core MacOs for python 3.8.0 (command 'gcc' failed with exit status 1)

OS: macOS Big Sur: 11.0.1 Python: 3.8.0 trying to install pyobjc-core==5.2 to fulfill the requirements for the "automate the boring stuff" book. I have tried many suggested fixes online and have...

Error installing PyObjC library for python windows 10

I was trying to create a personal assistant for fun. I imported playsound module and gTTS module. They were all ok. But the google tts was sounding like old days tts. It did not sound so great...

This version of ChromeDriver only supports Chrome version 87 Current browser version is 90.0.4430.93

ChromeDriver is giving an error about its version being too low: This version of ChromeDriver only supports Chrome version 87 Current browser version is 90.0.4430.93. I've updated pip's packages...