What are the differences between django-tastypie and djangorestframework?

Why would you use one over the other, for exposing an API for your Django app? http://pypi.python.org/pypi/djangorestframework/ http://pypi.python.org/pypi/django-tastypie

Parallel Pip install

Our Django project is getting huge. We have hundreds of apps and use a ton of 3rd party python packages, many of which need to have C compiled. Our deployments are taking a long time when we need...

Building PySide 1.2.0: no pyside-uic

I compiled PySide 1.2.0 for python 3.3 on my machine (Ubuntu 13.04 x64), but, for some reason, pyside-tools don't get "compiled". When I try to execute pyside-uic (after install) I get this...

ImportError: No module named pip

OS: Mac OS X 10.7.5 Python Ver: 2.7.5 I have installed setuptools 1.0 with ez_setup.py from https://pypi.python.org/pypi/setuptools Then I download pip.1.4.1 pkg from...

How can I install packages hosted in a private PyPI using setup.py?

I'm trying to write the setup.py install file for a private project, which has both public and private dependencies. The public ones are hosted on PyPI, whereas the private ones are hosted on a...

How to install pip for Python 3 on Mac OS X?

OS X (Mavericks) has Python 2.7 stock installed. But I do all my own personal Python stuff with 3.3. I just flushed my 3.3.2 install and installed the new 3.3.3. So I need to install pyserial...

pip, proxy authentication and "Not supported proxy scheme"

Trying to install pip on a new python installation. I am stuck with proxy errors. Looks like a bug in get-pip or urllib3?? Question is do I have to go through the pain of setting up CNTLM as...

I cannot install mysql-connector-python using pip

I am trying to install mysql-connector-python==1.0.12 as part of my project's automated installation, and I get the following error from pip install: Collecting mysql-connector-python==1.0.12...

Why is python setup.py saying invalid command 'bdist_wheel' on Travis CI?

My Python package has a setup.py which builds fine locally on Ubuntu Trusty and on a fresh Vagrant Ubuntu Trusty VM when I provision it like this: sudo apt-get install python python-dev...

Google Cloud Composer using google-cloud-bigquery python client library

I'm trying to run a DAG in Google Cloud Composer in which the first component is to use a http GET request to call an API and then use the python-client library to insert the json into a BigQuery...

Pythonista core module

I’m quite new to Pythonista and I’ve found the StaSh pip installer. I installed the module PyDictionary but for some reason whenever I try to import it, it gives me an error saying I haven’t...

'Cannot setup a Python SDK' in PyCharm project using virtualenv after OS reinstallation

I re-installed windows and opened an existing Pycharm project and get the error 'SDK seems invalid' in Settings > Project Interpreter. The project interpreter path is pointing to python in the...

Pip ReadTimeoutError in Windows 10

Fresh Python 3.7 64-bit install downloaded from their main website, working on Windows 10 Pro. Using PowerShell with Admin rights. Pip always throws ReadTimeoutError. The command: python -m pip...

Create and use a PyPi proxy repository on nexus

Running Nexus 3 OSS 3.6.0-02 I have created a pypi proxy repository on nexus using this guide: https://help.sonatype.com/repomanager3/pypi-repositories With the following info: Format: pypi Type:...

Python: why do I get an error when I import geopandas?

I try to import geopandas in my jupyter notebook. import geopandas as gp and I get the following error: ImportError:...

Install from pipfile using pipenv install gives error

I have a project where I'm trying to install from the pipfile using pipenv install. I get som error when installing. Before i describe the error, this is what I did: Reinstall pipenv Reinstall...

Cannot install pyqt5-tools - 'Could not find a version that satisfies the requirement pyqt5-tools'

I try to install pyqt5-tools like this: pip install pyqt5-tools and the resulting out put is: ERROR: Could not find a version that satisfies the requirement pyqt5-tools (from versions:...

Twine is asking for my password each time : how to use the .pypirc

I have pip installed pypirc and set up a ~/.pypirc file with the requisite password. Why is twine asking for a password each time python setup.py is invoked? $twine upload --repository-url...

pip install from Azure DevOps Python Artifacts feed not working

When I attempt to install a package from our Azure DevOps Artifacts feed, I get the error: Looking in indexes: https://pypi.org/simple,...

ImportError: cannot import name 'rcParams' from 'matplotlib'

I have tried to uninstall and reinstall matplotlib in my tf-gpu enviornment I made but I keep getting this error: ImportError: cannot import name 'rcParams' from 'matplotlib' This is the entire...

Pytorch says that CUDA is not available

I'm trying to run Pytorch on a laptop that I have. It's an older model but it does have an Nvidia graphics card. I realize it is probably not going to be sufficient for real machine learning but I...

Apple M1: install psycopg2 package Symbol not found: _PQbackendPID

pg_config venv ❯ which pg_config /Applications/Postgres.app/Contents/Versions/latest/bin/pg_config pip3 install -r requirements.txt requirements.txt venv ❯ cat requirements.txt -i...

ERROR: Failed building wheel for psycopg2 (Ubuntu 20.04 + Python 3.8.5 + venv)

Greetings wisdom from Stackoverflow! I'm having issues building wheel for psycopg2 thru pip install -r requirements.txt. I'm on ubuntu 20.04 + python 3.8.5 + venv. This is my...

Cannot install psycopg2 with pip3 on M1 Mac

I cannot install psycopg2 on my M1 Mac and I used pip3. When I tried to install with pip3 install psycopg2 The output like that: ERROR: Command errored out with exit status 1: command:...

Cross account access to a CodeArtifact repo

I have an IAM user in account A with admin privileges and arn:aws:iam::aws:policy/AWSCodeArtifactReadOnlyAccess attached for good measure. The iam user from account A has an arn of...

How can I get torch-geometric to work using Nix?

I am trying to get the Python package torch-geometric to work using Nix (I am on NixOS). Currently, I use mach-nix to try and setup a Python environment. However, the difficulty is that some of...

Cannot pip install mediapipe on Macos M1

Hello fellows I'm using mac air with M1 chip My env sets like (CV) san  ~/work/python  conda list # packages in environment at /Users/san/miniforge3/envs/CV: # # Name ...

Error: Failed to building wheel for fbprophet

I saw a similar post in StackOverflow.But my question is different as I'm using Jupyterlab, not the anaconda I'm trying to install fbprophet in my jupyterlab 3.0.16. So I wrote the following...

How to install a package using pip in editable mode with pyproject.toml?

When a project is specified only via pyproject.toml (i.e. no setup.{py,cfg} files), how can it be installed in editable mode via pip (i.e. python -m pip install -e .)? I tried both setuptools and...

AWS Codeartifact with upstream pypi not fetching latest version

I have a python Codeartifact repository which has an upstream PyPI repo. In PyPI a new version of a library (google-auth 2.3.1) was published on the 25th of October, but whenever I try to install...