Conda takes 20+ minutes to solve environment when package is already installed

NOTE: I'm duplicating this post because the question has been up on the conda github page for ~6-days with no response. The original link is...

Anaconda Package Installation OSError(22, 'The parameter is incorrect', None, 87, None)

I am having problems with Anaconda, installing some packages. I have installed Anaconda and am having a problem installing packages. Anytime I try using the install buttons on the Anaconda...

Python 3.7 anaconda environment - import _ssl DLL load fail error

I created anaconda environment with Python=3.7 and have trouble with the error of _ssl and DLL. When I tried to get back to my base environment, I have trouble getting the background processes to...

WEBP support not installed error with Pillow included in Anaconda

I have written a small code to open webp image in the Anaconda prompt. from PIL import Image im = Image.open('test.webp') It causes the following...

How to fix the environment with inconsistent dependencies after using conda "update" commands?

I'm trying to update my Spyder to fix some error in my Spyder 3.2.3. But when I called conda update spyder mentioned in (https://github.com/spyder-ide/spyder/issues/9019#event-2225858161), the...

"AssertionError: Torch not compiled with CUDA enabled" in spite upgrading to CUDA version

I figured out this is a popular question, but still I couldn't find a solution for that. I'm trying to run a simple repo Here which uses PyTorch. Although I just upgraded my Pytorch to the latest...

ERROR: You must give at least one requirement to install -- when running: pip install --upgrade --no-binary hdbscan

I am trying to install hdbscan in my PC which runs Windows 10 and has installed Python 3.6. My first attempt failed: (base) C:\WINDOWS\system32>pip install hdbscan --user Collecting hdbscan ...

No module named 'matplotlib.artist'

I faced with this error No module named 'matplotlib.artist' here is the complete error: --------------------------------------------------------------------------- ModuleNotFoundError ...

How to use Tensorboard with Pytorch in Sagemaker

I am using torch version 1.2.0 and installed with conda tensorboard 2.0.2. I am running on Sagemaker conda_pytorch_p36. I also followed this StackOverflow question from a while ago. My goal is to...

Conda does not create environment

I am working on a shared project stored in bitbucket. I am trying to import the environment that it is used there. After I git clone, I have everything that I need in my PyCharm project folder....

Python coverage report covering only test file

I’m pretty new to contributing to open source projects and am trying to get some coverage reports so I can find out what needs more / better testing. However, I am having trouble getting the...

Command to update anaconda downgrade anaconda

I am relatively new to python and in Stackoverflow and have the 2019.10 version of anaconda and saw that it launched 2020.02. I would manually uninstall my current version and install the latest...

Pytest E DeprecationWarning: defusedxml.lxml is no longer supported and will be removed in a future release

I have a simple python code like these: filename: test_pytest_openpyxl.py import openpyxl def test_1(): print("test_1") if __name__ == "__main__": test_1() python...

conda update InvalidSpecError

I am trying to update a conda environment: conda update --all but get the following Fetching package metadata ............. InvalidSpecError: Invalid spec: =20190808 output of conda list is as...

conda install psycopg2 errors

New mackbookpro running Catalina. Installed anaconda using homebrew. Tried to install psycopg2 using the command conda install -c anaconda psycopg2 but failed due to package conflicts. Here's some...

error H13 on heroku on an dash application

import requests from bs4 import BeautifulSoup import pandas as pd import dash import dash_core_components as dcc import dash_html_components as html import...

How do I install the most recent Tensorflow (here: 2.2) on Windows when conda does not yet support it?

I have conda 4.8.3 and Python 3.7.4 on Windows 8.1. I have tf 2.0.0 installed in a conda environment. How do I upgrade to 2.2.x? Or, how do I just install 2.2.x in a conda environment? Edit 1: pip...

pygpu problem : DLL load failed: The specified procedure could not be found

When Trying to run a model in Theano on anaconda Using TensorFlow backend. pygame 1.9.6 Hello from the pygame community....

Fatal Python Error when running pytest with QT

I'm new to pytest and I'm having trouble trying to run one of my test files. I'm getting the following output: ================================================== test session starts...

How can I check if I installed Python, pandas, and Jupyter with conda or pip? Should I reinstall it with conda?

I don't remember how I installed python. I'm learning to use Jupyter now and the official website recommends to install python using conda, not pip. Why is installing python and Jupyter with pip...

Update python on anaconda

My current python version is : When I search for available python using the code: conda search python Below is the output: I want to update my python to the latest version. I use the...

Error running unit tests using pytest - AttributeError: 'TestCaseFunction' object has no attribute 'get_marker'

I am using pytest 5.4.1 with python 3.6 Code: import unittest class TestStringMethods(unittest.TestCase): def test_upper(self): self.assertEqual('foo'.upper(), 'FOO') if __name__ ==...

virtualenv: pre-installed with packages on creating virtual environment

I created a virtual environment using command virtualenv env on my terminal. On using pip freeze > requirements.txt after activating the virtual environment, I was a bunch of packages...

How to generate a test report in python using selenium and unittest?

I was trying to test a simple login form with different cases. I used python,selenium,python's unittest library for testing and i am able to get test done by unittest library but how can i...

After Talos installation jupyter notebook breaks (kernel going on and off)

What is the best way to install talos because whenever i am installing talos i am getting error as [I 10:35:48.748 NotebookApp] Adapting to protocol v5.1 for kernel...

"ImportError: No module named seaborn" in Azure ML

Created a new compute instance in Azure ML and trained a model with out any issue. I wanted to draw a pairplot using seaborn but I keep getting the error "ImportError: No module named seaborn" I...

Import rasterio failed. Reason: image not found

I'm going to use rasterio in python. I downloaded rasterio via conda install -c conda-forge rasterio But I cannot import it due to the following import error. I've read some related questions and...

Installing tensorflow with virtualenv pip in Anaconda

I'm trying to install tensorflow with pip in virtualenv in Anaconda for Windows 10. After activating my virtualenv, when I run pip install tensorflow, I get an error: ERROR: Could not find a...

Importing stix2, ModuleNotFoundError: No module named 'six.moves.collections_abc'

I have issues importing the stix2 library regardless of the code I have written. Following https://github.com/oasis-open/cti-python-stix2, I followed the installations instructions and...

It seems that scikit-learn has not been built correctly

I have been using Jupyter Notebook for my machine learning project. Before scikit-learn was working fine but eventually I installed pip install imblearn and pip install -U imbalanced-learn after...