SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1108) Discord/python

I'm using Pycharm and python 3.8 and latest version of discord. I tried to run this script but got this error. Can anyone help? import discord TOKEN = 'xxxxx' client =...

PyTorch RuntimeError: DataLoader worker (pid(s) 15332) exited unexpectedly

I am a beginner at PyTorch and I am just trying out some examples on this webpage. But I can't seem to get the 'super_resolution' program running due to this error: RuntimeError: DataLoader worker...

ERROR: PyAudio-0.2.11-cp38-cp38-win_amd64.whl is not a supported wheel on this platform

I am trying to install pyaudio in python 3.8 and when i execute pip3 install PyAudio-0.2.11-cp38-cp38-win_amd64.whl it shows an error that ERROR: PyAudio-0.2.11-cp38-cp38-win_amd64.whl is not a...

Error: TypeError: can only concatenate str (not "NoneType") to str

I'm doing a vocal assistant in Python 3.8 and I use a maps url to create an itinerary. The problem is that I have an error and I have no idea how to fix it: this is my code def RecordAudio(ask =...

Debugging dockerized Django in VS Code results in error "Timed out waiting for launcher to connect"

I want to debug my Django application using a docker container in Visual Studio Code. Microsoft published a guide how to do that, which I followed step by...

How do I list databases with the python asyncio mongo client, motor?

I'm having problems get motor to list databases with asyncio. The following code: import asyncio import motor.motor_asyncio import sys async def list(): print(sys.version) ...

import _tkinter # If this fails your Python may not be configured for Tk error in python 3.8

Currently using Ubuntu 20.04 LTS with python3.8.5. Its my first time using ubuntu with absolutely no previous knowledge of terminal.SO,would love to have a detailed answer if possible. Below is...

__init__.py needed for imports to work in Pytest. But using Python 3.8

I have read that after Python 3.3, __init__.py is not required anymore, So I am not understanding why I need to add it (__init__.py) for my pytests to work. Directory structure: |- root/ |-...

Printing multiple input strings in reverse using a loop

Write a program that takes in a line of text as input, and outputs that line of text in reverse. The program repeats, ending when the user enters "Quit", "quit", or "q" for the line of text. Ex:...

Apple M1: install psycopg2 package Symbol not found: _PQbackendPID

pg_config venv ❯ which pg_config /Applications/Postgres.app/Contents/Versions/latest/bin/pg_config pip3 install -r requirements.txt requirements.txt venv ❯ cat requirements.txt -i...

fatal error: libmemcached/memcached.h: no such file or directory

I try to setup a development environment for developing on django itself. Docs: Contributing / Running the test suite for the first time python -m pip install -r requirements/py3.txt It...

how to solve numpy error while installing mxnet?

I was just running the default command to install mxnet on windows but this error popped up, I need to use mxnet in order to run insightface library, I was wondering what I did wrong What I've...

How to create a point cloud for stereovision using python 3+?

I am new to Stereo Vision, and I am trying to get the size of an object(length breadth, and height). I got a fine result on DepthMap. But I am not able to get any resource on how to plot a point...

Getting error in installing in PyAudio module

After trying countless times I still cannot install PyAudio without getting this error I have tried using many approaches including pipwin which doesn't get recognized as a real function, how can...

Ensurepip module not existing, how to install manually?

In the interest of not getting an XY problem: the goal is to create a virtual environment on synology dsm, so no apt-get, where pip is installed manually. I am trying to create a virtual...

Handshake operation timed out error while installing modules

I installed python 3.8 on my laptop. It was all fine then I was setting up modules so I can start my work I installed one module pyttsx3 then it asked to upgrade pip I did that then I had to...

VS Code can't find Python

I have a huge issue with VS Code since many weeks. One day VS Code didn't manage to run any python file. I have the message : bash:...

openpyxl load_workbook() on a legit .xlsx file leads to a zipfile.BadZipFile error

What I was trying to do is appening dataframe data to an existing legit excel file. I used load_workbook() function from openpyxl, but it systematically returns an error. Here is some code that...

ORB Demo code errors out with cv2.error: Unknown C++ exception from OpenCV code

ORB Demo code at https://opencv-python-tutroals.readthedocs.io/en/latest/py_tutorials/py_feature2d/py_orb/py_orb.html import numpy as np import cv2 from matplotlib import pyplot as plt img =...

ImportError: cannot import name 'LayerNormalization' from 'tensorflow.python.keras.layers.normalization'

I am using Python 3.8, Tensorflow 2.5.0 and keras 2.3.1 and I am trying to make a model, but I get error from keras. This is my code : import cv2 import os import numpy as np from keras.layers...

how to install pandas on m1 Mac

clang -Wno-unused-result -Wsign-compare -Wunreachable-code -fno-common -dynamic -DNDEBUG -g -fwrapv -O3 -Wall -iwithsysroot/System/Library/Frameworks/System.framework/PrivateHeaders...

WARNING: Running pip as the 'root' user

I am making simple image of my python Django app in Docker. But at the end of the building container it throws next warning (I am building it on Ubuntu 20.04): WARNING: Running pip as the 'root'...

Importing pytorch geometric results in an error message

I'm suddenly unable to import pytorch geometric and I cannot figure out why. I've added a screenshot of the packages in my conda environment and the error message that I get when I try to import...

Alphafold core dumped

I installed Alphafold algorithm as suggested by https://github.com/kuixu/alphafold However I am getting the following errors: I0826 12:08:54.630447 139693760276288 xla_bridge.py:236] Unable to...

Visual Studio 2019 with C++ has been installed but CMake can't find it

Visual Studio 2019 has been installed in my windows. I have coded c++ with it, and it doesn't have any problem with the compiler. The compiler, cl.exe, exists in this directory: C:\Program Files...

install tensorflow on python 2.7

I want to install tensorflow on python 2.7 I built environment for python 2.7 on conda(windows 10). but when I try to install tensorflow by "conda install tensorflow", I got a error massage like...

Upgrading Elastic Beanstalk environment from AWS Linux 1 to AWS Linux 2

I have an Elastic Beanstalk environment running Python 3.6 on AWS Linux 1, and I want to switch it to Python 3.8 on Amazon Linux 2. I know that I can upgrade environments using the aws CLI...

snowflake.connector.errors.OperationalError: 250003: Failed to get the response

I am trying to set up a connection with snowflake from python using a an account which is not MFA enabled, but the connection is not made.please help me with the solution to proceed further. I...

how to create a venv with a different python version

I have different venvs in my machine in which I have python 3.10. Now for a specific project, I realised that python 3.10 is not suitable as some libraries are still not compatible. Therefore when...

Error while finding module specification for 'pip' (AttributeError: module '__main__' has no attribute '__file__')

Long story short, I did a pip upgrade and a command that told it to install a bunch of dependencies in one file, and now when i try to do anything with pip, it is throwing me For example,...