apt-get install build-essential not working on vagrant through provision

I have the following in my Vagrantfile. It install vim, but it does not install nodejs, git etc. How to change it so that it run apt-get install build-essential git-core python-software-properties...

ImportError: No module named mysql.connector using Python3?

trying to import python-mysql.connector on Python 3.2.3 and receiving an odd stack. I suspect bad configuration on my ubuntu 12.04 install. [email protected]:/usr/share/pyshared$ python3 Python...

How to use gdb python debugging extension inside virtualenv

I'm running ubuntu, and installed the python-dbg package. When trying to use the installed version directly everything works great: $ gdb python2.7-dbg GNU gdb (Ubuntu/Linaro...

Catching segfault with debugger in Python

I want to debug a Python program which is often stuck. Basically, my program runs a spyne-server which accepts SOAP requests. My program is multi-threaded and sometimes, the client I use to reach...

Install pip in docker

I'm not able to install pip in Docker. Here's my Dockerfile: FROM ubuntu:14.04 # Install dependencies RUN apt-get update -y RUN apt-get install -y git curl apache2 php5 libapache2-mod-php5...

Ubuntu / DigitalOcean - Unable to fetch packages to install git on a fresh install

Just started with a fresh install of Ubuntu 14.04 on my digitalocean droplet and I'm trying to install git. My first attempt failed to install some packages - [email protected]:~# sudo apt-get install...

Error while installing python3 and pip3 in kali linux

I have use the following commands at the time of installation: tar -xvf python-3.3.0.tgz cd python-3.3.0 ./configure make sudo make altinstall sudo apt-get install...

Unable to locate gdb frame for python bytecode interpreter

I ty to get a stacktrace from the running python process, using gdb. The python is running in an virtualenv managed by pyenv, on Ubuntu 16.4. I tried this: sudo gdb...

Trying to install selenium python3 package on docker image

I've tried unsuccessfully to re-build a docker image with selenium python package on it. I'm not sure how to proceed. Here's my dockerfile: FROM selenium/standalone-chrome:latest WORKDIR...

Unable to install packages from amazon repo on AWS EC2 instance Ubuntu

I'm having an EC2 instance on AWS, contains platform as Ubuntu. I'm unable to install anything from the command line toolsudo apt-get install <package> The result pops out on screen is like >...

Django Unable to load the SpatiaLite library extension mod_spatialite on Ubuntu

I'm trying to run sqlite3 with spatialite but when i run $ python manage.py makemigrations im getting the error: django.core.exceptions.ImproperlyConfigured: Unable to load the SpatiaLite...

The following packages have unmet dependencies: postgresql-9.6

Please help, I'm trying to install a fresh install of postgres-9.6 and only that version, but I keep receiving this error when I try to run: sudo apt-get install...

How to upgrade sqlite 3.8.2 to >= 3.8.3

In a virtual Env with Python 3.7.2, I am trying to run django's python manage.py startap myapp and I get this error: raise ImproperlyConfigured('SQLite 3.8.3 or later is required (found %s).' %...

do_compile fails when building an image using the yocto-project "no such file or directory"

I tried to append a layer from git (https://github.com/sigysmund/meta-lora-net) to my Image and whenever I try to bitbake one of the recipes (the other worked), I get this error message: ERROR:...

How to fix python3 instalation on linux mint

So I've been using linux mint mate for a while, and everything was working fine. So as I got a new notebook, I installed the new version of linux mint (19.2 - Tina) alongside the windows 10....

Python: Bloomberg API Failed to get Token. No Authorisation

Trying to use the IntradayTickExample code enclosed below. However I kept getting the following message. It says about authorization so I guess its getting stuck in the main. But I have no idea...

Cannot debug python3 program using gdb (py-locals fails)

Please find below my dummy program import time import random while True: print('.', end='', flush=True) a = random.randint(1,3) b = a*2 time.sleep(1) I'm running it as...

minidump stackwalk vs gdb backtrace

I have a vulnerability trigger (CVE-2018-18492) in Firefox, which crashes and gives SIGSEGV. I used breakpad minidump_stackwalk to get its stack trace from the minidump file produced with the...

Python3 CTypes error loading dylib on Mac 10.14 (Mojave)

Background I have read countless GitHub project threads and everything I can find on StackOverflow about this problem, though so far no luck. I have a Mac 10.14 box running with the stock...

How to install ansible 2.9+ on ubuntu 18.04 and utilize python3?

I'm trying to install minimal ansible 2.9.x on Ubuntu Bionic (18.04 LTS). The final goal is to build new disk image (using packer) on every commit and want the process to be as fast as...

Google Cloud VM startup script fails to install pip3

I'd like to pass a startup-script to my free f1-micro instance VM in GCP. The command that I'm specifying is the following: gcloud compute instances create dora-scanner --zone=us-central1-a...

Docker container random segmentation fault

I am trying to run an application on a Docker container, but the program is randomly generating segmentation faults. Sometimes the code runs as it is supposed to. Other times, when I interrupt its...

opencv do_compile bitbake error because of undefined opencl sample code header

I add my bblayer.conf with meta-openembedded layer in order to install opencv library on my 64-bit image. But on 99% do_compile() phase, it gave me error which it seems opencl header (CL/cl.h) on...

SyntaxError (amazon-sagemaker-stock-prediction/dbg-custom-rnn.ipython)

I'm running the code cell below from https://github.com/aws-samples/amazon-sagemaker-stock-prediction/blob/master/notebooks/dbg-custom-rnn.ipynb , on SageMaker Notebook instance. For more...

Corrupted python package in ubuntu18.04LTS(WSL)

I am a newbie of ubuntu, thanks for reading this thread. I was trying to remove and reinstall pip and python2.7, python3.6, python3.8 etc... However I corrupt it somehow,and don't know how to fix...

Flashing ESP8266 with a LittleFS binary

I'm trying to build a LittleFS file system binary on my PC and flash it to my WeMos D1 Mini Pro (16MB) ESP8266. I used the following code on the ESP LittleFS.begin() FSInfo info; ...

Running Faust with kafka crashes with ConsumerStoppedError

I freshly installed Faust and ran a basic program to send and receive messages over Kafka.I used the sample code mentioned in...

Unmet dependencies (venv & ensurepip) error when running erdpy-up

Trying to install erdpy fails with the following error: $ python3 erdpy-up.py INFO:installer:Checking user. INFO:installer:Checking Python version. INFO:installer:Python version:...

Broken package installation using Ansible on debian 11 Bullseye

I woud like to install debian packages using Ansible 2.7.7 on Debian testing (yet) I try to execute this simple task: tasks: - name: install basic packages apt: name: ['mc', 'htop',...

QA Issue: Package version for package went backwards which would break package feeds [version-going-backwards]

I'm trying to build a core-image-minimal image using an updated recipe of Yocto 3.1 (pytest from 5.x.x to 6.x.x) that has been successfully builded with devtool build. The work has been added to a...