From virtualenv, pip freeze > requirements.txt give TONES of garbage! How to trim it out?

I'm following this tutorial: http://devcenter.heroku.com/articles/django At some point I'm suposed to do: pip freeze > requirements.txt (Ofc. from virtualenv created instance of python) And I...

ImportError: No module named psycopg2.extensions when rubber gem

I get this error when i call cap rubber:create_staging Im using a Ubuntu machine. so far i have been mainly focusing on making changes to local_settings.py but did not get anywhere with...

Why is the command 'sudo pip uninstall' not working?

When I type the following command in Ubuntu, it is showing all list of python packages: $ sudo pip list adium-theme-ubuntu (0.3.2) apt-xapian-index (0.44) apturl (0.5.1ubuntu3) argparse...

pyvenv-3.4 pip freeze showing multiple packages in new environment

I am using pyvenv-3.4 on Ubuntu 12.04 and just created my first virtual environment. After activating i checked to see that no packages had been installed using pip freeze and found the following...

python pip trouble installing from requirements.txt

I've had great luck with pip in the past, but working at installing some stuff in a venv on is giving me some headaches. I keep getting errors like No distributions at all found for...

Failed to load libGL.so when running Flask app on Heroku

I'm trying to run my Flask application on Heroku. After git push heroku master I run heroku open and get the following error. What does this it mean and how can I fix...

Manage python packages in Sublime text 3

Working with Ubuntu 14.04 How to tell Sublime text 3 and SublimeREPL where to look for the python packages? From my terminal, pip list returns a list with many python packages like that: numexpr...

Flask debug depends on tkinter, sometimes

When I try to import non-standard modules into my Flask app with debug mode on and run it locally, the Flask server crashes with an ImportError for _tkinter. If I remove the import for the...

Installing NPM on Ubuntu 14.0 giving python 2.7 dependency issue

I am installing npm on the ubuntu 14.0. It is already having installed python 2.7.11. It is showing the following error. Building dependency tree Reading state information... Done ...

equivs dummy package version number syntax

I try to create a dummy package with equivs that provides the python-oauthlib package for apt. The problem is that most dependency issues are resolved, except for one package that has a version...

numpy asarray float32 works on Ubuntu but not Windows 7

Update Critique would be nice if a downvote is necesarry. Question has been modified since. I followed the instructions here Steps 1 and 2 have been checked. My Intel(R) Core(TM) i7-2860QM CPU @...

apt-get upgrade, apt-get install not working.

I recently updated Python 2.7.6 to Python 2.7.12. Since then, when I run apt-get upgrade or apt-get install or apt-get autoremove` I get the following error: Reading package lists... Done Building...

gunicorn is corrupting sys.path

I wrote a simple python program: # /tmp/src/Code.py import sys print sys.path # /tmp/src/Main.py import Code When I run it with python src/Main.py, it works as expected: max% cd /tmp max%...

Thread-Safe Signal API in Python 2.7

I have a multi-threaded program and want to catch SIGINT. I tried using the signal interface but it appears to stop doing anything when the program uses threading. What is the correct signal API...

How to properly handle conflicting distutils libraries with pip?

After upgrade of pip version to 10.0.0, installation with pip fails when there is a version conflict with a distutils installed package: Cannot uninstall '***'. It is a distutils installed project...

ssl handshake failure using proxy for scrapy

I'm trying to setup a proxy on a scrapy project. I followed te instructions from this answer: "1-Create a new file called “middlewares.py” and save it in your scrapy project and add the...

apt-get install halted because of too many errors

So it all started when I somehow broke python3, running it (even just the repl) resulted in the following error: [1] <some four-digit number> Illegal hardware instruction python3 I decided to try...

Why do Python plots look so different on different remote machine?

I have a python script that produces a plot, and I run it on a remote machine. The panels and font in the plot are perfectly proportioned, and look as I want them to. I have recently run the...

Spyder 2.2.5 is giving "You should import from qtconsole instead.", ShimWarning

my issue, spyder 2.2.5 stopped running any code. first of all, I have wanted to install ipywidgets but I can't because of python 2.7.6. I updated python 2.7.6 to 2.7.12, then installed ...