'module' object has no attribute 'OSMGeoAdmin'

The enviroment is as follows: **Windows 7** PATH=C:\Python27\;C:\Python27\Scripts;C:\Python27\Lib\site-packages\MySQLdb;C:\Program Files\MySQL\MySQL Server 5.5\bin;C:\OSGeo4W\bin **python...

can't compile avahi on android

I am a newbie in cross compilation and I was assigned the task to use the android patch http://avahi.org/ticket/354 to compile avahi core to android. ndk-build avahi-configure V=1 was successful,...

Problems compiling avahi into Android NDK project

Over the last few days I've been having a difficult time trying to build avahi into a static or shared library for use with an existing Android NDK project. We have a few games in the App and Play...

"import babel.dates" gets me permission denied

In python, when I run import babel.dates I get a permission denied: Python 2.7.5+ (default, Jun 5 2013, 10:40:07) [GCC 4.8.1] on linux2 Type "help", "copyright", "credits" or "license" for more...

Unable to install matplotlib on Mountain Lion

I am struggling to install matplotlib 1.2.1 on Mountain lion. I am NOT using homebrew or easy install. I am compiling using python setup.py build and install. If I try and use homebrew I get...

How to use Qt libraries in ros

Hi dear I'm working with Ubuntu 12.10 and ros hydro I want to use Qt libraries in ros. So I try to use simple library like "QDebug" and I write this program and Cmake #include "QDebug" #include...

Cannot connect (null) error in a gis application

I'm trying to use QgsMapCanvas() in my pyggis script but I don't get the result I want getting this message instead: QObject::connect: Cannot connect (null)::repaintRequested() to...

How safe is it to cache dependencies built from source in Travis CI

This question regards the caching capabilities of Travis CI. My project (quamash) has some pretty weird dependencies. It needs to be tested 6 times once with PySide, once with PyQt4 and once with...

Installing MySQL 5.6 in Ubuntu 14.04 triggers removal of needed packages

So I was trying to make a fresh installation of MySQL 5.6 on Ubuntu 14.04.2 and for some reason it tried to remove needed packages, not without first complaining about some unmet dependencies....

Unrecognized command line option '-Xarch_x86_64' in PyQt4 installation on mac

I made sure to try installing PyQt4 on mac in many different ways, but I always get the error above. My attempts have in common installing Python 3.4 from the official website installer, then...

Where can I find the QWebPage and pymongo in python3.4?

I'm working on some code that requires a number of packages from python qt 5. I get a missing package error upon importing the QWebPage module: from PyQt5.Qt import QWebPage,...

Install PyQt4 with Python3 on Travis CI

I'm trying to make at least one successful build on Travis CI but no luck so far (7 errored builds) The problem is that I use PyQt4 and it seems to be too complicated to make it work with...

Rstudio on Gentoo with qt = no workspace variable and file list text

I'm trying to fix the problem of no text when I run rstudio at my gentoo. My gentoo is configured with the necessary use flags to be almost pure QT5 desktop. I have tested from rstudio-0.98.1091...

I can't install pycharm due to Sub-process /usr/bin/dpkg returned an error code (1)

I've recently install anaconda and I'm using PyCharm as my IDE, but when I go to import some modules, they don't seem to exist, even though they were downloaded with anaconda. When I tried to...

vollib issue after pip install

I have installed vollib module as follows: [[email protected] boris]# python -m pip install vollib Collecting vollib Using cached vollib-0.1.5.tar.gz Requirement already satisfied: lets_be_rational in...

apt-get upgrade, apt-get install not working.

I recently updated Python 2.7.6 to Python 2.7.12. Since then, when I run apt-get upgrade or apt-get install or apt-get autoremove` I get the following error: Reading package lists... Done Building...

How to install clang on ubuntu14.04

I want to learn llvm so I have to install clang in my ubuntu 14.04,but I encounter some problems.Here it is: when I execute command:sudo apt-get install clang-3.5 I just get some error message...

Broken apt dependency tree

I was upgrading Ubuntu 16.04 to 17.04, when some packaged failed to upgrade. This left the apt dependency in a broken state. I tried some other answers online, but I am afraid this only...

Bitbake error openembedded-core/meta/recipes-connectivity/openssl/openssl_1.0.2j.bb:do_compile) failed with exit code '1'?

UPDATE: bitbake core-image-minimal without any added layers gives me errors such as: ERROR: Task...

Git issue Bitbake gets stuck at do_fetch?

These are the contents of my git2 folder: [email protected]:~/repositories/oe-core/build/downloads/git2$ ls anongit.freedesktop.org.pkg-config ...

PySide2 equivalent of PyQt5's loadUiType() to dynamically mix in UI designs

TL;DR: I want a drop-in replacement for PyQt5's loadUiType() function from its uic module that works with PySide2 and Python 3.6+. I want to migrate a PyQt5 application to PySide2. A common...

How to fix a problem that "apt-get install" doesn't work because of python issue

I'm using Ubuntu 16.04.I'd like to install a ROS related package with "apt-get install", but it doesn't work. Terminal said like following. $ sudo apt-get install ros-kinetic-libuvc Reading...