Django runserver error: unsupported operand type(s) for +=: 'NoneType' and 'str'

I'm running a local dev project made with Django. But I cannot have the dev server to start: (Gaia_database_env)FakeComputer:gaia_database_proj FakeUser$ python manage.py runserver Traceback (most...

Why is python setup.py saying invalid command 'bdist_wheel' on Travis CI?

My Python package has a setup.py which builds fine locally on Ubuntu Trusty and on a fresh Vagrant Ubuntu Trusty VM when I provision it like this: sudo apt-get install python python-dev...

Tensorflow: Not a supported wheel on this platform

I've installed both anaconda 2 and 3 in a Windows 64bit machine. I'm trying to install Tensorflow with anaconda as per the instructions here. However, I'm getting the following error while doing a...

Ubuntu Python: unable to pip install dlib - Failed building wheel for dlib and machine is almost stuck

I am trying to install dlib (machine learning library) for my django python environment. however, i cant get it installed. there is error and stuck. based on this instruction, this is what I did...

pip3 install not working - No module named 'pip._vendor.pkg_resources'

When trying to install a package for Python 3 (in Ubuntu), using pip3 install packageName (or sudo pip3 install packageName), I get the following error message: Traceback (most recent call last): ...

Failed building wheel for mujoco-py with OpenAI Gym

I followed the installation instructions for OpenAI Gym, but the full install gives the error "Failed to build wheel for mujoco-py" pip install gym and import gym work fine on my laptop and import...

"Failed building wheel for regex" while installing pip package

I am having issues installing a pip package on Windows 10 WSL running Debian Stretch. While running sudo pip install invoice2data, with python3-pip installed I run into following errors. error:...

Error installing gevent in Docker Alpine Python

I'm trying to install gevent on docker image python:3.8.0a4-alpine3.9 which is running gunicorn. When building the docker, I always get an error "gcc failed with exit status 1". I've tried...

library pocketsphinx not downloading using pip or binary files

I am working on a speech recognition software and wanted to test out pocketsphinx and have tried to install it using pip on windows 10 python version 3.8 and it wont download usually i would fix...

Failed to fetch packages from jonathonf repository while running Dockerfile from AzureDevOps

I have a Dockerfile which is getting the packages from a source called jonathonf but it's failing to download some packages from this repository. Could any one please help me with the solution? I...

Issue while installing Postal (Address Parser ) package of python

I am trying to install postal package using pip install postal I am following the steps mentioned in link https://github.com/openvenues/libpostal#installation-windows I have installed Visual...

OpenCV-python not importing

I am using Pydroid to code in android. Though it is an ARM machine so I downloaded OpenCV-python wheel from PiWheels and successfully installed it using pip. But i can't import OpenCV anyways....

How do I install netfilterqueue for python3?

I am doing a project with python3.8 as my interpreter in pycharm. How do I install netfilterqueue so that it works in python3? I have tried to run the following command in my kali terminal but I...

ERROR: Could not build wheels for scipy which use PEP 517 and cannot be installed directly

I'm trying to install scipy via pip on my 64 bit ARMV8 board. I have already installed openblas which is required by scipy. So, no issues with that. When i gave pip3 install scipy --trusted-host...

Anaconda and upgrading to new M1 Mac

Background I've just got a new M1 mac mini dev machine, and migrated from my old x86 mac using apple's migration assistant. Doing that also copied over all my conda environments to the new machine...

Why do I get error "Could not find a version that satisfies the requirement scipy==1.5.3" when running "pip install -r requirements.txt"?

I am trying to install all needed modules for an existing Django project. When I run pip install -r requirements.txt I get the following errors: ERROR: Could not find a version that satisfies the...

How to get rid of cryptography build error?

I am trying to build a dockerfile but the problem is when it trying to build specifically cryptography is not building. MY Dockerfile FROM python:3.7-alpine ENV PYTHONUNBUFFERED 1 RUN apk update...

Why do I get "HTTP Error 404: Not Found" when installing pyaudio with pipwin in Python Django project in Windows 10?

I'm trying to install pyaudio with pipwin in a Python Django project in Windows 10. I first run CMD as admin in Windows 10. Then I run the command: pipwin install pyaudio and I get the following...

Docker Alpine executable binary not found even if in PATH

I have an alpine running container which contains some binaries in usr/local/bin When I ls the content of usr/local/bin I got this output : /usr/local/bin # ls dwg2SVG dwg2dxf dwgadd ...

Cannot deploy dataflow template because of requirements file

I'm deploying a dataflow template in python from my local virtual environment, which threw a bunch of unintelligible issues that end like this: Discarding...

unable to install awscli using pip on dind 18.09.6-dind due to cython dependency

I saw a strange issue just most of yesterday where while running a simple jenkins build that uses pod template with container docker:18.09.6-dind (alpine linux) the build would fail while trying...

How to fix errors occurring on installation of Jupyter Notebook?

I am new to Python and try to install Jupyter Notebook from within a Windows command prompt window using: pip install jupyter But after a couple of minutes of downloading, an error message is...

Error while uploading python package with Azure Pipelines

I am trying to use Azure Pipelines to build and submit the package to Azure Artifacts feed. The azure-pipeline file: - script: | pip install wheel pip install twine displayName: 'Install...

How to install PyQt5 on MacOS?

I try to install PyQt in my Mac by pip or brew to install, it all failed with sipbuild.pyproject.PyProjectOptionException error. Need help can someone solve this? [email protected] ~ % pip install...

Getting an error saying "Could not build wheels for numpy which use PEP 517 and cannot be installed directly" while installing numpy

I am trying to install a specific version of numpy using the command pip install numpy=1.19.1 in a python virtual environment. But I am getting the following errors ERROR: Failed building wheel...

I can't install libpostal library on Windows

I am having a hard time trying to install the library libpostal on a Windows system. I tried many times to install this library even with an other computer, but I didn't succeed. I have followed...

How to fix Import Error of CyLP on M1 Mac?

I want to use the CyLP package (https://github.com/coin-or/CyLP). My OS is macOS Big Sur 11.5.1. I am using Python 3.8.8 via anaconda3. Following the instructions in the README, I first installed...

Binance Api Python setup

I created a Bot to trade BTC with Binance and am currently trying to set my Raspberry Pi 3 B+ up. With every pip install python-binance I get Using cached backports.zoneinfo-0.2.1.tar.gz (74...

How to fix PyQt6-tools installation error?

I want to create my small GUI app with PyQt6. I've installed PyQt6, but I also have to install PyQt6-tools. So, when I tried to get it, I got this error: C:\Users\egorl>pip install...

pycharm error happening at random time: Process finished with exit code 134 (interrupted by signal 6: SIGABRT)

I am working with pycharm community on a tensorflow model with keras backend, sometimes this error appears in a random time, specially after I call pyplot and close the window: Exception ignored...