Install pip in docker

I'm not able to install pip in Docker. Here's my Dockerfile: FROM ubuntu:14.04 # Install dependencies RUN apt-get update -y RUN apt-get install -y git curl apache2 php5 libapache2-mod-php5...

No module named 'beautifulsoup4' in python3

$ virtualenv test $ source test/bin/activate $ pip3 install beautifulsoup4 Now the script test.py import urllib.request import sys import unittest, time, re import requests from bs4 import...

ImportError: No module named 'config.settings'; 'config' is not a package

I'm trying to get my cookiecutter-django app running under Apache with mod_wsgi installed via pip. python3 manager.py runserver works. But after running it in Apache, I got an error saying Module...

Import error: No module named 'scipy._lib'

I'm using pythonanywere.com to deploy my Django application. So I've installed a few machine learning libraries to that virtual environment. (venv) 19:16 ~ $ pip3 list Package Version ...

Failed building wheel for xmlsec - mac

I'm installing my mac on python virtualenv environment. Whenever I install requirement packages command "pip install -r requirements.txt" i got this messages. pip install -r requirements.txt...

How to fix ModuleNotFoundError in azureml-sdk when installed inside conda environment

I'm setting up a conda environment on Windows 10 Pro x64 using Miniconda 4.5.12 and have done a pip install of azureml-sdk inside the environment but get a ModuleNotFoundError when attempting to...

Cuda Runtime Error cudaErrorNoDevice: no CUDA-capable device is detected

I am using Chainer, Cupy for CUDA 8.0 . I am trying to train machine learning model using python3.5 script, but I got this error: cupy.cuda.runtime.CUDARuntimeError: cudaErrorNoDevice: no...

Django, Docker, Python - Unable to install Pillow on python-alpine

I have a dockerized django app that I want to put in production. But ever since I added an Imagefield Pillow is required and I struggle to install Pillow in the Docker container. As far as I...

django.db.utils.InterfaceError: (0, '') when using django model

I have django.db.utils.InterfaceError: (0, '') error on django. I googled around and found this error is related with django mysql connection. What I have done is just like this , from...

Kivy app build successfully using buildozer but crashes when opened on android phone

I'm building an app using kivy and it works perfectly on my Linux laptop. I build the app for android using buildozer and the log does not show any errors. When it was complete, the apk file is...

What is the correct way to put Python version and requirements in buildozer spec file?

This is really confusing when using buildozer to build Kivy apps for Android or iOS. The right way to put the dependencies and requirements in the buildozer spec file is not provided in the...

How to activate virtual envirooment for existing django project using pipenv in python 3.8

I developed a Django webapp project using Django 2.2.1 in python 3.7.2 in a pipenv version 2018.11.26 virtual environment in MacBook Air. After an unintentional update to python 3.8 using brew...

python : While installing requirements dlib error showing on ubuntu 16.04 web server

I am trying to install the requirements of face recognition python api on webserver but it is giving me error in last , below is the list of...

Apple M1: install psycopg2 package Symbol not found: _PQbackendPID

pg_config venv ❯ which pg_config /Applications/Postgres.app/Contents/Versions/latest/bin/pg_config pip3 install -r requirements.txt requirements.txt venv ❯ cat requirements.txt -i...

ERROR: Failed building wheel for psycopg2 (Ubuntu 20.04 + Python 3.8.5 + venv)

Greetings wisdom from Stackoverflow! I'm having issues building wheel for psycopg2 thru pip install -r requirements.txt. I'm on ubuntu 20.04 + python 3.8.5 + venv. This is my...

kivymd app crashes on android phone ModuleNotFoundError: No module named 'PIL'

My Kivy app crashes on launch on android phone. buildozer logcat shows the following error: 02-21 17:09:58.777 14941 14979 I python : ModuleNotFoundError: No module named 'PIL' 02-21...

Using apache-airflow-providers-snowflake on airflow (no module named Snowflake)

I have installed package apache-airflow-providers-snowflake on airflow on docker and i am getting error No module named Snowflake Please refer attachment (check the error mentioned for the...

Error when running executable generated by pyinstaller [pyvisa-py]

I'm trying to build an executable from a simple python script using pyvisa-py but I'm running into error after I run the executable generated by pyinstaller. Here what my small python code looks...

Im trying to build mediapipe on my jetson nano

So Im trying to build a mediapipe whl file for my jetson nano by following this guide https://github.com/jiuqiant/mediapipe_python_aarch64 I am successful on building it with my raspberry pi 4. By...

NameError: name '_mysql' is not defined -- On airflow start in MacOSX

There are numbers of articles on the titled question but none of them worked for me. The detailed error is as follows: Traceback (most recent call last): File...

ERROR: Could not build wheels for pandas which use PEP 517 and cannot be installed directly

I am using Docker with my dockerfile as: FROM python:3-alpine WORKDIR /app COPY ./requirements.txt . RUN apk update && apk add postgresql-dev gcc python3-dev musl-dev libffi-dev RUN pip install...

Kivy apk built by buildozer crashes soon after displaying presplash screen

I am new to Kivy and using buildozer. However, I've followed the instructions from buildozer.readthedocs and run "buildozer -v android debug deploy run logcat > my_log.txt" as best as I can, yet,...

Building wheel for cffi (setup.py) ... error while installing the packages from requirements.txt in django

I am trying to install a new Django project from git, I created a new virtual envt using python3(version: 3.8.5). When I try to install the required libraries in the requirements.txt, I get the...

run Python in GraalVM - `import requests` fails with Exception: You need either charset_normalizer or chardet installed (requests init failure)

I try to run Python script in GraalVm and it fails on import requests And it seems GraalVM issue, as the script work with usual python3. Java code: import org.graalvm.polyglot.Context; import...

How to fix strict error when loading RoBerta using PyTorch

Any tips on how to fix this? Trying to follow the basic torch guide here: https://pytorch.org/hub/pytorch_fairseq_roberta/ but running into this error: <ipython-input-16-53ecab33b355> in <module> ...

Locust-plugins Unhandled exception in greenlet: <Greenlet at 0x7fde698e57b0: <lambda>>

I've switched to Ubuntu to get a Locust/Selenium solution going. I'm running a very simple script but when running the script through the WebUI I'm receiving an exception error: Unhandled...

Cannot open camera using cv2.VideoCapture(0) in android phones

I need to create an android application using OpenCV VideoCapture() method with python kivy framework. Please note I'm not going to use KivyCamera available on Kivy, because I need to draw some...

Django mod_wsgi Apache Server, ModuleNotFoundError: No Module Named Django

I read ton of articles, but still can't figure out what I'm missing. I'm running a django website from virtualenv. Here's my config file. The website address is replaced by <domain.com>, can't use...

Poetry | AttributeError 'Link' object has no attribute 'name'

I want to install packages from poetry.lock file; using poetry install. However, the majority of packages throw the exact same error, indicating a shared fundamental problem. What is causing this?...

Tensorflow Object Detection API taking forever to install in a Google Colab and failing

I am trying to install the Tensorflow Object Detection API on a Google Colab and the part that installs the API, shown below, takes a very long time to execute (in excess of one hour) and...