Error installing Eric5 on Ubuntu 13.04 (cannot impot name Qsci)

I've mostly been following the directions here http://ubuntuforums.org/showthread.php?t=1865840 to get Eric5 running. I've had no success so far. I've built everything from source, but when I try...

How do I deploy a Python PyQt5 Application to an embedded Linux?

I've written a Python3 application which uses PyQt5 for the GUI, it runs fine on every desktop system. Now I would like to run this on an embedded linux (specifically: Yocto BSP) which is...

Installing PyQt-gpl-5.5.1 and sip for python 3.4.3+

I'm trying to install eric6-6.1.2 which requires PyQt-gpl-5.5.1 which tells me during python3 configure.py Error: Make sure you have a working sip on your PATH or use the --sip argument to...

PyQt5 installation error (QtCore Module Error: Unable to create the C++ code)

I'm trying to install PyQt5 on my PC to have access to QtDesigner. I'm facing following error during the installation: $ python3 configure.py --qmake=/usr/local/Cellar/qt/5.10.1/bin/qmake...

PyQt5 error "PyCapsule_GetPointer called with incorrect name"

I've just built PyQt5 in a pyenv virtualenv with python 3.6.3 on OpenSUSE leap, the build went fine, but when I import >>> from PyQt5 import QtCore Traceback (most recent call last): File...

Dependency problems in Debian Stretch

I have a pretty fresh installation of Debian GNU/Linux 9 (stretch). I have installed python3.7.2 and some python-packages. After attempting to install spyder3 using sudo apt-get install...

python3-pjsip(pjproject2.9 pjsua) custom sdp

I have a lab that I need to insert a custom body (SDP) in SIP message. I'm using python3-pjsip(pjproject2.9) to create simple SIP UA. However, python3-pjsip(pjproject2.9) does not support custom...

No matching distribution found for PyQt5

I install a rasbian os on my vmware workstation and I am currently trying to install some packages and modules. I have a problem with pip. I try: sudo pip install PyQt5 sudo pip3 install...

Can't install PyQt5 using pip on raspberry pi

On a raspberry pi using raspbian buuster, am I trying to install PyQt5 using pip install PyQt5 pip3 install PyQt5 sudo -H pip install PyQt5 python3 -m pip install PyQt5 python3 -m pip install...

How install python3-poppler-qt5 on my mac

I am looking to install this software (https://github.com/alexisflesch/texamator) on my mac. For that, I install Python, but I also need to install python3-pyqt5 and python3-poppler-qt5. But I...

Can't install PyQt5 On Raspberry pi

I can't seem to install PyQt5 on raspberry pi using: sudo python3 -m pip install --trusted-host pypi.python.org --trusted-host files.pythonhosted.org --trusted-host pypi.org pyqt5. I just have ran...

Install PyQt5 5.14.1 on Linux

pip3 install PyQt5 Collecting PyQt5 Using cached https://files.pythonhosted.org/packages/3a/fb/eb51731f2dc7c22d8e1a63ba88fb702727b324c6352183a32f27f73b8116/PyQt5-5.14.1.tar.gz Complete...

How to use Asterisk AGI with python3?

Using Asterisk 16.2.1 my AGI script (at the bottom) works with python2 #!/usr/bin/env python2, but not with python3 #!/usr/bin/env python3. I do not even get as far as agi.verbose("python agi...

PJSUA2 / PJSIP Python Real-Time Audio Streams

currently im writing a script using PJSUA2 in Python3. The goal of the script is to make voice-calls using SIP. The script is working so far. With createRecorder() and createPlayer() and...

Difficulty installing/importing pyqt5 on ubuntu 18.04

Goal: To import pyqt5 into python3 under Ubuntu 18.04 I know there are many answers to similar questions here and elsewhere. I have tried a lot of them, but I don't see anything that exactly...

Accessing Python Modules Installed with Brew

I am trying to access "rdkit" module in python, but my python install doesn't seem to find the module. I installed it using brew as suggested here. I included the commands I use to reproduce the...

Failed Quantlib / Quantlib SWIG installation: undefined symbol

Wonder if you can help me. I am trying to install Anaconda / Boost / Quantlib for a financial markets proof of concept (determining counterparty potential forward exposure using Spark). I am using...

How do I not get OSError: [Errno -9993] Illegal combination of I/O devices when using pyaudio

I believe it's this module that's crashing my program and throwing this error: OSError: [Errno -9993] Illegal combination of I/O devices. I wrapped the call to this module in a try except...

Msys2: Maintaining two python installations

I am using Msys2 portable under Win 10. I have 2 python 3.8 installations. The original question asked if that is so. I am now certain it is, so for the time being I want to deal with their...

Python3 Scapy custom payload from string

Intro I am using python3 and scapy to modify and resend a captured packet. The issue When I send the modified payload in the Raw section the \r and \n parts of the message are not interpreted as...

Python3 (pip): find which package provides a particular module

Without getting confused, there are tons of questions about installing packages, how to import the resulting modules, and listing what packages are available. But there doesn't seem to be the...

Direct URL SIP Client for Python3 (Windows and Linux)

I have a SIP URL. I would like to connect to this SIP URL with python. I would also like to record the session. OS: Windows 10 (should also work on Linux) Python Version: Python 3.8.3 64-bit

Unable to install PyQt5 on Raspberry Pi

I am trying to install PyQt5 on my Raspberry Pi machine. I have tried: pip3 install pyqt5 pip3 install --upgrade pip pip3 install pyqt5==5.14.0 sudo apt-get update sudo apt-get install...

Project ERROR: Unknown module(s) in QT: x11extras

I'm trying to build the pyqtdeploy-sysroot containing Qt5 and PyQt5 for the current machine (x86_64 system). I tried Qt5 versions 5.15.0, 5.15.1 or 5.15.2 on a Fedora 30 (tried 31 and 32 as well...

how to fix read-only file system error python

I am trying to make a python script that runs the command line for turning a file into a .zip using python3 on my Mac. However, whenever I run: os.system('zip -er file.zip...

How to install the PyQt5?

I have been searching to resolve this problem for two days. I tried a lot of ways, searched the answer on google, but didn't find a single solution to the problem. I want to know why PyQt5 is not...

QObject::moveToThread: Current thread (0x7fec075fd3a0) is not the object's thread (0x7fec07e67800). Cannot move to target thread (0x7fec075fd3a0)

I am trying to compile my Python 3.9 script with PyInstaller on my MAC OS Catalina: MAC OS CATALINA 10.15.6 Python 3.9 Pyinstaller 4.2 My script has a GUI made of PyQt5. If I do a “pip freeze”...

How to install PyQt5 on MacOS?

I try to install PyQt in my Mac by pip or brew to install, it all failed with sipbuild.pyproject.PyProjectOptionException error. Need help can someone solve this? [email protected] ~ % pip install...

How to fix strict error when loading RoBerta using PyTorch

Any tips on how to fix this? Trying to follow the basic torch guide here: https://pytorch.org/hub/pytorch_fairseq_roberta/ but running into this error: <ipython-input-16-53ecab33b355> in <module> ...

Unable to install PyQt5 with pip

Im running into a problem installing PyQt5 with pip: pip install pyqt5 DEPRECATION: Configuring installation scheme with distutils config files is deprecated and will no longer work in the near...