Install pip in docker

I'm not able to install pip in Docker. Here's my Dockerfile: FROM ubuntu:14.04 # Install dependencies RUN apt-get update -y RUN apt-get install -y git curl apache2 php5 libapache2-mod-php5...

ImportError: No module named 'thread'

when I run mitmproxy command in command line, I get the following error. % mitmproxy Traceback (most recent call last): File "/usr/local/bin/mitmproxy", line 7, in <module> from...

How to install OpenCV+Python on Mac?

I am trying to install OpenCV+Python on Mac. I am trying to do this in six steps by running commands at terminal (after step2): Step1: Install Xcode Step2: Install Homebrew Step3: Install Python2...

ImportError: No module named 'config.settings'; 'config' is not a package

I'm trying to get my cookiecutter-django app running under Apache with mod_wsgi installed via pip. python3 manager.py runserver works. But after running it in Apache, I got an error saying Module...

Import error: No module named 'scipy._lib'

I'm using pythonanywere.com to deploy my Django application. So I've installed a few machine learning libraries to that virtual environment. (venv) 19:16 ~ $ pip3 list Package Version ...

Failed building wheel for xmlsec - mac

I'm installing my mac on python virtualenv environment. Whenever I install requirement packages command "pip install -r requirements.txt" i got this messages. pip install -r requirements.txt...

How to fix ModuleNotFoundError in azureml-sdk when installed inside conda environment

I'm setting up a conda environment on Windows 10 Pro x64 using Miniconda 4.5.12 and have done a pip install of azureml-sdk inside the environment but get a ModuleNotFoundError when attempting to...

Cuda Runtime Error cudaErrorNoDevice: no CUDA-capable device is detected

I am using Chainer, Cupy for CUDA 8.0 . I am trying to train machine learning model using python3.5 script, but I got this error: cupy.cuda.runtime.CUDARuntimeError: cudaErrorNoDevice: no...

Module 'tensorflow' has no attribute 'contrib'

I am trying to train my own custom object detector using Tensorflow Object-Detection-API I installed the tensorflow using "pip install tensorflow" in my google compute engine. Then I followed all...

Django, Docker, Python - Unable to install Pillow on python-alpine

I have a dockerized django app that I want to put in production. But ever since I added an Imagefield Pillow is required and I struggle to install Pillow in the Docker container. As far as I...

django.db.utils.InterfaceError: (0, '') when using django model

I have django.db.utils.InterfaceError: (0, '') error on django. I googled around and found this error is related with django mysql connection. What I have done is just like this , from...

Kivy garden mapview deploying error with Buildozer

I am using kivy.garden.mapview for my application. Everything works properly, but problems arise when I try to deploy the application to Android with Buildozer. I set "garden_requirements =...

Kivy app build successfully using buildozer but crashes when opened on android phone

I'm building an app using kivy and it works perfectly on my Linux laptop. I build the app for android using buildozer and the log does not show any errors. When it was complete, the apk file is...

Installing OpenCV fails because it cannot find "skbuild"

I have a docker image that I need to install openCV in it and from yesterday it started to fail because it cannot find the "skbuild" module: Step 12/24 : RUN pip install opencv-python...

How to activate virtual envirooment for existing django project using pipenv in python 3.8

I developed a Django webapp project using Django 2.2.1 in python 3.7.2 in a pipenv version 2018.11.26 virtual environment in MacBook Air. After an unintentional update to python 3.8 using brew...

Apple M1: install psycopg2 package Symbol not found: _PQbackendPID

pg_config venv ❯ which pg_config /Applications/Postgres.app/Contents/Versions/latest/bin/pg_config pip3 install -r requirements.txt requirements.txt venv ❯ cat requirements.txt -i...

Unable to install pip azure-cognitiveservices-speech within a docker container

Original Issue I'm unable to install azure-cognitiveservices-speech within a docker container using pip. My container is running fine and is able to install all other packages (django,...

ERROR: Failed building wheel for psycopg2 (Ubuntu 20.04 + Python 3.8.5 + venv)

Greetings wisdom from Stackoverflow! I'm having issues building wheel for psycopg2 thru pip install -r requirements.txt. I'm on ubuntu 20.04 + python 3.8.5 + venv. This is my...

Error installing apache-airflow: "Could not build wheels for setproctitle which use PEP 517 and cannot be installed directly"

I'm trying to find some help installing apache-airflow. I am on MacOS 10.15.7, Python version 3.8.2, and I keep getting an error: ERROR: Could not build wheels for setproctitle which use PEP 517...

Module Six has no attribute ensure_text

Out of the blue, my python installation seems to have broken. When trying to run a python script, I get the following... [[email protected] ~/Code/CTF/aero/house]$ ./solve.py Traceback (most recent...

NameError: name '_mysql' is not defined -- On airflow start in MacOSX

There are numbers of articles on the titled question but none of them worked for me. The detailed error is as follows: Traceback (most recent call last): File...

Building wheel for cffi (setup.py) ... error while installing the packages from requirements.txt in django

I am trying to install a new Django project from git, I created a new virtual envt using python3(version: 3.8.5). When I try to install the required libraries in the requirements.txt, I get the...

AWS EMR pandas conflict with numpy in pyspark after bootstrapping

After launching cluster with the below bootstrap code and getting the below stdout, when I try to import pandas in pyspark, i get the following error due to conflict with a different numpy version...

python packages not being installed on the virtual environment using ubuntu

I have a requirements.txt file which holds all information of my python packages I need for my Flask application. Here is what I did: python3 -m venv venv source venv/bin/activate sudo pip...

Installing pynput results in ERROR: Command errored out with exit status 1

Im trying install pynput by using pip install pynput and output like this $ pip install pynput Collecting pynput Using cached pynput-1.7.3-py2.py3-none-any.whl (99 kB) Requirement already...

installing NVIDIA Apex for Python 3.8.5 and compatible with PyTorch 1.9

I am running a code that apparently requires NVIDIA apex (I initially didn't know and installed the wrong apex). I am unsure how to fix the final error: (proxy) [[email protected] proxynca_pp]$...

Getting import error while installing odoo 15

Traceback (most recent call last): File "/opt/odoo151/odoo/odoo/service/server.py", line 1196, in load_server_wide_modules odoo.modules.module.load_openerp_module(m) File...

Why can I not run matplotlib on Python 3.10?

My Issue. I am trying to run matplotlib on python 3.10 on my MacOS, but I get the following error: ModuleNotFoundError: No module named 'matplotlib' However, when I try running pip install...

Django mod_wsgi Apache Server, ModuleNotFoundError: No Module Named Django

I read ton of articles, but still can't figure out what I'm missing. I'm running a django website from virtualenv. Here's my config file. The website address is replaced by <domain.com>, can't use...

Failed building wheel for pillow

Trying to build a wordcloud in python. # Start with loading all necessary libraries import pandas as pd import matplotlib.pyplot as plt from wordcloud import WordCloud pandas imported just fine,...