oh-my-zsh themes don't show properly (background stays white)

I am trying to figure out why my oh-my-zsh themes don't work properly. The colors show up properly, but background stays white (with black text). below is my /.zshrc file and current path...

The command rbenv install is missing

In Ubuntu 10.04 I just installed rbenv. The install command is not present. rbenv 0.4.0-49-g8b04303 Usage: rbenv <command> [<args>] Some useful rbenv commands are: commands List all...

bundler/setup (LoadError)

I cloned a repository and tried to run rails s. However, I received the following error: /Users/me/.rbenv/versions/1.9.3-p547/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load...

pg gem install fails, cannot find libpq-fe.h header

Whenever I run bundle install on my VPS (CentOS Linux release 7.0.1406 (Core)) I get an error when installing the pg gem. No pg_config... trying anyway. If building fails, please try again...

Rails environment config: `method_missing': undefined method `action_mailer'

Attempting to invoke a Rails console (bundle exec rails c) or Rails server (bundle exec rails s) causes the following exception to be...

react-native: command not found

I am getting *-bash: react-native: command not found error* while creating react-native project. Below are the additional info 1. brew --version homebrew 0.9.9 2 brew info watchman watchman...

Error with ruby update

I tried to update my ruby and rails version. But I ended up with this error: ~ ruby -v /Users/Benjamin/.rbenv/shims/ruby: line 21: /usr/local/Cellar/rbenv/1.1.0/libexec/rbenv: No such file or...

vscode( vscode-ruby + rubocop ) how to auto correct on save?

Environments vscode Version 1.19.1 (1.19.1) rubocop (0.52.1) Darwin mbp 16.7.0 Darwin Kernel Version 16.7.0: Wed Oct 4 00:17:00 PDT 2017; root:xnu-3789.71.6~1/RELEASE_X86_64 x86_64 ruby...

Cannot load 'pry' - `require': cannot load such file -- pry (LoadError)

I'm trying to debug a simple ruby console script and am getting a load error when trying to require pry: I'm using rbenv to management environment. I'm using Ruby version: 2.3.1. Trying to use...

bundler: failed to load command: puma - Errno::EACCES: Permission denied - connect(2)

When I run [email protected]:/app$ /home/vagrant/.rbenv/shims/bundle exec puma -C /app/config/puma.development.rb -b unix:/var/tmp/app/sockets/puma.development.sock I get an error: [7159] Puma...

pyenv: python :command not found

I want to use Python3 with pyenv. $ pyenv root /Users/asari/.pyenv $ pyenv versions system 2.7.15 3.6.2 3.6.3 3.6.4 * 3.6.6 (set by /Users/asari/workspace/hoge/.python-version) $ python...

How to correct `Style/ClassVars` in RuboCop?

I see the issue with using class variables with Ruby; however, it seems RuboCop's documentation for how to fix the issue is not sufficient. Now, I could just ignore it. Given my project, it...

Fastlane is running version 2.114 instead of 2.110 after a reinstall

After uninstalling/reinstalling an older version of Fastlane, it still appears to be running the latest version. I recently updated Fastlane to version 2.114, but when I ran my ionic ios build...

ld: library not found for -lssl while installing mysql2 gem

I changed mysql2 version in my project's Gemfile from 0.3.20 to 0.5.2. When I run bundle update mysql2 I get the following error: Fetching mysql2 0.5.2 (was 0.3.21) Installing mysql2 0.5.2 (was...

rbenv install 2.6.3 BUILD FAILED

I want to use rbenv for first time, install it and initialize it, after using rbenv install 2.6.3 (this version is in my list. rbenv install --list) I have BUILD FAILED (error about clang3.0 and...

firebase_analytics: CocoaPods could not find compatible versions for pod "Firebase/Core"

I added firebase_analytics to my Flutter app and it works great on Android. When I go to build an iOS version I get a vague error when I build the app using Codemagic. It seems to build OK...

How do I resolve the message "No such file or directory" after installing rbenv on Mac OS?

When opening my Terminal and/or using an IDE to write code, I get the following message: -bash: export PATH="/Users/ryananding/.rbenv/shims:${PATH}" export RBENV_SHELL=bash source...

Avoiding extra lines in Ruby JSON.pretty_generate

I would like to produce JSON formatted like this: { "a": { "b": 1 }, "c": [ 2 ], "d": [], "e": {} } This is easy to do with the standard JSON support in Python,...

How do I fix .rbenv version with bundle install error in Jekyll? Reason: image not found

I keep getting this error: Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib (LoadError). I'm not sure how to fix this error. Apologies, I'm new to working with Jekyll and...

Cannot suppress Ruby 2.7.0 warnings

I followed the question here, specifically adding export RUBYOPT='-W:no-deprecated -W:no-experimental' to my .zshrc file. Despite doing this, I'm still getting loads of warnings....

Getting error "You've tried to invoke Spring when it's already loaded" when I try start server

I have started getting the following error when I try to run 'rails s' on my local machine: You've tried to invoke Spring when it's already loaded (i.e. the Spring constant is defined). This is...

Rails wikedPDF Error: PDF could not be generated

I'm trying to use WikerdPdf on rails 6 but I'm having this error RuntimeError (Failed to execute: ["/home/guilherme/.rbenv/versions/2.7.1/bin/wkhtmltopdf",...

Gem::Ext::BuildError: ERROR: Failed to build gem native extension. Keep getting this message when running bundler install in VScode

I am trying to run a bundler install on vscode for windows, but every time I do, I keep getting the same message: Fetching gem metadata from https://rubygems.org/....... Resolving...

libffi.so.6: cannot open shared object file in rails

I'm newbie in rails and I'm working on Ubuntu 19.10 yesterday I decide to upgrade my OS to new version every things is going fine after upgrading finished after t i start to use my computer to...

How do I fix this error: "Your bundle only supports platforms [] but your local platforms are ["ruby", "x86_64-darwin-19"], and there's no compati..."

When I run bundle install this is the response I get "Your bundle only supports platforms [] but your local platforms are ["ruby", "x86_64-darwin-19"], and there's no compatible match between...

Is the 'pathutil' ruby gem compatible with jekyll (v3.9.0) and ruby (v3.0.0)?

My problem: I have a jekyll-based static website; after running bundle exec jekyll serve (as directed by the jekyll docs) I get the stack trace below. The markdown file I've created for that blog...

Rails Error: Sprockets::FileNotFound in Users::Sessions#new

The following error occurred while executing the project after git clone, yarn install and bundle install. Error logs Sprockets::FileNotFound in Users::Sessions#new Showing...

undefined method `each_child' for #<Dir:0x00007fcc34ccf6e8> Did you mean? each_slice

Since I run flutter upgrade when I try to run my flutter app I get this error : [!] An error occurred while processing the post-install hook of the Podfile undefined method `each_child'...

Install older Ruby versions on a M1 MacBook?

Installing Ruby 3.0.x works fine on M1 MacBooks using rbenv or asdf. But older versions like 2.7.x and 2.6.x are having various issues. How do I fix them, without installing both x86 and ARM...

Can't install Python 3.10.0 with pyenv on MacOS

Trying to install Python 3.10.0 on MacOS 11.6 (Intel) with pyenv 2.1.0 (from homebrew) fails with: python-build: use [email protected] from homebrew python-build: use readline from homebrew Downloading...