Install MySQL gem for Ruby along with JRuby gem

I have the JRuby MySQL gem installed on my machine. However, for some reason I had to change to Ruby instead of JRuby and everything seems to be working fine except that the MySQL gem for Ruby...

Error Installing rails on Ubuntu 10.04

I am trying to install rails on Ubuntu 10.04. So far, I've executed these commands: apt-get install build-essential libapache2-mod-passenger apache2 rubygems ruby1.8-dev libopenssl-ruby gem...

How to Downgrade from Ruby 1.9.2 to Ruby 1.8.7 to run Rails 2.0.2

I want to downgrade the Ruby version I have installed(Ruby 1.9.2) on Ubuntu 10.04 OS so that I can use the appropriate version of Ruby 1.8.7 to run Rails 2.0.2. I am using the older version of...

unable to install passenger

i'm trying to set up a ruby on rails environment to run a website app (clocking it) unfortunely as I'm a kind of newbie lots of stuff going wrong :p this is what i got when i run...

Ruby on Rails install on ubuntu fail. I can has help?

I am trying to install Ruby, RubyGems, and the Ruby on Rails framework so that it will play nicely with my system. I am having issues with my installation. Could somebody help me? Here are the...

Entering Rails commands in Terminal, Help is returned

When I enter: $ rails server I get this returned for and rails commands entered: Usage: rails new APP_PATH [options] Options: [--edge] # Setup the application with Gemfile...

Tried many suggestions, how do I install mysql2 gem?

I'm trying to install a mysql2 gem on a ruby on rails app. I'm currently running Ubuntu 11.04 and this is the error I get when I run sudo gem install mysql2 or bundle install: Building native...

gettext no translations showed

I'm trying to install gettext on debian, it works perfectly on Wamp on my local computer, but not on the server. I did this for the install: apt-get install -V gettext I launch this: # apt-cache...

Installing Apache Passenger , Ruby Development Headers Not Found

I have a RoR app that needs to be hosted on Apache, so I have been trying to install Apache Passenger. When I run the following command: sudo passenger-install-apache2-module I get: Checking for...

ruby on rails use openid auth Exception

I use ruby-openid to allow auth with openid when i use ruby 1.8 with rails as below: ii rails 2.3.5-1.2+squeeze1 MVC ruby based...

Rails server does not start by command "Rails s"

I'm new to ruby and rails and i installed rails in to the ubuntu. but when i go to the start server by typing "rails s" it doesn't start and comes following message . but i can create a new...

rails - installed rails but can't create app "cannot load such file -- active_support"

I did sudo apt-get install rails and all seemed good. Reading package lists... Done Building dependency tree Reading state information... ... Setting up ruby-actionmailer-2.3 (2.3.14-2)...

Installing Ruby on Linode Server

This linode guide provides instructions on how to install ruby on the server. The guide uses ruby 1.8 which is installed alongside other dependencies. How can I alter these commands to setup ruby...

rails install pg - Can't find the 'libpq-fe.h header

$ sudo bundle install Result Fetching gem metadata from https://rubygems.org/........... Fetching gem metadata from https://rubygems.org/.. Using rake (0.9.2.2) Using i18n (0.6.1) Using...

ubuntu 12.04 install fontforge No package 'zlib' found

1,when i try ./configure it says: checking for ZLIB... configure: error: Package requirements (zlib) were not met: No package 'zlib' found Consider adjusting the PKG_CONFIG_PATH...

Cannot install passenger due to Ruby development headers not found

Running rvmsudo passenger-install-nginx-module, I get: Checking for required software... * GNU C++ compiler... found at /usr/bin/g++ * The 'make' tool... found at /usr/bin/make * A download...

difficulty in installing ruby-bundler and update headers in ubuntu

I'm learning ruby on rails and therefore require installation of some gems for app. I'm trying to install ruby-bundler but getting errors. need some help.. i'll paste the commands i tried in my...

Installing a gem after native extension packages during chef execution

I am trying to install the fog gem in a chef recipe though the gem installation occurs before the native packages are being installed so the gem installation fails package "libxslt-dev" package...

debian apt packages hash sum mismatch

From the Debian command line, I'm getting a hash sum mismatch after executing aptitude update; aptitude upgrade. Below is the command line output. I've tried an aptitude clean, but this does not...

Install rgdal library in rstudio - GDALAllRegister not found in libgdal

I'm trying to install rgdal library in Rstudio (0.97.332), using Ubuntu 12.10 (quantal) and R 2.15.1 (Roasted Marshmallows). I have the following installed regarding gdal in Ubuntu: $ apt-cache...

/bin/sh: 1: gdk-pixbuf-config: not found

I am trying to compile a C/C++ program which is based on gdk-pixbuf, during compilation i get error "/bin/sh: 1: gdk-pixbuf-config: not found" I got below packages currently, kindly guide, what i...

Deploy Rails 3 with Phusion Passenger on Ubuntu WITH ALL GEMS INCLUDED

I need to deploy a Rails 3/Phusion Passenger/Apache2 app to an Ubuntu 12.04 server without installing ANY gems on the server. I can install any Debian packages. How can I include all needed gems...

Cannot run Jekyll on Ubuntu 12.04

I encountered this issue: gabriele @ osiris { ~ } [ ven nov 15 ] [ 12:57 ] > jekyll /var/lib/gems/1.8/gems/highline-1.6.19/lib/highline/system_extensions.rb:210: warning: Insecure world writable...

ERROR: Error installing nokogiri: ERROR: Failed to build gem native extension

I recently reinstalled rbenv as it helped with other issues. Now I receive a completly new issue with a particular project. Similar to issue already posted:...

Configuring puppet with passenger causing port conflict with apache2

I am new to puppet, so this might a simple issue that I am stuck with. While installing puppet I needed to use Proxy Certificate Traffic so that the agents can reach the CA master. I have Ubuntu...

Error in installation of rmagick [in rails 2.3.5]

I was trying to install rmagick gem in rails 2.3.5 . but I could not install as it shows error. Same error comes in both rvm and system. Building native extensions. This could take a...

update-alternatives: error: alternative path /usr/bin/gem1.8 doesn't exist

I am trying to install ruby1.8 on Ubuntu 14.04 so that I can be able to run a work application. When i run this command: sudo apt-get install build-essential ruby1.8-dev ruby-dev mysql-client...

How to fix Augeas dependency for Tomcat manifest?

I've the following puppet manifest which suppose to install and run Tomcat on port 8983: # tomcat.pp package { [ "tomcat7", "tomcat7-admin" ]: ensure => present } package { [ "augeas-tools",...

How do I make RGeo::Feature::Geometry methods available to RGeo::Geographic::SphericalMultiPolygonImpl?

I am using Rails 4.2 with PostGIS, rgeo and the activerecord-postgis-adapter gem on Ubuntu. I have also installed the following libraries: libgeos++-dev libgeos-3.4.2 libgeos-c1 libgeos-dbg...

How to install clang on ubuntu14.04

I want to learn llvm so I have to install clang in my ubuntu 14.04,but I encounter some problems.Here it is: when I execute command:sudo apt-get install clang-3.5 I just get some error message...