What does the "$" character mean in Ruby?

Been playing with Ruby on Rails for awhile and decided to take a look through the actual source. Grabbed the repo from GitHub and started looking around. Came across some code that I am not sure...

Heroku push rejected, failed to install gems via Bundler

I am struggling to push my code to Heroku. And after searching on Google and Stack Overflow questions, I have not been able to find the solution. Here is What I get when I try "git push heroku...

What's an appropriate way to override the view of a gem?

I thought it would be overkill to unpack the entire gem into my application. Is there a way to just override a single view it provides? This gem is spree_easy_contact which allows you to easily...

Understanding the Gemfile.lock file

After running the bundle install command, 'Gemfile.lock' is created in the working directory. What do the directives inside that file mean? For example, let's take the following file: PATH ...

JetBrains RubyMine 3.2.4 debugger not working

Running with Ruby 1.9.2 The IDE complains that The gem ruby-debug-base19x is required and offers to install it. However, upon attempting to install it it displays the message Failed to install...

"No such file or directory - getcwd" error on rubygems on Mac Os Lion

I'm trying to launch a heroku console that uses rubygems but I keep getting this error: /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:471:in `expand_path': No...

The compiler failed to generate an executable file. (RuntimeError)

I recently upgraded to OS Mountain Lion. A project I'm working on requires gem sys-proctable as a dependency, but when I run bundle install I get: Fetching gem metadata from...

Why do I get a "permission denied" error while installing a gem?

I'm attempting to install Jekyll. After running gem install jekyll I get this error: ERROR: While executing gem ... (Errno::EACCES) Permission denied -...

Failed to build gem native extensions of jquery-rails after installing Python 2.7

Using: Ruby: 2.1.1 Rails: 4 OS: Debian Wheezy Short problem story: I installed Python 2.7 and now my bundle install won't succeed anymore. It got stuck at: Using jquery-rails...

Ruby - TypeError: no implicit conversion of Hash into String

Trying to parse some JSON, byt why is text empty? Desired output: text should return Hello world\n\nApple, Harbor\n\nBanana, Kitchen\n\nMango, Bedroom text = "Hello world" json = '{"fruits":...

How to select columns from multiple table in rails?

I have two tables User and Order and association between those two table as follow. in User model has_many :orders, dependent: :destroy in Order model belongs_to :user I want to select all...

What are the default gems of Mac OSX 10.11?

I tried to study Ruby on Rails and followed a tutorial. However, I think I missed a part and I can't proceed to the next step in the tutorial, so I plan to uninstall things, including the gems I...

Installing unf_ext 0.0.7.2 not working

So when I try running bundle install --without production it tells me that I am getting an error and that I need to Make sure that gem install unf_ext -v 0.0.7.2 succeeds before bundling. I have...

extconf failed, exit code 1 error when installing [Ruby on Rails] 5 on OS X Yosemite 10.10.5

I'm trying to install Ruby on Rails v5 on OS X Yosemite 10.10.5, following the instructions on the rails site: http://railsapps.github.io/installrubyonrails-mac.html When I run this: sudo gem...

When is the 'require' necessary when using a ruby gem?

I noticed for some gems you must include it in the file where you want to use it like this require 'a_gem', but this is not always the case. I am going to compose a gem by myself. What should I do...

Using Ruby in an Elixir umbrella appp

I am running an Elixir umbrella app on Heroku. All is fine but one thing. I am using :erlport, github: "hdima/erlport" to run some Ruby code (asciidoctor-latex). This works locally but not on...

You don't have write permissions for the /Library/Ruby/Gems/2.3.0 directory. (mac user)

below is what I need to do. To run the specs, you'll need to install RSpec. First, run gem install bundler in the root directory of your project. Then, run bundle install. To run a single spec...

Error occurred while installing mini_racer (0.2.0)

I am using mac 10.14. I have some problem with mini_racer gem. After run bundle install the below error occurs. I don't know how can I solve this. Error Installing mini_racer 0.2.0 with native...

Commonmarker gem cannot be installed (needed for jekyll) macos

what do I have to do, is there a problem with dependencies? How do I fix those? I am on catalina. I repeatedly get this error and have already looked for the directory.. doesn't exist. sudo bundle...

Gitlab dpl issue with ruby version

I have a node app that I am deploying through Gitlab. I am using docker image node:12.8.0. Recently it has been failing deployment with the following error $ dpl --provider=heroku...

Running CocoaPods on Apple Silicon (M1)

I have a Flutter project that I'm trying to run on iOS. It runs normally on my Intel-based Mac, but on my new Apple Silicon-based M1 Mac it fails to install pods. LoadError - dlsym(0x7f8926035eb0,...

Problem with Cocoa Pods: undefined method `map' for nil:NilClass

I'm running Cocoa Pods on a MacBook Air with M1, with the lastest Mac OS Version. My Problem: When I run pod install I get following Output (I delete a bit, because other ways it would be to...

Ruby's mysql2 gem using incorrect database package (MariaDB instead of MySQL)

Using Windows 10 x64 and Ruby 2.7.4, trying to install the mysql2 0.5.3 gem. Normal installation fails, so I link the libraries manually. This gem was compiled using MySQL's C API (C Connector) v...

Unable to install json version 1.8.2 gem for Ruby version 2.5.3 on Ubuntu 20.04

I am trying to run a rails server and when I run the bundle install command, I get the following error: An error occurred while installing json (1.8.3), and Bundler cannot continue. Make sure that...

Gem install wrong number of arguments (given 4, expected 1)

When I run bundle, I get the following: -bash: bundle: command not found I'm not a ruby developer, but it seems like I need bundler to get some software running other people wrote. So I'm trying...

can't run flutter project on iOS simulator

I have been developing e-commerce app for about 3 months, I switched to MacOs recently. I have a problem when I run my code in iOS Simulator every time I run it I get this message. CocoaPods'...

Crash with cocoa pods env

I am following a tutorial to create an IOS app using a Google Maps with cocoa pods. The command pod install crashes. I am thinking of a env problem because the command pod env crashes... I have...

Powershell: Cannot find a variable with the name 'AmsiContext'

Summary Using Vagrant with Virtualbox and Powershell 5.* I get a message while running any vagrant commands. PS C:\Users\dharris\SparkleShare\vagrant-salt> vagrant up es-master Vagrant failed to...

Unable to install cocoapods on Catalina

I have catalina OS 10.15.7 and XCode Version 12.4 (12D4e) I am trying to install cocoapods using gem: sudo gem install cocoapods And I am getting this error: ERROR: While executing gem ......

Could not find 'minitest' (>= 5.1) among 39 total gem(s) (Gem::MissingSpecError)

I m trying to install Pod on my mac os (os version is big sure), and I m using Xcode 13.1 I m trying to install Pod with this command from terminal: sudo pod install then the system ask me...