vendor folder is not present in my docker image

I'm trying to build a deployable image of my laravel app into docker. Here is my dockerfile: FROM php:7.1.14-fpm ENV node_version 8.4.0 ENV npm_version 5.7.1 RUN echo "deb...

How can I prevent sentry from capturing events for some uncaught exceptions and logging messages?

As recommended by Sentry's docs [1][2] for their new unified python sdk (sentry_sdk), I've configured it with my Django application to capture events on all exceptions or "error"-level...

How to ignore a logger in the Sentry Python SDK

I'm using sentry-python SDK for capture exceptions from my django server. I don't want to capture django.security.DisallowedHost like above. How to remove sentry handling for that logger? I...

React Native, cloned repo has Reactotron code and now I would like to use it but no connection

So I cloned a React Native app from Github and noticed this package called Reactotron, what is that I wondered? I looked it up, it's like Redux DevTools, why not avail myself of its...

NuGet lock file fails to restore with --locked-mode

Roslyn gave us deterministic builds a few years ago. And with the addition of NuGet lock files, we can finally have guaranteed reproducible build. I'm looking at the docs that say I can opt-in...

docker does not installs the updated pipfile

I am using docker in my project. Initially there was following packages in Pipfile [packages] django = "*" djangorestframework = "*" celery = "*" whitenoise = "*" redis = "*" django-celery-beat =...

ld: library not found for -lRCTBlob clang: error: linker command failed

> Ld > /Users/ajaysivan/Library/Developer/Xcode/DerivedData/MyApp-fhlxfvymksoqhsglhalddkzaekrm/Build/Products/Debug-iphonesimulator/MyApp.app/MyApp > normal x86_64 (in target 'MyApp' from project...

This type of error comes:- Cannot find module 'sharp'

Error: Cannot find module 'sharp' Require stack: - D:\Marketing\sbj-react\suburban\node_modules\gatsby-plugin-manifest\safe-sharp.js -...

Firebase Crashlytics and Sentry do not work together? (iOS)

I have to work with 2 different SDKs which should report the Crashs. Once is Firebase Crashlytics and the other is Sentry. The second one I need in the company for different tools. With Firebase I...

node_modules/expo/AppEntry.js: Transformer.transform is not a function

I've been looking for a solution to this problem for a couple of days now and I think it has something to do with my upgrade to the latest version of expo. I've tried downgrading the SDK and expo...

Fresh init React Native Build has CompileSwiftSources normal x86_64 com.apple.xcode.tools.swift.compiler error on Xcode 12

Recently, Apple released Xcode to version 12, and after update from 11.7 to 12.0.1 all of the React Native applications cannot build on a simulator, even a fresh initialized React Native project...

cudaErrorInsufficientDriver: CUDA driver version is insufficient for CUDA runtime version

I am running GPU instance on GKE when everything is deployed I make the request to the service Above mention error occur I followed all the step in mentioned in...

Assets not showing when using expo:build for .apk after upgrading to SDK 39

I am updating app from Expo SDK 38 to Expo SDK 39. Everything goes smoothly it works perfectly in the Expo Client. When I build a standalone app for testing before submission with the...

TypeError: undefined is not an object (evaluating 'state.routes.find')

using createMaterialBottomTabNavigator, it has Component Exception at Tab.Navigator and message is TypeError: undefined is not an object (evaluating 'state.routes.find') The part that causes the...

Expo Android Application crashing on navigation.navigate()

The Android version of my React Native application is crashing on navigation.navigate() on both standalone builds and in Expo client. This is an Expo Managed Project FYI. This is what I've...

Invalid plugin specification moor_ffi Cannot find the `flutter.plugin.platforms` key in the `pubspec.yaml`

I upgraded flutter to the latest version and now everytime I try build I get this error. Invalid plugin specification moor_ffi. Cannot find the flutter.plugin.platforms key in the pubspec.yaml...

How to log error in catch statement in sentry

I am new to Sentry and I want to log an error manually. For some reason I am unable to find in their docs, how I can achieve this I am using RN project but from their docs, RN extends JS...

Conda - how to update only cudatoolkit in an existing environment?

This is a specific instance of a general problem that I run into when updating packages using conda. I have an environment that is working great on machine A. I want to transfer it to machine...

Failed to write manifest file.Error Domain=NSCocoaErrorDomain

I have react native expo app with Sentry configured. Sentry is reporting this crash. Error: Failed to write manifest file.Error Domain=NSCocoaErrorDomain Code=640 "You can’t save the file...

Saleor Platform running, storefront wont start the server

I've used the saleor platform method, with docker and dashboard and everything else works properly, but not the frontend, any idea how to debug this, this is the output of the last...

React native testing with Typescript and Jest

I am trying to start test with react-native/expo and typescript. I have created an app with the expo's basic typescript template. To start testing, I followed the expo's documentation on testing...

Crash on Android phone with expo, react Native and firebase

I'm doing an app in react Native, Expo and Firebase. I've got some crash when i test it on an Android phone. I recently use Test Lab from firebase to test my app and I've got this error: Your app...

Failed import for Sentry_sdk in Django

I am currently trying to get Sentry to work with my Django project. While initializing Sentry in the settings.py file I get this error: line 301, in module import sentry_sdk ModuleNotFoundError:...

How to make Jest testing work in a React Native (Expo) application that uses Firebase? ("addEventListener and attachEvent are unavailable")

For the past couple of weeks, I have built a simple React Native application on Expo that uses Firebase Firestore for storing user data. The basic functions of the app work fine, and now for the...

No handler function found for event: "changeText"

I am trying out the React Native Testing Library with Expo / Jest for the first time. Following the tutorials, I can get a simple button to work test("Simple Button", () => { const mockFn =...

Webpack code splitting: ChunkLoadError - Loading chunk X failed, but the chunk exists

I've integrated Sentry with my website a few days ago and I noticed that sometimes users receive this error in their console: ChunkLoadError: Loading chunk <CHUNK_NAME> failed. (error:...

Add additional details to a Sentry error using Python SDK

There are many situations where I know an error will occur and want to pass additional data to Sentry. I still want the exception to get raised (so the rest of my code stops) and I only want one...

apache-airflow-providers-google in MWAA

I tried to install apache-airflow-providers-google in MWAA but it seems that Airflow does not pick the library: Broken DAG: [/usr/local/airflow/dags/mi-framework/jobs/google_analytics/main.py]...

SSL Error for Sentry v2.10 with Laravel 6.20.27 (PHP v7.4.19)

I am using sentry (version 2.10) with Laravel v6.20.27 and PHP v7.4.19. I follow the same steps mentioned in the documentation...

Could not find a version that satisfies the requirement psycopg2

I'm working on CI for my Python + Django project. I have to use the python:3.9-alpine image. A weird error is popping in my CI pipelines: WARNING: Discarding...