Remove all non-essential Python packages from Linux system

Before I started using Anaconda to manage virtual environments for my projects, I installed all Python packages with: pip install <package> or worst sudo pip install <package> Now that I'm...

Sphinx is not recognising my markdown tables

I am using sphinx locally with .md files. When I add a table in the format: | something | something else | something more | | one | two | three | the text is getting parsed as a paragraph. I have...

one hot encoding for frequent values only

I am looking to do one hot encoding to a column, but only for those that are very frequent. All that are below a threshold T will be put in their own category. My strategy was to create a...

How to render HTML from markdown, which contains tables, using Sphinx

I have a *.md files which I am going to put into documentation with help of Sphinx. These files contains tables. The documentation said to do the following: pip install...

Include my markdown README into Sphinx

I would like to include my project's README.md into my Sphinx documentation like...

There is something wrong with my building app with py2app

It works well with $ python setup.py py2app -A, but not with $ python setup.py py2app. What should I do to solve the problem? Could you help me? The following is what's in my...

How to uninstall system Python's packages except for pip (for the best practice)

I'm trying to follow Python's best practice for environment settings as described below. https://averlytics.com/2017/08/06/virtual-environment-a-python-best-practice/ The whole point of the...

error importing backend from keras over tensorflow

After installing cuda 9, cudnn 7, tensorflow and keras, keras cannot find the backend. Running on Ubuntu. Any idea what to do? Thanks! Here are some outputs that may help find the problem: $...

Creating Tables in Sphinx while sourcing from Markdown

I am creating my SphinX document via sourcing from a MarkDown source file i.e. in my index.rst file I have: .. toctree:: :maxdepth: 2 :caption: Contents: myMarkDownText . . . in which...

Unable to import Keras Library

I am working on Artificial Neural Network Algorithm on a dataset. Below is the source of dataset I am using. Kaggle Dataset I have ran the code until Feature Scaling and it ran successfully...

jellyfish C package not appearing in conda environment

I have developed something using my home machines conda environment. I want to move this to a different user on the machine so I exported the environment to a environment.yml file. I done this...

Sphinx documentation and links to Markdown

I'm trying to use Sphinx to build some documentation from Markdown source. My conf.py is as follows... conf.py from recommonmark.parser import CommonMarkParser project = 'DS' copyright = '2018,...

Deciphering error message to understand package conflict

A coworker sent me a yaml file with information regarding the environment he uses to run his python scripts. When I try to install the packages with anaconda, I get this error: Solving...

Jupyter making 3D matplotlib graphs extremely small

Having read many of the posts on this site about resizing graphs and setting limits on graph sizes in Jupyter, I am virtually convinced there is something different when it comes to 3D...

Error during building of exe using cx_freez

I am getting: "import error :No Module named 'PyQt5.QtGui'" during the build. The code snippet for setup.py file and .py is below. Please take a look and suggest changes i need to make to either...

Python Dynamic Test Plan generation

I am using Sphinx for documentation and pytest for testing. I need to generate a test plan but I really don't want to generate it by hand. It occurred to me that a neat solution would be to...

TensorFlow issue with anaconda env

I made a CNN with TensorFlow to use it in the University Cluster. The CNN works fine on my Mac where I have an Anaconda env with TensorFlow 1.10, here all the packages I use in my working...

KeyError: 'collectstatic' When deploying the Django application to pythonanywhere

During the implementation of my Django application on pythonanywhere for the first time I encountered such an error. Previous applications with a very similar structure were able to be implemented...

Spyder 2.2.5 is giving "You should import from qtconsole instead.", ShimWarning

my issue, spyder 2.2.5 stopped running any code. first of all, I have wanted to install ipywidgets but I can't because of python 2.7.6. I updated python 2.7.6 to 2.7.12, then installed ...

Unable to install tensorflow on Win10 - ImportError: DLL load failed

Trying to run import tensorflow as tf but it failed. I just installed tensorflow but is not allowing to import it. This is the...

Could not connect mssql with django

I am trying to connect mssql server with django. I have created a database name "sample". I have a table named "Sales" in my models.py. In my settings.py I have edited my database section as...

beam.io.ReadFromPubSub - ImportError: No module named iam.v1

I have a simple beam pipeline in which I am reading data from pub sub and writing to a file. I am running it on direct runner, the code is as follows: pubsub_data = ( p ...

ERROR: You must give at least one requirement to install -- when running: pip install --upgrade --no-binary hdbscan

I am trying to install hdbscan in my PC which runs Windows 10 and has installed Python 3.6. My first attempt failed: (base) C:\WINDOWS\system32>pip install hdbscan --user Collecting hdbscan ...

I can't install Open CV

I am trying to install Open CV for this tutorial... https://www.youtube.com/watch?v=Hqf__FlRlzg&list=WL&index=4&t=2494s I have installed it and when I type pip list in the terminal it shows that I...

ContextualVersionConflict when importing guesslang package

When importing guesslang package, I've got ContextualVersionConflict error about html5lib package. ContextualVersionConflict: (html5lib 1.0.1...

ImportError: cannot import name 'downsample' while importing lasagne in python 3.6

I am getting the above error with the following import statements on Google Colab GPU: import argparse #import cPickle import _pickle as cPickle import time import os import numpy as np import...

Conda does not create environment

I am working on a shared project stored in bitbucket. I am trying to import the environment that it is used there. After I git clone, I have everything that I need in my PyCharm project folder....

Trouble installing turbodbc

I am attempting to install turbodbc on my Ubuntu 20.10 machine. My specs are as follows: pip 20.2.4, Python 3.8.5 , gcc (Ubuntu 10.2.0-13ubuntu1) 10.2.0 I have attempted the solutions provided in...

Invalid requirement

I converted the requirements of my project into a txt file with the method below. pip freeze > requirements.txt And I tried to load the generated txt file with the code below to test it, but I...

Sudden Tensorflow / Keras Google Colab dependency problems `AttributeError: module 'tensorflow._api.v1.compat.v2' has no attribute '__internal__'`

I have running a machine learning model (Matterport's Mask R-CNN) in google colab for a couple of weeks. All of a sudden today I am unable to run any of my notebooks due to I think some kind of...