npm update does not do anything

When I execute this code in my application folder where the package.json is located: npm update or npm update --save-dev it does not do anything. But when I do npm outdated is shows many outdated...

Build:Cannot find type definition file for 'node'

VS 2015 community edition (at home), npm 3.10, Angular 2 Im trying to pull get Angular2 setup within an ASP.Net MVC 5 app. The template I started with used an older version of Angular, so I...

How to start node server locally in electron app

I'm running a NG4-Electron application and now I want to start a local node js server (Express) when the electron app starts. I have a local folder named as local_server at the root of the...

What could cause an error related to npm not being able to find a file? No contents in my node_modules subfolder. Why is that?

I'm trying to run npm install in the angular project folder I got from ASP.NET Boilerplate and I'm getting an error that is "related to npm not being able to find a...

Node Sass does not yet support Windows 64-bit

I am running protractor UI automation project and try to run test with yarn test and received following build error Module build failed: Error: Node Sass does not yet support your current...

Could not find module "@angular-devkit/build-angular"

After updating to Angular 6.0.1, I get the following error on ng serve: Could not find module "@angular-devkit/build-angular" from "/home/Projects/myProjectName". Error: Could not find module...

npm run build on multiple environments without mention specified environment

I am using angular project with multiple environment. Whenever doing build taking so long time for single environment. How can i reduce it. I have added my project configuration...

error TS6200: Definitions of the following identifiers conflict with those in another file (@types/jasmine)

I am receiving the following error when attempting to build my project (using Angular CLI) ERROR in ../my-app/node_modules/@types/jasmine/index.d.ts(18,1): error TS6200: Definitions of the...

Angular 7:@angular/core/core has no exported member 'OpaqueToken'

Getting this error message on the build of a brand new project just created from Angular: ERROR in node_modules/@ngrx/store/src/ng2.d.ts(1,10): error TS2305: Module '"../../../@angular/core/core"'...

Could not find the implementation for builder @angular-devkit/build-angular:dev-server on ng serve command

I tried to update the angular CLI following this, but now I can't run my app. When I try to run the command ng serve, it gives me this error: Could not find the implementation for builder...

Module not found: Error: Can't resolve 'fs' in

Oke, I upgraded Angular from 6 to 8. But I stil get errors. I found on internet a solution that for a lot of users helped. But in this case it doesn't helped me. So my package.json file looks like...

The Angular Compiler requires TypeScript >=3.4.0 and <3.5.0 but 3.5.3 was found instead

I'm getting the following error when I do npm run build: The Angular Compiler requires TypeScript >=3.4.0 and <3.5.0 but 3.5.3 was found instead. I've tried following things separately: npm...

Definitions of identifiers conflict with those in another file

I'm updating an old component from Typescript 6 to 8. I've updated the Jasmine dependencies in the package.json, but now I'm getting an error: "Definitions of the following identifiers conflict...

How to get rid of the warning .ts file is part of the TypeScript compilation but it's unused

I Just updated angular to latest 9.0.0-next.4. I am not using routing but suddenly after updating I keep seeing this warning. How Do I remove this warning WARNING in...

Ng serve throwing @angular/core/core has no exported member 'eeFactoryDef'

Im getting like 50 errors that all say that angular/core/core has no exported member 'eeFactoryDef'. They come from different node_modules, for example angular/cdk, ng-bootstrap, ngx-pipes,...

Electron + Ionic + child_process

I'm building an electron app to run on Windows to move a robot. (The controlling device must be windows as requested by the customer) It's built in Ionic with typescript and I'm attempting to...

CORS error with MSAL, Angular and ASP.NET Core

I'm trying to build an ASP.NET Core webapi + Angular website where users can login using Microsoft personal or work or school email. I followed the instructions described...

Why am I getting blank page when deploying Angular Spring war file to Apache Tomcat

I am trying to package an Angular app together with a Spring Boot app as a war file so that I can deploy it to my Apache Tomcat server. I have built the angular app and copied the files to my...

Angular 9 "Error: This constructor was not compatible with Dependency Injection."

This weird error, that I don't remember seeing pre-Ivy, has popped up in the setup of a new app created with the latest Angular 9 CLI. Looks like it could be a bug with Ivy? Any ideas on how to...

TypeError: Cannot read property 'tapPromise' of undefined

I am using Angular Build Optimization in Angular 9 project and using below code for generating bundles but getting below error. I Google with the error but didn't find any concrete answer. As the...

How can I use aws-iot-device-sdk NPM module with Angular 11 ? (it throws fs, path, & tls errors on build)

I maintain an browser-based Angular app that was at version 5.6. This app has two components that subscribe to an IOT topic and listen for updates (no pub, just sub). We need to upgrade to Agnular...

Angular 10.2 build: Localized bundle generation failed: Cannot read property 'value' of undefined

I have a project build on Angular 10.0.11. I updated the project to 10.2 with npm update, but this resulted in multiple Unable to fully load [...] for source-map flattening: Circular source file...

Chart JS +ng2-charts not working on Angular+2

Hello developers i have been literally the whole day trying to implement charts on my proyect , but following the official docs there is not way i could rid off this error : ERROR in...

Why am I getting "no exported member" errors when attempting to upgrade Angular?

The issue I am trying to upgrade from Angular V9 to V11 and I'm struggling quite a lot with the the following errors Namespace node_module/@angular/core/core has no exported member...

Could not resolve dependency: npm ERR! peer @angular/[email protected]"11.2.8"

I am trying to get my app to deploy on Heroku. I was getting the "sh: 1: ng: not found" error but based on responses on here, I moved my @angular/cli, @angular-devkit/build-angular,...

Angular 12 aws-sdk 2.910.0 Error: Module not found: Error: Can't resolve 'util' in '.\.\.\node_modules\aws-sdk\lib'

Prior to moving from Angular 11 to 12 the following error did not occur and the application was able to use the aws-sdk library to access my S3...

Angular 6 to 12 Migration: Getting Multiple Warning: Css Minimizer Plugin: > Unexpected "$"

After migrating my angular 6 project to 12. I am getting multiple warning in terminal if in angular.json i set optimisation: false configuration then all issue get resolved but i don't want to...

Ionic 6. Google maps not being displayed after updating to cordova 10.0.0

As soon as updated cordova to version 10.0.0. My map view is just blank. No error is being thrown. I am sharing the Ionic info and dependency list below. I have tried creating a new API ke and...

After upgrading to Angular 12 getting Error: NGCC failed

I was working on Angular 8 project when the time came to upgrade it to Angular 12. Since I come exclusively from React environments, didn't think it would be this much of a hassle until I started....

This version of CLI is only compatible with Angular versions ^13.0.0, but Angular version 12.2.13 was found instead

My Ionic project was running fine a month ago. Today when I tried ionic serve or ionic build then I get the below error: My simple question is What CLI version is compatible with Angular version...