Webpack gives eslint errors while using npm link

I have a multi-package project set up, where I have one JavaScript package that relies on a TypeScript library. Initially I installed Sinopia and was reinstalling the library every time I made...

Why ESLint throws 'no-unused-vars' for TypeScript interface?

So, I have this piece of code in .ts file: import {MicroEventInterface} from '../Interfaces'; export default class MicroEvent implements MicroEventInterface { // code And ESLint throws this...

Prettier and eslint indents not working together

I traying setup my vim based typescript developing environment, but have an issue with indent management. Probably 'eslint' says: indent: Expected indentation of 2 spaces but found 4. after...

How to use static imports in Glitch?

For the life of me, I can't understand how to use ES6 static imports in a simple Glitch.com project. I found this project where someone uses a static import with no extra node modules or anything...

How to use ESLint TypeScript Airbnb configuration?

I try to install and use ESLint Airbnb configuration for TypeScript for several days and I cannot make it work. Can somebody give installation and configuration steps of a working configuration,...

How can I enforce filename and folder name convention in typescript eslint?

I am using eslint for typescript convention. And I checked this rule https://github.com/typescript-eslint/typescript-eslint/blob/master/packages/eslint-plugin/docs/rules/naming-convention.md which...

Nest js packaging hangs at build process of the serverless framework

So i did a fresh install of nestjs application and i am trying to add the serverless framework with it.I also added few of the packages to support the serverless framework { "name": "n1", ...

Cannot find module './App.svelte' or its corresponding type declarations

I have a setup that integrates electron with svelte along with typescript support. when I run the rollup script to compile svelte app, i am getting cannot find module ./App.svelte error as shown...

functions/lib/functions/src/index.ts does not exist, can't deploy Cloud Functions

When I try deploying my Firebase cloud functions I get the following error. Desired behavior: Deploy functions successfully. Error: Error: There was an error reading...

Rollup + Typescript + ESLint wrong warning

I created a project using Rollup which use Typescript and ESLint with the typescript-eslint plugin and it seems that ESLint is executed on compiled code. Here is my Rollup config : export default...

Netlify "build.command" failed for gatsby website

I've recently updated some plugins on my Gatsby website. It works fine locally but it is failing the deploy on Netlify. The error I'm getting is: "build.command" failed - Command was killed with...

How to resolve aliases in Storybook?

I have a React/Typescript project with Storybook. Storybook works great, but as soon as I start importing files with aliases, it crashes. Example: import Foo from "@components/foo" =>...

How to solve "Failed to load config "airbnb-typescript" to extend from." on Google Cloud Build?

TL;DR, the error: Step #0: Creating an optimized production build... Step #0: Failed to compile. Step #0: Step #0: Failed to load config "airbnb-typescript" to extend from. Step #0: Referenced...

How to use `mongoose-delete` plugin with NestJs and typescript?

I'm using Mongoose in NestJs library and want to use mongoose-delete plugin for all of my schemas. But I don't know how to use it with nestJS And Typescript. First i installed both mongoose-delete...

Saleor Platform running, storefront wont start the server

I've used the saleor platform method, with docker and dashboard and everything else works properly, but not the frontend, any idea how to debug this, this is the output of the last...

Vue 3: Module '"../../node_modules/vue/dist/vue"' has no exported member

After updating my npm packages, some of the imports from the 'vue' module started showing errors: TS2305: Module '"../../node_modules/vue/dist/vue"' has no exported member 'X' where X is...

ESLint Definition for rule 'import/extensions' was not found

I'm getting the following two errors on all TypeScript files using ESLint in VS Code: Definition for rule 'import/extensions' was not found.eslint(import/extensions) Definition for rule...

eslint / typescript: Unable to resolve path to module

My .eslintrc.json is: { "env": { "browser": true, "commonjs": true, "es6": true, "node": true, "jest": true }, "parserOptions": { ...

Error: Failed to load config "next" to extend from

I have a Nextjs app using jest and react-testing-library for the test, I add the .eslintrc file with npx .eslintrc --init command to my project. whenever I lint my project, I get the following...

" npx cap add ios" fails with error "Updating iOS native dependencies with pod install - failed!"

I just created a brand new Ionic app, using command "ionic start myApp blank" I added the necessary angular dependencies to get "ionic serve" working properly. I have installed capacitor using the...

ESLint: 8.0.0 Failed to load plugin '@typescript-eslint'

Could you help me, I've got this error when I try building a project? Oops! Something went wrong! :( ESLint: 8.0.0 TypeError: Failed to load plugin '@typescript-eslint' declared in...

Nx e2e cypress runner: values from cypress.env.json entries not overwriting same entries in cypress.json env object

I have an Nx powered angular project and am facing an issue where values supplied in a cypress.env.json file do not override corresponding entries in the env object of the cypress.json...

Typescript Box produces a union type that is too complex to represent

Rendering a Box produces the following error: Expression produces a union type that is too complex to represent.ts(2590) As I can see here, this is due to having both @mui/material and...

eslint Angular Strict Template Checks should show error

We recently migrated to a new project with many angular 11+ applications and libraries. We have angularCompilerOptions.strictTemplates: true set for all the applications. The problem is that we...

npx create-react-app not working -- everything is deprecated

Starting this morning, whenever I run the command npx create-react-app project-name, I am getting the below code block errors. I've tried: clearing cache, removing and reinstalling node, removing...

Create-react-app - ERROR in Plugin "react" was conflicted between ".eslintrc.json" and "BaseConfig"

After updating to CRA 5.0.0, I got this error on compilation process: ERROR in Plugin "react" was conflicted between ".eslintrc.json" and "BaseConfig »...

Using pnpm to install create react app shows warning

When installing dependencies for a create-react app(version 5.0.0) using pnpm dlx and pnpm import, i get a warning that peer dependencies should be installed. The dev environment for react spins...

Angular v13 Jest with nx test - SyntaxError: Cannot use import statement outside a module at Runtime.createScriptFromCode

I tried to follow every comment with a possible solution here to the letter. I relied on an example project on github as well which works perfectly. This also started to happen to me after...

error code ELIFECYCLE while running npm run build

I have built react app based on fuse react theme it is running fine in the dev environment by npm start but I'm getting error while making production build, running npm run build to make a...

TypeError: MiniCssExtractPlugin is not a constructor

[webpack-cli] TypeError: MiniCssExtractPlugin is not a constructor at module.exports (/home/andrey/smartadmin-app/webpack.config.js:70:9) at loadConfigByPath...