keybord shortcut to minimize all windows in Ubuntu 17.04

I want the keyboard shortcut to minimize all windows in Ubuntu and how to modify default shortcut in Ubuntu 17.04

How to resolve conflicting distributions in apt-get

When doing an apt-get update/upgrade I see that error W: Conflicting distribution: https://downloads.plex.tv/repo/deb public InRelease (expected public but got ) I was upgrading to Ubuntu Zesty...

LHAPDF: undefined symbol when running in Python

I'm trying to use the Python interface for LHAPDF, but I receive the following error message: Traceback (most recent call last): File "test.py", line 2, in <module> import...

How do I advertise AND browse mDNS from within docker container?

I'm trying to create a ubuntu 17.04 based docker container that can browse mDNS on my network (outside of the docker network) AND advertise on mDNS to my network (outside of docker network). I...

How to keep matplotlib (python) window in background?

I have a python / matplotlib application that frequently updates a plot with new data coming in from a measurement instrument. The plot window should not change from background to foreground (or...

How to specify to install oracle jdk instead of openjdk in sdk cli on ubuntu 17.04?

When using sdkman on uBuntu 17.04, I do not see an option to install the oracle jdk. How to specify to install oracle jdk using sdkman on uBuntu 17.04? $sdk list java ...

Can't change emulated performance of AVD in Android Studio

I can't change the graphics to software as I'm sure this is the fix for my AVD not launching. The option is greyed out (see screenshot). Has anyone has experience with this? I couldn't find...

Maven crashes when trying to compile a project "Error executing Maven."

I'm trying to compile a project that uses maven. Running mvn compile results in the following error: [ERROR] Error executing Maven. [ERROR] java.lang.IllegalStateException: Unable to load cache...

Unable to locate package libjasper-dev

I want to install opencv in ubuntu 17.04 and I know that the jasper library is removed from ubuntu 17.04 what should I do to complete install opencv correctly ??? I tried used this two below...

Understanding Heap graph from visualvm

I have a program which essentially reads many files (mixed PDF usually below 10 MB + XML size of Kb) from disk and upload them one at a time into a legacy system. I let it run under visualvm when...

ListUtil.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080, needed 0xdb80080)

For some reason, whenever I run any Perl module (like cpanm), I've been getting this response: ListUtil.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080,...

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct

I am trying to install rails on ubuntu 17.04 but it was giving an error. Then I tried to run other installations but the error was same. **E: dpkg was interrupted, you must manually run 'sudo...

Netbeans 8.2 can't edit persistence.xml

If I navigate to "Other Sources" -> META-INF -> persistence.xml then I get a GUI which is very annoying as it does not list my hibernate, or C3P0 properties. I just want an xml editor. To edit the...

laravel command not found setting path does not work

I am have installed laravel via composer using the following procedure in my Ubuntu 17.04 running on the latest Oracle Virtualbox: Steps: composer global require "laravel/installer" nano...

How to install Tidyverse on Ubuntu 16.04 and 17.04

I'm running Ubuntu 16.04 [now 17.04: see note in bold below] and R 3.4.1. I installed the latter this morning, so I presume it's the latest version. I want to install Tidyverse, which I've spent...

How can one access http://localhost/ using the command line

I installed apache2 on ubuntu and I want to check that it works by accessing http://localhost/. The problem is I installed ubuntu(17.04) server, so there is no web browser, only the command...

LocalDB is not supported on this Platform

I'm trying to launch .Net Core 2.0 application on Ubuntu 17.04. I developed it on Windows 10 before and it works well. The problem is that when I run dotnet ef database update I get the next...

lookup registry-1.docker.io: no such host

I have docker daemon running on my Ubuntu 16.4 server my server details: No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 17.04 Release: 17.04 Codename: zesty I'm...

Docker daemon/container real-time scheduling with Ubuntu (Linux) host

Before I begin, I was at two minds as to whether this question should be raised in SuperUser or Stackoverflow - apologies in advance if it's in the incorrect location. I have a docker container...

Ignore system headers in clang-tidy

tldr;> How do I hide warnings from system headers in clang-tidy? I have the following minimal example source file, which triggers a clang-tidy warning in the system headers: #include <future> int...

google cloud - permission denied when running dynamic inventory through ansible

I have followed the Google Cloud Platform Guide for Ansible (http://docs.ansible.com/ansible/latest/guide_gce.html) and I can successfully create an instance from a playbook, but when I try to run...

Does tensorflow or python have memory cleanup issues when using multiple models in loop?

I am working on a tensorflow model which takes pretty much RAM. It is executed iteratively to process given tasks. However, with increasing time the whole process starts consuming more and more...

Install Qt 4 ubuntu 17.04

I need to install Qt 4 in my computer to run a specific software. I've download Qt 4.8.6 from: https://download.qt.io/archive/qt/4.8/4.8.6/. I followed the steps from the link...

Matlab's VideoReader not working on Ubuntu 17.04

I have been struggling to get VideoReader working on Ubuntu 17.04. If I run a simple program: v = VideoReader('flame.avi') I get the following: Error using VideoReader/init (line 619) Could...

How to install GDAL in Ubuntu?

I've got Ubuntu 17.04 version installed and I want to install GDAL. I have tried several ways to install it, but always I've got an error. I have installed Python 2.7 and Python 3.6 but I want to...

Rubymine and yarn

I have an error with my RoR project when I try to start it using "Run" (shift+f10) But when I start the server using rails s in console, it works. ======================================== Your...

Classpath is empty. Please build the project first e.g. by running './gradlew jar -PscalaVersion=2.11.12'

I am not able to run a Apache Kafka service due to a failure while trying to start a Zookeeper instance. I have downloaded and tried it with all 3 availabe downloads at the official site. (binarys...

Error while installing php 7.2 in ubuntu 17.04

I got this error when run below command sudo apt install php7.2 php7.2-common php7.2-cli php7.2-fpm Reading state information... Done E: Unable to locate package php7.2 E: Couldn't find any...

How to fix "dial unix /var/run/docker.sock: connect: permission denied" when group permissions seem correct?

I'm suddenly having issues after an update of Ubuntu 18.04: previously I've used docker without issue on the system, but suddenly I cannot. As far as I can tell, the permissions look correct: $...

VSCode not using Vcpkg acquired libraries

For some reason, VSCode is not able to see headers inside Vcpkg's installed libraries directory. I am using CMake build system on Ubuntu 17.04. I am getting errors like: [GCC] GL/glew.h: No such...

Relevant tags