Static link libpng into a shared library

I've reduced the problem to this minimal test.c: #include "png.h" int function() { printf("%ld", (long)png_create_read_struct); } Compiling with gcc -shared -fPIC test.c -o test.so -lm...

Android Studio emulator: Process finished with exit code 139 (interrupted by signal 11: SIGSEGV)

My android studio emulator not starting. I'm using Android Studio 3.0 on Ubuntu 17.10 Error - Emulator: Process finished with exit code 139 (interrupted by signal 11: SIGSEGV)

VS Code will not build c++ programs with multiple .ccp source files

Note that I'm using VS Code on Ubuntu 17.10 and using the GCC Compiler. I'm having trouble building a simple program which makes use of additional .ccp files. I'm probably missing something...

gradle build for kotlin code

I'm trying to set up a project building Kotlin code with Gradle. I've followed instructions [here][1] on how to set up the build.gradle file but am receiving an error buildscript { ...

Azure App Service gives 503 Service Temporarily Unavailable

I am a total newcomer to the Azure cloud. I have this .net-core 2.0 app which runs locally on my development PC (Ubuntu Linux 17.10). I have followed this...

What is -no-pie used for?

I was working on Ubuntu 17.10 with GPROF for some testing with C files, and when I execute with gprof the file generated (gmon.out), compiling and linking with -pg option, I got an empty flat and...

Why does unittest require __init__.py to be present in Python 3.6?

I just come across this line in python3.6 unittest (/usr/lib/python3.6/unittest/loader.py:286): is_not_importable = not os.path.isfile(os.path.join(start_dir, '__init__.py')) which caused the...

How to run .Appimage on ubuntu 17.10

How to run .AppImage on ubuntu 17.10? I did cura-build from the following exec (AppRun and Appimagetool) files from https://github.com/AppImage/AppImageKit/releases ~cura-build/build$ make Copying...

SQLite Browser without SQLCipher support in Ubuntu

SQLite Browser package for ubuntu does not come with SQLCipher by default. sudo add-apt-repository -y ppa:linuxgndu/sqlitebrowser sudo apt-get update sudo apt-get install sqlitebrowser The...

"The "TransformWebConfig" task failed unexpectedly" on dotnet publish

I'm experiencing a problem when publishing an ASP.NET Core 2.0 Web Application. Actually the project is an open source template I'm building. You can check it out on:...

ImportError: No module named gtk

I have a PC running Ubuntu 17.10. I want to runn a python script that uses gtk. HoweverI get the following error: Traceback (most recent call last): File "/usr/local/bin/selectvm.py", line 3, in...

Errors "QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-mizu'" when running phantomjs from contab

When I run phantomJS with crontab, the following errors occur. How can I run it successfully? I am using Ubuntu 17.10. [error] QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to...

Access denied when pulling Docker image from a repository I own

I built a Docker image that I pushed to Docker Hub under my account and removed locally after. But when I try to pull it, it throws the following error: Error response from daemon: pull access...

Yarn add --dev returning --> yarn: error: no such option: --dev

I have looked at this post: https://stackoverflow.com/questions/45430645/yarn-error-no-such-option-with-dev-flag but it did not work for me. I did the npm install --global yarn and it did not...

How to set up devices for Visual Studio Code for a Flutter emulator

I'd like to use Visual Studio Code as my editor for Flutter development, but I don't know how to get the emulator going. I've installed Visual Studio Code on Ubuntu 17.10 (Artful Aardvark). I...

WebDriverException: Message: Service chromedriver unexpectedly exited. Status code was: 127

I'd like to construct my crawler using selenium on my server. Thus I had installed/download required dependencies- such as chromedriver, chromium-browser etc on my Ubuntu17.10 server However, when...

Android Studio 3.1: Erroneous unresolved references in editor

I'm running Ubuntu 17.10, and I've just updated Android Studio from version 3.0.1 to 3.1. Here's the version information in Help -> About: Android Studio 3.1 Build #AI-173.4670197, built on March...

Redis service is not starting

I built from source and installed Redis on my system following this digital-ocean guide. But after running $ sudo systemctl status redis I get this failed status report. ● redis.service -...

hdparm.conf settings don't seem to run at boot

I'm trying to get my HDD to spin down after boot, as I only use it occasionally for backing up and long term storage. I'm running Ubuntu 17.10. I've been searching for a while and found that I can...

.NET Core - RequireHttpsAttribute causes ERR_TOO_MANY_REDIRECTS on Ubuntu with Apache2

Using .NET Core 2.0 if I follow the official documentation to enforce HTTPS the website fails to load with the error ERR_TOO_MANY_REDIRECTS. Steps to reproduce: Create new .NET Razor App: dotnet...

Resetting mysql password results: ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

I keep getting the error: ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) When trying to connect to MySQL via terminal. I've done both...

Mongo shell not open in ubuntu 17.10

MongoDB shell version v3.4.7 connecting to: mongodb://127.0.0.1:27017 2018-05-10T10:54:49.810+0530 W NETWORK [thread1] Failed to connect to 127.0.0.1:27017, in(checking socket for error after...

cannot install redis-server on ubuntu 18.04

I have upgraded to ubuntu 18.04 from 17.10. The redis-server package cannot be fully installed. I looked at /var/log/syslog and it says ==> /var/log/syslog <== Jun 3 13:04:10 qaz-mko systemd[1]:...

How to create a desktop-entry for anaconda on Ubuntu 17.10?

I've recently installed anaconda3 in Ubuntu 17.10 (system environment). To run anaconda-navigator, I've to activate root for each time as Source ~/anaconda3/bin/activate root And to run it I've...

Xdebug not working on PhpStorm - PHP 7.2.10, Ubuntu 18.04.01

I was using Ubuntu 17.10 and everything worked. However, after a update to Ubuntu version 18.04 along with a clean install I can no longer get my Xdebug to work properly. I tried to implement...

how to debug: if mpi can't run across machine

I have around 20 servers, I use mpi to distribute my task across servers, all the server have the same version of OS (ubuntu 17.10), and all the package is installed with same scripts (of course,...

How to acquire a complete list of packages and versions for a particular Ubuntu series using launchpadlib

I am looking for some help (an example would be excellent) figuring out how to just acquire a list of package names for a certain version of Ubuntu. For example, using the web interface I could...

Installing python-ldap fails with lber.h file not found in ubuntu 17.10 even after installing devel packages

I am trying to install python-ldap package using pip. I am getting the below error while executing pip install python-ldap. I tried installing the package corresponding to ubuntu 17.10 ( Artful )...

Install .NET Core on Google Colab

I am trying to install .NET Core on Google Colab. I follow the instructions given (for Ubuntu 17.10): ! wget -q https://packages.microsoft.com/config/ubuntu/17.10/packages-microsoft-prod.deb !...

Apache2 periodically using 100% CPU

I am fairly new to managing my own servers and have a problem where some Apache2 processes hog 100% of the CPU. This lasts for about half an hour and a couple of hours later, it will start again....