What does shorthand "index >= 0 && count++" do?

I was killing time reading the underscore.string functions, when I found this weird shorthand: function count (str, substr) { var count = 0, index; for (var i = 0; i < str.length;) { index...

Node package ( Grunt ) installed but not available

I'm trying to build a github jquery-ui library using grunt, but after running npm install I still can't run the command according to the readme file. It just gives No command 'grunt'...

npm install not installing things at /usr/bin

I am trying to install SailsJS with: $ sudo npm install -g sails It works, install everything at /home/brunoluiz/npm/lib/node_modules/sails with the following log: /home/brunoluiz/npm/bin/sails...

npm install not installing latest version on GitHub

I have a module called 'sails-mongo' and I want to update it to the newest version using the following command: npm update sails-mongo --save I also tried uninstall then install again. I tried...

NPM install for packages not working

T hanks in advance for any help I can get. I am trying to install packages like grunt, bower, and yeoman using nodejs and the NPM in my mac OSX 10.8's terminal. I check node and NPM's versions to...

How can I run NPM without sudo?

I've been reading posts, trying to figure out how to run npm install without sudo. I also came across the following article but I think it's for an older version of NPM. I done the following which...

After odoo installation, either CSS nor JS are found

After a lot of tries, I could finally install odoo 8, however, when I connect to it, browser redirects to /web/database/manager and the HTML is loaded (the logo appears and in the title Tag...

npm install installing extra packages not specified in package.json

I have a fairly typical package.json on an AWS ec2 instance. I'm running npm install and instead of installing { "name": "angular-app-server", "description": "Back end server to support our...

Number formatting in template strings (Javascript - ES6)

I was wondering if it is possible to format numbers in Javascript template strings, for example something like: var n = 5.1234; console.log(`This is a number: $.2d{n}`); // -> 5.12 Or...

Unable to start odoo 8 getting bootstrap 404

I want to use eclipse for odoo development. So I had gone through this link, https://www.odoo.com/forum/how-to/developers-13/how-to-debug-odoo-in-eclipse-under-winows-36105 But odoo is not...

How do I install appium on Ubuntu?

I am having trouble installing appium on Ubuntu. I tried the normal apt-get install way and found out that I should not be doing that. So I uninstall node, and appium from apt-get and I tried a...

EPROTO: protocol error, symlink '../semver/bin/semver' when using ember new

I have a Vagrant virtual machine created with ubuntu/trusty64 box (it runs Ubuntu 14.04.3 LTS (GNU/Linux 3.13.0-66-generic x86_64)) with Ruby on Rails, Node.js (5.x, but previously 0.12) and Ember...

Angular2 Cli installation problems

I want to give a shot at angular 2 so I'm working to install angular2 cli now, but when I install it and then run ng new newapp , it awkwardly opens the command line and says something about 'mg'...

How to use underscore.string globally in a web page (with requireJS)

The documentation says once underscore.string included in my application, the library is available using s, __s global variables (http://epeli.github.io/underscore.string/#others), or within...

How to convert a local sql file to json with nodejs

I want to convert a local sql file ( backup.mysql, around 50mb ) to json format in node, I googled around on some plugins but no luck, most of them need a sql server to convert the data. Does any...

grunt installing unrequested dependencies

When I install grunt into a local folder it appears to be loading 88 dependencies I did not request. Is this normal? If I use a packages.json file and and perform an pm install it won't install...

npm ERR! user is not allowed to access package @gulp-sourcemaps/map-sources : @gulp-sourcemaps/map-sources

I am working with nodejs and 'Jenkins' every day now for the past few months. Without making any changes to my package.json. Building my project at 'jenkins' I get the following error...

Script loader not working in webpack 2

I'm upgrading to webpack 2 and had this file to load all...

403 Error for app folder in solution

I want to start angular2 with mvc 5. so i passed all required steps and installed npm like what you see in code: +-- @angular/[email protected] +-- @angular/[email protected] +-- @angular/[email protected] +--...

Electron + Angular 4 = two ways data binding not working

Each time we want to update the UI we are forced to use the zone.run() method and this in not an option since it's unintuitive and force devs to add more repetitive code. Here our main...

How to create Phaser.js site on Heroku?

I am trying to create a site on Heroku and I just have an HTML file that calls a javascript file https://github.com/abdalah/ZakInDaBox. I'm not sure if it's the package.json file or something...

Permission denied during npm install even though I run it as root

same as the title. I ran npm install as root but still getting permission error. what should I do? I never got into this type of situation. I tried chmod -R 777 *, chown nobody:nogroup -R * in the...

How to force DLL plugin to share a library?

I'm using the webpack config below to generate a "DLL" bundle. What I can't figure out is why jquery-validate won't use the same copy of jquery from the same entry-point. The code that webpack...

Angular 2 to Angular 5 upgrade issue

I am trying to upgrade my Angular 2 Application to Angular 5 by following the instructions in this tutorial: https://vitalflux.com/how-to-upgrade-from-angular-2-to-angular-5-apps/ My project...

How do I deploy my Node.js app with a opencv4nodejs dependency to Heroku?

I am trying to deploy my Express Node.Js app to Heroku, but am running into issues with OpenCV in the build phase. I am using opencv4nodejs. I have the same issue with this thread at...

What is correct way to respond from webhook running nodejs?

Trying to implement web-hook (with V2 dialogflow) running nodejs. Received response "MalformedResponse 'final_response' must be set.". Below is the code. To the end of POST (app.post) code block...

Google Actions & Dialogflow v2 - webhooks

Background: I setup a simple DialogFlow to with two intents. Set as api v1 and webhook to a glitch server. I used glitch.com to host some js to gather information (requested by the...

bash: http-server: command not found

I am trying to run AngularJS project. I am unable to start the http server. I have tried multiple solution posted in the past. When perform npm list --depth=0 got following error on my project...

if I have source code and macOS and Windows installers for an app, how can I find what version of Node.js was used to build the app?

I need to build a new version of a javascript Node.js app. I have the source code and the macOS and Windows installers for the previous version of the app. How can I find what version of Node.js...

Version of TypeScript not officially supported by typescript-eslint-parser

I inherited an old AngularJs application which use the legacy tools: bower and grunt. When I run grunt serve --reload, I have the following warning message: WARNING: You are currently running a...