How is versioning supposed to work with the new Typescript 2 @types?

Instead of using typings, with Typescript 2 we're supposed to install dependencies in the @type namespace via npm. But the versioning seems to be a mess. For example, if I do an npm view urijs, I...

cordova wkwebview-engine-localhost plugin returning 403 forbidden

I am trying to use the cordova wkwebview-engine-localhost plugin in my app to server up an exported inVison prototype. So far my project file structure looks like shown below : . ├──...

React app crashes in IE11

We have a react app based on the react-production-starter boilerplate. Our dev build runs fine in IE11, but for some reason our production build doesn't. We get the following error: Minified...

sourceMappingURL returns full path. How to switch it off?

I have my own Angular 2 library and trying to compile it with Angular2 official ngc compiler. Everything works fine but when I was inspecting code generated, I found sourceMappingURL returns full...

Error: ENOENT: no such file or directory ember-cli-shims/app-shims.js

I'm trying to rebuild a project with updated packages but run into this error: [[email protected] genesis]$ ember build cleaning up... Build failed. The Broccoli Plugin: [SourceMapConcat: Concat:...

How do I fix a "Vue packages version mismatch" error on Laravel Spark v4.0.9?

When I run npm run dev on a Laravel Spark v4.0.9 app, I get the following error: Module build failed: Error: Vue packages version mismatch: - [email protected] - [email protected] This may...

Error on start Ember project on new machine: Unexpected token import, define is not defined

I have existing Ember js project on 2 computers, but I have problems with installation on a new one. I do install on such way: git clone <repository-url> cd projectfolder npm install bower...

npm install - ERR! addLocal Could not install on Windows 10

I'm trying to install a new nodeJS project. I set node and npm as environment variable When I run command npm install, I got errors as below: What is my wrong? Update details of...

How to include URI.js library in a Angular2+ app?

I'm trying to find a way to include a third party library (urijs) in my angular2+ app. Below you'll find the files concerned. // package.json { ... "dependencies": { ... "urijs":...

NPM run watch cant find module webpack

I have a package.json which contains some packages. Once i use npm install it will install all the items required, but it also creates symlinks: /Users/donny/Sites/Homestead/node_modules/lodash ->...

Writing an object to the location.hash using Vue.js and URI.js

I have a list of items along with a filter. I'd like to store the filter options in the window.location.hash property, so that I have nice sharable urls. I am struggling to build a hash fragment...

Angular-CLI Code Coverage Issue

I have ejected my angular-cli project and cannot get any code coverage working. I have tried various packages and configurations and cannot seem to find the right combo. When I run npm run test...

Outlook Web-Add-In: Execute Function hangs

I am currently developing an Outlook Web-Add-In, which executes a JavaScript function when a button in the ribbon is clicked. Another button which shows the Task Pane works. The first button does...

tslint in visual studio shows linting errors for node_modules

I'm using Visual studio 2017 (15.5.1) and trying to get tsLint to work correctly. For some reason, i'm getting linting errors (in the visual studio Error List (Build+intellisense)) from all of...

TypeError: undefined is not a function with karma test but I get the expected result from the function itself

Here is my function: const retrieve = (options = {page: 1, colors: []}) => { const limit = 10; var page = options.page || 1; const offset = (page * limit)-10; ...

After deploying the approuter to cloud foundry, the app is getting crashed

I followed the steps on this blog and deployed the After I deployed the approuter to cloud foundry, the app is getting crashed. Below is the error log. 2018-04-11T15:26:11.61-0400...

Jest encountered an unexpected token with react-native

So I'm trying to write tests on my React Native app with Jest and TypeScript. While using old babel version everything worked fine, but because of some project problems we had to upgrade babel to...

My Webpack file-loader will not load my images from index.html

I am trying to have all my images export into my lib folder (our equivalent of dist) once I run a webpack build. The file-loader successfully loads all the images in the css, but not from the...

Error: Cannot find module cross-env using nodemon

I have installed nodemon in my app , when I run npm run prod I get the following error module.js:550 throw err; ^ Error: Cannot find module 'C:\Users\jelly\lavalite-new\cross-env' at...

Why does webpack dev server server CSS bundles with text/html MIME type?

Because CSS served with text/html MIME type by webpack dev server on my development system, Chrome refuses to load them: Refused to apply style from...

Requires Babel "^7.0.0-0", but was loaded with "6.26.3" on a react-xml-parser package - already tried all the current solutions

I've already tried a lot of solutions given by the Github community about this matter, but none seems to work for me. /node_modules/react-xml-parser/dist/bundle.js: Requires Babel "^7.0.0-0", but...

yarn cannot build node-sass with node 12.1.0

I am trying to install my packages with yarn install I have node 12.1.0 installed, and as I understand, node-sass needs to be at least version 4.12+ to work with node 12 my package.json file is as...

Ignore types that reference a typescript library if not included in current project

In @types/urijs, there exists a type that references HTMLElement new (value?: string | URIOptions | HTMLElement): URI; Is there a way to ignore the HTMLElement type if I do not want to include...

Karma tests which run to successful completion in Angular 7 (Karma 2.0.4) fail after Angular 8 (Karma 4.1.0) upgrade

We have a suite of ~1100 units running in ’ng test’ which currently run to completion in ~4 minutes with no failures in Angular 7.2.5 and fail to run to completion with random failures,...

SDK 32.0.0 is not valid SDK

My application is built in sdk 32.0.0 and previously its working fine but its giving me error if i upgrade app into 33.0.0 so face many of issues like unable to load node modules or localization....

Xcode 11 Module AppRegistry is not a registered callable module (calling runApplication)

I recently upgraded (painfully) from react-native 0.59.10 to 0.61.2 and when I build and run thru Xcode 11 the splash screen loads but then errors show up in the console and the app doesn't...

Parcel build & IE11: regenerator-transform fails because it finds a for-of statement (ForOfStatement) within a generator

I try to build a small app based upon Webex web SDK, internally requiring regenerator-transform. Here is my package.json simple file: { "scripts": { "serve": "yarn build", "build":...

CDN: trunk URL couldn't be downloaded in certain React Native project when running "pod install"?

I have this react native project that im working with multiple computers, in my MacBook everything works fine, when I run "pod install" after running "npm install" the pods project is created...

Expo SDK40 upgrade TypeError: undefined is not an object (evaluating 'inspect.custom')

upgraded Expo SDK along with referring to the “Deprecations, renamings, and removals” section of the SDK 40 upgrading post from SDK39 to SDK40 and got an error. expo diagnostics Expo CLI...

Version of TypeScript not officially supported by typescript-eslint-parser

I inherited an old AngularJs application which use the legacy tools: bower and grunt. When I run grunt serve --reload, I have the following warning message: WARNING: You are currently running a...