Electron failed to install correctly, please delete node_modules/ and try installing again

I am trying to use webpack + react + electron, and when I type in the CLI "electron ." it gives me this error: I deleted node_modules and re-installed all the modules over and over like about 6...

Jest Test Babel Error: Plugin/Preset files are not allowed to export objects

I'm using a very up-to-date (December 2017) stack of dependencies. As I try-out isomorphic react tests with Jest, the test suit keeps failing with the following error: * Test suite failed to...

Vue.js two different main Layouts

I am using vue.js version 2.5.13 installed with the vue-cli using the webpack-template. Now I would like to use the generated App.vue-template for all my public pages and another template...

Webpack error: Invalid configuration object. Webpack has been initialised using a configuration object that does not match the API schema

I have upgraded my web application's packages, this upgrade seems to have broken my build. I first received an error telling me to install the webpack CLI, The CLI moved into a separate package:...

Node Sass does not yet support Windows 64-bit

I am running protractor UI automation project and try to run test with yarn test and received following build error Module build failed: Error: Node Sass does not yet support your current...

TypeScript 2.8: preact and react in one compilation

According to below site, I thought I can use preact and react both in one compilation. But when I'm trying to use these libraries together in one compliation there is a conflict. I think preact...

install bootstrap on angular project

Hi i hav latest angular cli in my machine. i have tried to install bootstrap on angular project. These are the steps i have followed . ng new Demo npm install bootstrap jquery --save Then open...

ngRx inherited Effects classes not working

I have two applications in a mono-repo, one will be a free subset of the other, so all of the functionality in the free one is included in the not-free one. I'm trying to set up my Effects so that...

Could not find an NgModule. Use the skip-import option to skip importing in NgModule

I get the error in the subject of this post when I use the CLI to create a new component: ng g c my-component --project=my-project (No component is created) I've seen other posts with the same...

npm start is giving webpack cli error with React.js

I have just started learning react.js from this site tutorailspoint and React.js. After following all the setup information when I run this command npm start this give the error...

TypeScript - [Subsequent property declarations must have the same time] - Multiple references to the same type definitions

I'm rather new to using TypeScript and Webpack and unfortunately keep running into an issue with my type declarations that I just cant seem to resolve. To put it simply my project is a ASP.NET MVC...

Ionic 4: Cannot GET /

Why do I get this error? I run the following commands in cmd: ionic start pollito tabs cd pollito ionic server CMD: [INFO] Browser window opened to http://localhost:8100%21 [ng] i ï½¢wdmï½£:...

Cannot fix "Unexpected token name «i», expected punc «;»" from UglifyJs

I have created a react app with a custom next server server.js: const { createServer } = require('http'); const next = require('next'); const app = next({ dev: process.env.NODE_ENV !==...

The Angular Compiler requires TypeScript >=3.4.0 and <3.5.0 but 3.5.3 was found instead

I'm getting the following error when I do npm run build: The Angular Compiler requires TypeScript >=3.4.0 and <3.5.0 but 3.5.3 was found instead. I've tried following things separately: npm...

Angular 9 "Error: This constructor was not compatible with Dependency Injection."

This weird error, that I don't remember seeing pre-Ivy, has popped up in the setup of a new app created with the latest Angular 9 CLI. Looks like it could be a bug with Ivy? Any ideas on how to...

Mongoose $push typescript errors

It seems like some package upgrade with mongoose or @types/mongoose is now causing new typescript errors from mongoose $push, $pull, $addToSet, and $each operators. For example: await...

How to load Global scss files in storybook for angular app?

I am trying to load a custom global style file, theme-default.scss in storybook. Although my components are loading in storybook but styles are not being applied.I followed this tutorial...

ionic unit testing - the pipe 'date' could not be found

I have a component that uses pipe date in template. It works in emulator and browser. When executing unit tests - I get a Error: The pipe 'date' could not be found! For all test cases within that...

Angular: node_modules/@types/babel _traverse/index.d.ts(1137,43): error TS1109: Expression expected

I am currently stucked in very weird issue in Angular. I was working on one my branch a week ago it was fine and building correctly. But I don't know how it start complaing during 'ng build' below...

Getting [TS] errors for files inside the node_modules folder

I just wanted to start a new typescript project using webpack5 and webpack-cli. In my surprise I'm getting these errors: Errors: [email protected] ~/projects/project $ npm run build >...

How to correctly set optimization.splitChunks.automaticNameDelimiter value using Webpack chain syntax?

I'm looking to modify the splitChunks.automaticNameDelimiter Webpack setting when using Vue CLI vue.config.js settings, but I don't quite understand the required syntax. This default delimiter...

Passing in environment variables after upgrade to Laravel MIX 6

Before upgrade to Laravel-Mix 6: Laravel-Mix version: 5.0.9 (supports Webpack 4) NPM version: 6.14.5 With this laravel mix version I was able to pass in environment variables to webpack.mix.js...

'npm run dev' suddenly broken, getting strange error

I logged onto my Mac today and tried to start up a next.js server on an on-going project and I am getting some strange behaviour with the log. 'npm run dev' fails to complete. I don't have the...

Empty runtime config for firebase functions when running locally

So i'm getting the infamous empty functions config() when running functions locally 😡 Error I'm getting: It looks like you're trying to access functions.config().stripe but there is no value...

Vue - npm run serve command crashes because of webpack version (vue-cli-service, laravel-mix, webpack)

to explain my problem, I will start by saying that I am currently making a system in Vue with backend API Laravel (irrelevant). I am making them as 2 separate projects. My problem is in the...

can not install expo-cli?

I'm trying to install the expo-cli package from npm. But everytime I do it I get this error, and I don't know why is this happening? npm WARN deprecated u[email protected]: Please upgrade to version 7 or...

How to solve Module parse failed: Unexpected token (3:27) in Vue 3 project

After trying to clone my project from github, (Had to delete I locally). I started to get the following error. error in ./src/App.vue?vue&type=template&id=7ba5bd90&ts=true Module parse failed:...

Cannot read property 'text' of undefined at NodeObject.getText at getRequiredModulePath

Error occurs while generating browser application bundles (phase: setup). What can cause this error? Info from console: Generating browser application bundles (phase: setup)... TypeError: Cannot...

After upgrading to Angular 12 getting Error: NGCC failed

I was working on Angular 8 project when the time came to upgrade it to Angular 12. Since I come exclusively from React environments, didn't think it would be this much of a hassle until I started....

Vue 3 and Vuetify 3 Alpha: ValidationError: progress plugin invalid options

After creating a Vue 3 project, adding Vuetify 3 Alpha, when I run "npm run serve", this is the error I get. I tried without adding Vuetify 3 Alpha and the Vue 3 project starts fine, it's just...