debian apt packages hash sum mismatch

From the Debian command line, I'm getting a hash sum mismatch after executing aptitude update; aptitude upgrade. Below is the command line output. I've tried an aptitude clean, but this does not...

Run OpenGL on AWS GPU instances with CentOS

I need to execute some off-screen rendering program on AWS EC2 GPU instance with CentOS. However, while I found that Ubuntu is very easy to setup, I cannot let CentOS work properly. The goal is to...

Vagrant error : Failed to mount folders in Linux guest

I have some issues with Vagrant shared folders, my base system is Ubuntu 13.10 desktop. I do not understand why I have this error is something that is not right configured ? Is a NFS issue or...

Debian: dist-upgrade removes gnome and many other stuff

I am (was) running the Debian Sid and faced a major update problem few days ago. It was weekend and I was just going to upgrade stuff, did sudo apt-get update, then sudo apt-get upgrade. Then I...

Can't run vagrant up

Ok this is pretty simple: I'm on windows 10. I just downloaded Vagrant v1.8.0 and Virtualbox 5.0.12. All i did i just: vagrant init so my VagrantFile only contains this : Vagrant.configure(2) do...

Where can I find the QWebPage and pymongo in python3.4?

I'm working on some code that requires a number of packages from python qt 5. I get a missing package error upon importing the QWebPage module: from PyQt5.Qt import QWebPage,...

bitbake: how does the build system choose the recipe provided by more than one layer

The meta layer provide recipe: meta/recipes-graphics/x11-common/xserver-nodm-init.bb The meta-oe layer provide recipe: meta-oe/recipes-graphics/xserver-nodm-init/xserver-nodm-init_2.0.bb My...

do_rootfs: Can't install [email protected]: no package provides xserver-nodm-init

At first I run the command to see my layers: $bitbake-layers show-layers layer path priority meta .../poky-krogoth-15.0.0/meta ...

Net::HTTPServerException causing Chef to fail

I'm attempting to set up a Rails environment with Vagrant and Chef by following this guide. I've used it in the past with success. When I run vagrant up it fails, and (I think) this is the...

Gray screen with cross cursor in TightVNC

I am trying to VNC to a Ununtu 16.04 from windows 10. I am getting a textured gray screen with cross cursor. Below is my log file: Xvnc Free Edition 4.1.1 - built Feb 25 2015 23:02:21 Copyright...

Can't get openGL to link in ubuntu

This is my first question on stackoverflow. I've seen a few posts related to openGL on Ubuntu, but none seem to relate to the problem I'm having. For some reason whenever I try to build my project...

Run OpenGL on AWS GPU instances with Ubuntu

I'm trying to get opengl working for headless offscreen rendering on a Amazon p2 instance with Ubuntu Ubuntu Server 16.04. After instance creation I've installed the appropriate nvidia drivers...

waking up from pm-suspend results in full restart

Waking up from $ sudo pm-suspend results in anomalous behaviour depending on whether the laptop in connected to external power. The following scenarios have been tested to be...

How to fix broken apt-get on debian wheezy?

I'm using a debian wheezy at work. Packages are held in specific versions. My /etc/apt/sources.list contains lines like : deb http://mycompany.com/debian/debian-main/ wheezy main non-free...

Jenkins build job fails while installing a package

I'm working on a Jenkinsfile that should be able to perform e2e-Tests with protractor befor deployment. So i need to install several packages for a chrome-headless installation (Yes, I've checked...

Gitlab: build docker container, then use it for compilation

Heres my .gitlab-ci.yml stages: - containerize - compile build_image: image: docker stage: containerize script: - docker build -t compiler_image_v0 . compile: image:...

Rails & Docker: configure bundler to run bundle install in a docker build for Rails.4.2.6?

I am having so much trouble with docker. It seems to be a pattern. I have a dockerfile which installs Node.js and Yarn from source repositories fine. I install ruby from the get-apt repositories...

How do I get GTK based GUI in a Yocto project?

I am developing a kiosk type application using Yocto and a raspberry pi3. I have an hdmi touchscreen attached and have a USB keyboard attached for development only. My problem starts when I try...

What executable path should I give for geckodriver when using docker?

I have my geckodriver in the same directory as my Dockerfile. I have tried setting the executable_path for my webdriver to "./geckodriver", "geckodriver" and "/app/geckodriver" browser =...

Dockerfile apt-get install - 503 service unavailable

Does anyone have a robust solution to prevent periodic 503 service unavailable errors from apt-get in a Dockerfile? I've tried pointing to different mirrors in the /etc/apt/services.list file, but...

How to craft a Dockerfile for an image with NVIDIA driver/CUDA (support for tensorflow-gpu) and Python3 with pip?

I have been unsuccessful in creating a Docker image using a Dockerfile for an image which contains: Python3 and pip so I can use pip to install my Python application's package requirements and...

how to fix php-gd failing to install debian

i know this question has already been asked, but it didn't have an answer that worked for me and i cannot comment as i do not have enough reputation. I'm not able to install php-gd extension on my...

Start an Electron app at boot on Raspberry Pi 3 with yocto

I built an image with X11 using yocto for a Raspberry Pi 3 and a touchscreen. I can start my app built with Electron (chromium) by running commands manually in a serial session: export...

Unmet dependencies, Installing ROS indigo, ros-indigo-desktop-full

I am trying to install ROS Indigo on a Oracle VM VirtualBox machine, however, i came across this issue. When i try to run the command sudo apt-get install ros-indigo-desktop-full i get this...

CUDA 10.1 installed but Tensorflow doesn't run simulation on GPU

CUDA 10.1 and the NVidia drivers v440 are installed on my Ubuntu 18.04 system. I don't understand why the nvidia-smi tool reports CUDA version 10.2 when the installed version is 10.1 (see further...

Issues with xdotool

So I have been trying to sort out xdotool. I can get things like :~$ xdotool getmouselocation x:347 y:310 screen:0 window:90 and :~$ xdotool getdisplaygeometry 1366 768 but am receiving to...

Problems running openGL in a container

I am trying to containerize a QT-based GUI application (specifically, ITK-SNAP) with X11 forwarding. When I build an image (let's call it itk-snap:3.8) with the following Dockerfile # 16.04...

GCC version 4.9 has no installation candidate

I'm trying to install gcc version 4.9 on Ubuntu to replace the current version 7.5 (because Torch is not compatible with version 6 and above). However, even following precise instructions, I can't...

Hyper-V Ubuntu VM GPU pass-through - NVIDIA SMI - UNKNOWN ERROR

My environment is; Host: Windows Server 2019 GPU: NVIDIA RTX 2080Ti Guest system: Hyper-V Ubuntu Linux 20.04 I have done the GPU pass-through on my Host to dismount the GPU and mount it to my...

Pytorch cuda is unavailable even installed CUDA and pytorch with cuda. How to fix?

I'm trying to use pytorch with my GPU (RTX 3070) on my Windows machine using WSL2, but I couldn't get it work even though I followed the Nvidia guide...