How to setup OpenCL on AMD videocard with opensource driver?

I have read this link - https://wiki.debian.org/ru/AtiHowTo and decide to setup OpenCL. the r600g driver still have to load proprietary microcode into the GPU to enable hardware acceleration....

Vagrant error : Failed to mount folders in Linux guest

I have some issues with Vagrant shared folders, my base system is Ubuntu 13.10 desktop. I do not understand why I have this error is something that is not right configured ? Is a NFS issue or...

VBoxLinuxAdditions.run never exits with 0

I am trying to automate the installation of Virtualbox guest additions using Chef, however I am running into an issue where VBoxLinuxAdditions.run never exists with exit code 0. I always get exit...

Hardware Accelerated NVidia and Intel Graphics Together in Debian

I would like to use two xservers each running on a separate graphics card,in fact I'm using two monitors with two different graphic cards installed on my computer,like this...

Debian: dist-upgrade removes gnome and many other stuff

I am (was) running the Debian Sid and faced a major update problem few days ago. It was weekend and I was just going to upgrade stuff, did sudo apt-get update, then sudo apt-get upgrade. Then I...

Can't run vagrant up

Ok this is pretty simple: I'm on windows 10. I just downloaded Vagrant v1.8.0 and Virtualbox 5.0.12. All i did i just: vagrant init so my VagrantFile only contains this : Vagrant.configure(2) do...

Trying to configure Xvfb to run Firefox headlessly

I was following along this tutorial to configure Xvfb to run firefox headlessly. http://www.alittlemadness.com/2008/03/05/running-selenium-headless/ I'm running these commands in a docker image...

Where can I find the QWebPage and pymongo in python3.4?

I'm working on some code that requires a number of packages from python qt 5. I get a missing package error upon importing the QWebPage module: from PyQt5.Qt import QWebPage,...

Net::HTTPServerException causing Chef to fail

I'm attempting to set up a Rails environment with Vagrant and Chef by following this guide. I've used it in the past with success. When I run vagrant up it fails, and (I think) this is the...

How to fix broken apt-get on debian wheezy?

I'm using a debian wheezy at work. Packages are held in specific versions. My /etc/apt/sources.list contains lines like : deb http://mycompany.com/debian/debian-main/ wheezy main non-free...

Ubuntu make error : c/usr/bin/ld: cannot find -lX11

I am installing nbis finger print recognition library.. it have executed following commands ./setup.sh /opt/nbis/ --64 make config Both worked fine and executed completely make it It gives...

Ubuntu 16.04.3 intel skylake i915 external monitor not detected

My external monitor, connected via HDMI was working fine but now is not being detected (it says 'No video input'). I'm pretty sure I didn't make any changes to make it stop - it was working on the...

Jenkins build job fails while installing a package

I'm working on a Jenkinsfile that should be able to perform e2e-Tests with protractor befor deployment. So i need to install several packages for a chrome-headless installation (Yes, I've checked...

Ubuntu 18.04 libosmesa6 depends libglapi-mesa (= 18.0.0~rc5-1ubuntu1) but 18.0.5-0ubuntu0~18.04.1 is to be installed

Quite a few people encounter this issue, especially those who want to use Gym and Mujoco for reinforcement learning. The installation process is frustrating, but luckily some people spot part of...

Why does KMS drmModeSetCrtc() fail with permission denied while running in X11 session?

The title already implies the question, so what is blocking the execution from the sample program in this repo https://github.com/dvdhrm/docs/tree/master/drm-howto It's a simple program showing...

Can Selenium and Chrome buildpack installs be cached on HerokuCI?

I've just started using HerokuCI. I have a few Selenium tests so I've added buildpacks in my app.json. { "buildpacks": [ { "url": "heroku/ruby" } ], "environments": { "test": { ...

Debian bumblebee problems

I am on a clean minimal Debian Stretch install with just a couple of graphical packages installed. I instelled these: sudo apt install xserver-xorg-core xinit bumblebee-nvidia primus...

yocto core-image-sato gstreamer1.0-plugins-bad QA Issue

During building core-image-sato on Yocto sumo distro for pcDuino3 using meta-sunxi I get the following QA error during finalizing gstreamer1.0-plugins-bad: ERROR:...

Unable to Install Older Version of R

I am trying to install and older version of R (3.2.1), and am following the instructions on this page: https://www.miskatonic.org/2015/06/23/installing-r-from-source/ As suggested by the webpage,...

Rails & Docker: configure bundler to run bundle install in a docker build for Rails.4.2.6?

I am having so much trouble with docker. It seems to be a pattern. I have a dockerfile which installs Node.js and Yarn from source repositories fine. I install ruby from the get-apt repositories...

sudo apt update && sudo apt dist-upgrade 7 not upgraded

sudo apt update && sudo apt dist-upgrade Hit:1 http://ports.ubuntu.com/ubuntu-ports xenial InRelease Hit:2 http://ports.ubuntu.com/ubuntu-ports xenial-security InRelease Hit:3...

"do_populate_sdk:Could not invoke dnf. Command" in yocto warrior branch

While generating a SDK by bitbake -c populate_sdk core-image-sato, getting following error, ERROR: panther2-usb-1.0-r0 do_populate_sdk: Could not invoke dnf. Command...

Debootstrap script installs, but xorg only starts as root

My Devuan debootstrap scripts work, but xorg only wants to start if I am the root user. You might have heard problems with xorg a million times, but I can't see what I am missing. The scripts are...

CUDA 10.1 installed but Tensorflow doesn't run simulation on GPU

CUDA 10.1 and the NVidia drivers v440 are installed on my Ubuntu 18.04 system. I don't understand why the nvidia-smi tool reports CUDA version 10.2 when the installed version is 10.1 (see further...

Issues with xdotool

So I have been trying to sort out xdotool. I can get things like :~$ xdotool getmouselocation x:347 y:310 screen:0 window:90 and :~$ xdotool getdisplaygeometry 1366 768 but am receiving to...

Problems running openGL in a container

I am trying to containerize a QT-based GUI application (specifically, ITK-SNAP) with X11 forwarding. When I build an image (let's call it itk-snap:3.8) with the following Dockerfile # 16.04...

OpenCL and Radeon R4 Integrated Graphics

I have a Dell Inspiron laptop with an AMD A6-6310 (Radeon R4 integrated graphics) SoC. I am running Debian Sid (updated to the latest). From wikipedia I see that the R4 Graphics has 128 shader...

Docker xserver for NVIDIA opengl application (without X in host)

I am trying to create an image of Docker that runs a X server using a NVIDIA GPU for OpenGL headless application. (Could be used creating textures, running Unity3D without screen, etc). In this...

Unable to locate package vulkan for GPU Nvidia GeForce?

Why I can't install vulkan? Maybe because it's not compatible with my GPU Nvidia GeForce? @ubuntu:~$ sudo ubuntu-drivers devices == /sys/devices/pci0000:00/0000:00:1c.4/0000:09:00.0 == modalias :...

Unable to Build Docker Image Using GitHub Actions

I'm currently trying to build a Docker image using GitHub Actions (CI). I can successfully build it on my machine and multiple other x86_64 architectures which I believe GitHub Actions also runs,...